Power: Fail to set delay time when the value is 90 minutes

Bug #1827346 reported by ethan.hsieh on 2019-05-02
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Status tracked in Xenial
Bionic
High
Unassigned
Xenial
High
Unassigned
gnome-control-center (Ubuntu)
Low
Unassigned
Xenial
Undecided
Unassigned
Bionic
Undecided
Unassigned
Disco
Undecided
Unassigned

Bug Description

[Impact]

Fail to set delay time when the value is 90 minutes.

In cc-power-panel.ui, the value of 90 minutes is 4800 (80*60), not 5400 (90*60). When setting the delay time to 90 minutes, the UI will show "80 minutes" after reopening "All Settings". (Please refer to the photo in #1 and #2)

[Test Case]

1) Go to [All Settings][Power][Automatic suspend]

2) Set delay time to 90 minutes (On Battery Power or Plugged in)

3) Close [All Settings]

4) Reopen [All Settings][Power][Automatic suspend]

5) Check if the value is 90 minutes.

[Regression Potential]

Low. The value of 90 minutes is wrong. Just correct the value to 5400.

ethan.hsieh (ethan.hsieh) wrote :
no longer affects: oem-priority
no longer affects: oem-priority/bionic
no longer affects: oem-priority/xenial
ethan.hsieh (ethan.hsieh) wrote :

The attached patch has been accepted by upstream.
Please help to backport it to bionic and xenial.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report/patch. Could you include the changelog entry to your diff? Also it needs to be also SRUed to Disco by SRU rules (and current serie, but since it's part of GNOME that's probably fine to delay a bit until we do the next version update there)

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Also can you update the description to be properly SRU compliant? The testcase describes the incorrect case, it should describe what the result should be to verify that the fix works. Also it needs a regression potential section describing what could be impacted/need extra testing

ethan.hsieh (ethan.hsieh) wrote :

@Sebastien
The description has been updated.

description: updated
Sebastien Bacher (seb128) wrote :

Thanks, can you also update the debdiff to include the changelog and add one for each serie you target? (xenial, bionic, disco)

The attachment "0001-power-correct-the-value-of-90-minutes-to-5400.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Sebastien Bacher (seb128) wrote :
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Committed
ethan.hsieh (ethan.hsieh) wrote :
ethan.hsieh (ethan.hsieh) wrote :
ethan.hsieh (ethan.hsieh) wrote :
Sebastien Bacher (seb128) wrote :

Thanks, I've uploaded the xenial versions, some comments for next time

- the version you picked already existed in the archive so it was rejected (https://launchpad.net/ubuntu/+source/gnome-control-center/1:3.18.2-1ubuntu7)

you can read https://wiki.ubuntu.com/SecurityTeam/UpdatePreparation#Update_the_packaging for recommendations on how to version SRUs to avoid those issue

- could you please include some description in the patch? Ideally following DEP-3 from Debian, but otherwise taking the git commit (e.g https://gitlab.gnome.org/GNOME/gnome-control-center/commit/9a67cd08.patch) at least gives the commit id and description

- it's common to indicate in the changelog entry or patch name that it's a backport from an upstream commit, which helps to give confidence in the change

Bionic and Disco are next for upload (we might wait next week and see if we have other pending changes for those series though)

ethan.hsieh (ethan.hsieh) wrote :

@Sebastien

Please check the diff for xenial as attached.

Robie Basak (racb) wrote :

I don't see uploads for Bionic or for Disco?

Sebastien Bacher (seb128) wrote :

@Robie, bionic/disco are coming but we wanted to include extra fixes and we are waiting for an upstream point release for disco, do we need to block Xenial on those?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.32.2-1ubuntu2

---------------
gnome-control-center (1:3.32.2-1ubuntu2) eoan; urgency=medium

  * Restore revision 1:3.32.1-1ubuntu5 discarded by error

 -- Sebastien Bacher <email address hidden> Wed, 29 May 2019 12:50:31 +0200

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released

Hello ethan.hsieh, or anyone else affected,

Accepted gnome-control-center into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-control-center/1:3.32.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-control-center (Ubuntu Disco):
status: New → Fix Committed
tags: added: verification-needed verification-needed-disco
ethan.hsieh (ethan.hsieh) wrote :

The issue is gone after upgrading gnome-control-center to 1:3.32.2-0ubuntu1.

tags: added: verification-done-disco
removed: verification-needed-disco

The verification of the Stable Release Update for gnome-control-center has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.32.2-0ubuntu1

---------------
gnome-control-center (1:3.32.2-0ubuntu1) disco; urgency=medium

  * New upstream stable version, based on the Debian update (lp: #1830884)
    - Fix crash if a monitor has no preferred mode (lp: #1820861)
    - Set correct sleep value for the 90 minutes choice (lp: #1827346)
  * d/p/git_nightlight_translations.patch,
    d/p/0001-region-Fix-input-source-options-not-being-applied.patch:
    - remove those patches, the changes are in the new version

 -- Sebastien Bacher <email address hidden> Wed, 29 May 2019 13:23:07 +0200

Changed in gnome-control-center (Ubuntu Disco):
status: Fix Committed → Fix Released

Hello ethan.hsieh, or anyone else affected,

Accepted gnome-control-center into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-control-center/1:3.18.2-1ubuntu6.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-control-center (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Steve Langasek (vorlon) wrote :

Hello ethan.hsieh, or anyone else affected,

Accepted gnome-control-center into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-control-center/1:3.28.2-0ubuntu0.18.04.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-control-center (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
ethan.hsieh (ethan.hsieh) wrote :

The issue is gone after upgrading gnome-control-center.

---
Bionic: ubuntu-18.04.2-desktop-amd64.iso
Xenial: ubuntu-gnome-16.04.5-desktop-amd64.iso

tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: added: verification-done-xenial
removed: verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.18.2-1ubuntu6.1

---------------
gnome-control-center (1:3.18.2-1ubuntu6.1) xenial; urgency=medium

  * debian/patches/correct-value-of-90-minutes-to-5400.patch:
    - correct the value of 90 minutes to 5400 (LP: #1827346)

 -- Ethan Hsieh <email address hidden> Fri, 03 May 2019 11:14:24 +0800

Changed in gnome-control-center (Ubuntu Xenial):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.28.2-0ubuntu0.18.04.5

---------------
gnome-control-center (1:3.28.2-0ubuntu0.18.04.5) bionic; urgency=medium

  * debian/patches/git_monitor_configuration.patch:
    - display: backport fix for the apply button not being displayed in
      some cases (lp: #1823857)
  * debian/patches/git_suspend_value.patch:
    - really suspend after 90 minutes when that value is selected
      (lp: #1827346)

 -- Sebastien Bacher <email address hidden> Wed, 29 May 2019 16:37:03 +0200

Changed in gnome-control-center (Ubuntu Bionic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers