Backport to bionic a patch for improved fractional scaling

Bug #1823857 reported by Mitar on 2019-04-09
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Unassigned
Bionic
Undecided
Unassigned

Bug Description

* Impact
In some cases after a configuration chang ethe "apply" button is not displayed

* Test case
On a multimonitor setup, go to settings -> display and change the monitors layout and zoom factor, following a change a "apply" button should be displayed

* Regression potential
The change is in the monitor configurations logic, just make sure that changing resolution/layouts work correctly and is restored are a logout/login cycle

----------------------

I have been debugging why I do not get "Apply" button in Displays view when my primary monitor is on the left of the external monitor, but it appears when it is on the right. I traced the problem down to this issue and patch:

https://gitlab.gnome.org/GNOME/mutter/issues/412
https://gitlab.gnome.org/GNOME/gnome-control-center/merge_requests/346

Reading this issue tracker I see that some issues people are reporting my be connected to this problem. I would suggest, if possible, that this patch is backported to Bionic and its version of gnome-control-center.

Mitar (mitar) wrote :

I made this patch for myself and it solved the problem.

The attachment "scaling-displays.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Sebastien Bacher (seb128) wrote :

The issue is fixed in newer serie but indeed sounds worth backporting to BIonic

Changed in gnome-control-center (Ubuntu):
status: New → Fix Released
importance: Undecided → Low
description: updated

Hello Mitar, or anyone else affected,

Accepted gnome-control-center into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-control-center/1:3.28.2-0ubuntu0.18.04.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-control-center (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic

The fix for this bug has been awaiting testing feedback in the -proposed repository for bionic for more than 90 days. Please test this fix and update the bug appropriately with the results. In the event that the fix for this bug is still not verified 15 days from now, the package will be removed from the -proposed repository.

tags: added: removal-candidate
Mitar (mitar) wrote :

Sorry for the delay.

I have just now tested the package and can confirm that it works for me. I can resize/scale screens and move them around and I always get "apply" button I can use.

Mitar (mitar) on 2019-09-19
tags: added: verification-done verification-done-bionic
removed: removal-candidate verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.28.2-0ubuntu0.18.04.5

---------------
gnome-control-center (1:3.28.2-0ubuntu0.18.04.5) bionic; urgency=medium

  * debian/patches/git_monitor_configuration.patch:
    - display: backport fix for the apply button not being displayed in
      some cases (lp: #1823857)
  * debian/patches/git_suspend_value.patch:
    - really suspend after 90 minutes when that value is selected
      (lp: #1827346)

 -- Sebastien Bacher <email address hidden> Wed, 29 May 2019 16:37:03 +0200

Changed in gnome-control-center (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-control-center has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers