Different input sources per window not work

Bug #1822775 reported by Toan Nguyen on 2019-04-02
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Unknown
gnome-control-center (Ubuntu)
Medium
Robert Ancell

Bug Description

Ubuntu 19.04

The option to apply different input source for each window doesn't work (it automatically reset itself)

However, I manually change org.gnome.desktop.input-sources.per-window and it works.

Olivier Tilloy (osomon) wrote :

Confirmed. The setting can be changed in the "Region & Languague" panel:

    gnome-control-center region

(cog icon next to "Input Sources" section)

But this doesn't actually change the corresponding gsetting:

    $ gsettings get org.gnome.desktop.input-sources per-window
    false

affects: ibus (Ubuntu) → gnome-control-center (Ubuntu)
Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
tags: added: rls-dd-incoming
Olivier Tilloy (osomon) wrote :

The corresponding code was added at https://gitlab.gnome.org/GNOME/gnome-control-center/commit/a86cf1eca2734b5ce8b250a7b16db3328945cf42.

The problem is the call to g_settings_delay in setup_input_section (https://gitlab.gnome.org/GNOME/gnome-control-center/blob/master/panels/region/cc-region-panel.c#L1207): the corresponding call to g_settings_apply is never issued when changing the per-window setting.

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
tags: added: desktop-trello-import
tags: removed: desktop-trello-import
Changed in gnome-control-center:
status: Unknown → New
Changed in gnome-control-center (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
importance: Low → Medium
Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.32.1-1ubuntu3

---------------
gnome-control-center (1:3.32.1-1ubuntu3) disco; urgency=medium

  * debian/patches/0001-region-Fix-input-source-options-not-being-applied.patch:
    - Fix input sources per-window setting not being applied (LP: #1822775)

 -- Robert Ancell <email address hidden> Tue, 09 Apr 2019 14:27:07 +1200

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-control-center:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.