gnome-control-center won't install: Depends: colord (>= 0.1.30)

Bug #1821809 reported by Lucas Partridge
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Unassigned

Bug Description

This bug looks similar to https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1762256.

I noticed Settings has gone missing from my ubuntu 18.04. When I click on the spanner icon under the power icon in the top right nothing appears to happen. Attempting to install it fails with:

$ sudo apt install gnome-control-center
[sudo] password for lucas:
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 gnome-control-center : Depends: colord (>= 0.1.30)
E: Unable to correct problems, you have held broken packages.

This may have come about as a side-effect of trying to install simple-scan. I raised a question about that at https://askubuntu.com/q/1108407/103266 but it never got fixed. I couldn't resolve the error "Unable to correct problems, you have held broken packages". Any suggestions welcome, please.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gnome-control-center (not installed)
ProcVersionSignature: Ubuntu 4.15.0-46.49-generic 4.15.18
Uname: Linux 4.15.0-46-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.6
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Tue Mar 26 21:15:46 2019
InstallationDate: Installed on 2017-09-03 (569 days ago)
InstallationMedia: Ubuntu 16.04.3 LTS "Xenial Xerus" - Release amd64 (20170801)
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Lucas Partridge (oakwing) wrote :
Revision history for this message
Lucas Partridge (oakwing) wrote :

I don't think this is exactly the same as https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1762256 because when I try installing the tree of dependencies I get slightly different errors...

$ sudo apt install colord
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 colord : Depends: libsane1 (>= 1.0.24) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

$ sudo apt install libsane1
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 libsane1 : Depends: libsane-common (= 1.0.27-1~experimental3ubuntu2) but 1.0.27+git20180317-xenial0 is to be installed
            Recommends: sane-utils (>= 1.0.27-1~experimental3ubuntu2)
E: Unable to correct problems, you have held broken packages.

Revision history for this message
Sebastien Bacher (seb128) wrote :

> '(= 1.0.27-1~experimental3ubuntu2) but 1.0.27+git20180317-xenial0 is to be installed'

those versions are not ubuntu ones, you probably used a ppa or such? closing for ubuntu

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Invalid
Revision history for this message
Lucas Partridge (oakwing) wrote :

Thanks. Yes, I had installed a ppa for simple-scan a long time ago to fix a scanner issue but I thought I'd gotten rid of it. I have also just deleted all the ppas to do with that under /etc/apt/sources.list.d. But I still can't get gnome-control-center to run or be installed:

The following packages have unmet dependencies.
 gnome-control-center : Depends: colord (>= 0.1.30)
E: Unable to correct problems, you have held broken packages.

Do you have any idea how I can fix this please? I'm at a loss here.

Revision history for this message
Lucas Partridge (oakwing) wrote :

Also, shouldn't the user at least see an error message if you click on the Settings icon but nothing appears to happen?

Revision history for this message
Sebastien Bacher (seb128) wrote :

try to "sudo apt-get install libsane1/bionic libsane-common/bionic sane-utils/bionic" to go back to the ubuntu versions of those binaries

Revision history for this message
Lucas Partridge (oakwing) wrote :
Download full text (5.7 KiB)

You're a hero - thank you!

$ sudo apt-get install libsane1/bionic libsane-common/bionic sane-utils/bionic
Reading package lists... Done
Building dependency tree
Reading state information... Done
Selected version '1.0.27-1~experimental3ubuntu2' (Ubuntu:18.04/bionic [amd64]) for 'libsane1'
Selected version '1.0.27-1~experimental3ubuntu2' (Ubuntu:18.04/bionic [all]) for 'libsane-common'
Selected version '1.0.27-1~experimental3ubuntu2' (Ubuntu:18.04/bionic [amd64]) for 'sane-utils'
The following packages were automatically installed and are no longer required:
  linux-headers-4.15.0-45 linux-headers-4.15.0-45-generic linux-image-4.15.0-45-generic
  linux-modules-4.15.0-45-generic linux-modules-extra-4.15.0-45-generic
Use 'sudo apt autoremove' to remove them.
Suggested packages:
  hplip unpaper
The following NEW packages will be installed
  libsane1 sane-utils
The following packages will be DOWNGRADED:
  libsane-common
0 to upgrade, 2 to newly install, 1 to downgrade, 0 to remove and 0 not to upgrade.
Need to get 2,547 kB of archives.
After this operation, 7,216 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://gb.archive.ubuntu.com/ubuntu bionic/main amd64 libsane-common all 1.0.27-1~experimental3ubuntu2 [274 kB]
Get:2 http://gb.archive.ubuntu.com/ubuntu bionic/main amd64 libsane1 amd64 1.0.27-1~experimental3ubuntu2 [2,089 kB]
Get:3 http://gb.archive.ubuntu.com/ubuntu bionic/main amd64 sane-utils amd64 1.0.27-1~experimental3ubuntu2 [185 kB]
Fetched 2,547 kB in 1s (2,937 kB/s)
Preconfiguring packages ...
dpkg: warning: downgrading libsane-common from 1.0.27+git20180317-xenial0 to 1.0.27-1~experimental3ubuntu2
(Reading database ... 242195 files and directories currently installed.)
Preparing to unpack .../libsane-common_1.0.27-1~experimental3ubuntu2_all.deb ...
Unpacking libsane-common (1.0.27-1~experimental3ubuntu2) over (1.0.27+git20180317-xenial0) ...
Selecting previously unselected package libsane1:amd64.
Preparing to unpack .../libsane1_1.0.27-1~experimental3ubuntu2_amd64.deb ...
Unpacking libsane1:amd64 (1.0.27-1~experimental3ubuntu2) ...
Selecting previously unselected package sane-utils.
Preparing to unpack .../sane-utils_1.0.27-1~experimental3ubuntu2_amd64.deb ...
Unpacking sane-utils (1.0.27-1~experimental3ubuntu2) ...
Processing triggers for ureadahead (0.100.0-20) ...
ureadahead will be reprofiled on next reboot
Setting up libsane-common (1.0.27-1~experimental3ubuntu2) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for udev (237-3ubuntu10.15) ...
Processing triggers for systemd (237-3ubuntu10.15) ...
Processing triggers for man-db (2.8.3-2ubuntu0.1) ...
Setting up libsane1:amd64 (1.0.27-1~experimental3ubuntu2) ...
Setting up sane-utils (1.0.27-1~experimental3ubuntu2) ...
Adding user saned to group scanner
Processing triggers for libc-bin (2.27-3ubuntu1) ...
Processing triggers for systemd (237-3ubuntu10.15) ...
Processing triggers for ureadahead (0.100.0-20) ...
$

Then:

$ sudo apt install gnome-control-center
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  ...

Read more...

Revision history for this message
salman ali (salman8102) wrote :
Download full text (6.3 KiB)

i am facing same colord dependency problem in ubuntu 20.04 on the way of installing gnome control center
i tried the same solution which is mentioned above

"sudo apt-get install libsane1/bionic libsane-common/bionic sane-utils/bionic"

i got this:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Release 'bionic' for 'libsane1' was not found
E: Release 'bionic' for 'libsane-common' was not found
E: Release 'bionic' for 'sane-utils' was not found

so i replaced bionic with focal:

"sudo apt-get install libsane1/focal libsane-common/focal sane-utils/focal"

and it returned the given:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Selected version '1.0.29-0ubuntu5' (Ubuntu:20.04/focal [amd64]) for 'libsane1'
Selected version '1.0.29-0ubuntu5' (Ubuntu:20.04/focal [amd64]) for 'libsane' because of 'libsane1'
Selected version '5.8+dfsg-2ubuntu2' (Ubuntu:20.04/focal [amd64]) for 'libsnmp35' because of 'libsane'
Selected version '1.0.29-0ubuntu5' (Ubuntu:20.04/focal [amd64]) for 'sane-utils' because of 'libsane'
Selected version '1.0.29-0ubuntu5' (Ubuntu:20.04/focal [all]) for 'libsane-common'
Selected version '1.0.29-0ubuntu5' (Ubuntu:20.04/focal [amd64]) for 'sane-utils'
The following additional packages will be installed:
  libmysqlclient21 libsane libsnmp35
Suggested packages:
  hplip unpaper
The following NEW packages will be installed:
  libmysqlclient21 libsane libsane1 libsnmp35 sane-utils
The following packages will be DOWNGRADED:
  libsane-common
0 upgraded, 5 newly installed, 1 downgraded, 0 to remove and 0 not upgraded.
Need to get 5,095 kB of archives.
After this operation, 24.7 MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu focal/main amd64 libsane-common all 1.0.29-0ubuntu5 [277 kB]
Get:2 http://archive.ubuntu.com/ubuntu focal/main amd64 libmysqlclient21 amd64 8.0.19-0ubuntu5 [1,218 kB]
Get:3 http://archive.ubuntu.com/ubuntu focal/main amd64 libsnmp35 amd64 5.8+dfsg-2ubuntu2 [981 kB]
Get:4 http://archive.ubuntu.com/ubuntu focal/main amd64 libsane amd64 1.0.29-0ubuntu5 [2,404 kB]
Get:5 http://archive.ubuntu.com/ubuntu focal/universe amd64 libsane1 amd64 1.0.29-0ubuntu5 [14.2 kB]
Get:6 http://archive.ubuntu.com/ubuntu focal/main amd64 sane-utils amd64 1.0.29-0ubuntu5 [201 kB]
Get:1 http://archive.ubuntu.com/ubuntu focal/main amd64 libsane-common all 1.0.29-0ubuntu5 [277 kB]
Get:2 http://archive.ubuntu.com/ubuntu focal/main amd64 libmysqlclient21 amd64 8.0.19-0ubuntu5 [1,218 kB]
Get:3 http://archive.ubuntu.com/ubuntu focal/main amd64 libsnmp35 amd64 5.8+dfsg-2ubuntu2 [981 kB]
Get:4 http://archive.ubuntu.com/ubuntu focal/main amd64 libsane amd64 1.0.29-0ubuntu5 [2,404 kB]
Get:5 http://archive.ubuntu.com/ubuntu focal/universe amd64 libsane1 amd64 1.0.29-0ubuntu5 [14.2 kB]
Get:6 http://archive.ubuntu.com/ubuntu focal/main amd64 sane-utils amd64 1.0.29-0ubuntu5 [201 kB]
Get:1 http://archive.ubuntu.com/ubuntu focal/main amd64 libsane-common all 1.0.29-0ubuntu5 [277 kB]
Get:2 http://archive.ubuntu.com/ubuntu focal/main amd64 libmysqlclient21 amd64 8.0.19-0ubuntu5 [1,218 kB]
Get:3...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers