Changing sound output doesn't work in gnome-control-center 3.32

Bug #1817338 reported by Franck on 2019-02-22
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
High
Robert Ancell
Disco
High
Robert Ancell

Bug Description

In 19.04, HDMI sound stopped working after some upgrade.

The sink is somehow availalbe, but cannot be selected.
In gnome-control-center, HDMI output device is listed, but if I choose it, no configuration list appears (see screen capture attached).

aplay -l gives me:
~$ aplay -l
**** Liste des Périphériques Matériels PLAYBACK ****
carte 0: PCH [HDA Intel PCH], périphérique 0: ALC269VC Analog [ALC269VC Analog]
  Sous-périphériques: 0/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 3: HDMI 0 [HDMI 0]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 7: HDMI 1 [HDMI 1]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0
carte 0: PCH [HDA Intel PCH], périphérique 8: HDMI 2 [HDMI 2]
  Sous-périphériques: 1/1
  Sous-périphérique #0: subdevice #0

pavucontrol shows HDMI as unplugged.

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: pulseaudio 1:12.2-2ubuntu1
ProcVersionSignature: Ubuntu 4.19.0-13.14-generic 4.19.20
Uname: Linux 4.19.0-13-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.10-0ubuntu21
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: franck 5998 F.... pulseaudio
 /dev/snd/pcmC1D0c: franck 5998 F...m pulseaudio
 /dev/snd/controlC0: franck 5998 F.... pulseaudio
CurrentDesktop: GNOME
Date: Fri Feb 22 16:16:56 2019
EcryptfsInUse: Yes
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: pulseaudio
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/27/2017
dmi.bios.vendor: LENOVO
dmi.bios.version: G7ETA9WW (2.69 )
dmi.board.asset.tag: Not Available
dmi.board.name: 2353CTO
dmi.board.vendor: LENOVO
dmi.board.version: Not Defined
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvrG7ETA9WW(2.69):bd09/27/2017:svnLENOVO:pn2353CTO:pvrThinkPadT430s:rvnLENOVO:rn2353CTO:rvrNotDefined:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.family: ThinkPad T430s
dmi.product.name: 2353CTO
dmi.product.sku: LENOVO_MT_2353
dmi.product.version: ThinkPad T430s
dmi.sys.vendor: LENOVO

Franck (alci) wrote :
Daniel van Vugt (vanvugt) wrote :

It's expected that HDMI output has fewer configurable options.

Can you explain in different words what's not working? Do you have speakers connected to your HDMI monitor that have stopped working?

Changed in pulseaudio (Ubuntu):
status: New → Incomplete
Franck (alci) wrote :

Ok, trying to rephrase the problem :-)

I have a laptop (Thinkpad T430s) hooked on a dock, then an HDMI monitor with embedded speakers (Asus MX27AQ) on the dock.

Before upgrading to 19.04 ongoing release, I was able to choose HDMI speaker as sound output, from the sound setting in Gnome shell.

Now, I can't get sound on the monitor anymore, only laptop speakers are working.

If I choose the HDMI/Displayport option in the gnome sound settings, it wont change anything.
When this option is selected, if I click on the test button, it will display a window with "click a speaker to test", but NO speaket to choose from (only the "user" icon).

Hopes this is helpful to define the bug more accuratly...

Daniel van Vugt (vanvugt) wrote :

OK. Since this version of PulseAudio hasn't really changed since October I suspect what changed for you was the recent redesign of gnome-control-center's Sound panel (or a kernel change).

What version did you upgrade from where it was working?

Can you please try live booting 18.10 and tell us if that has the same problem?
http://releases.ubuntu.com/18.10/

Franck (alci) wrote :

I can confirm it works when booting a live 18.10 session.

As to tell exactly when it broke, it's kind of hard, but it was near the beginning of february...

Thanks. This bug has been reassigned to gnome-control-center.

summary: - HDMI sound output not available
+ HDMI sound output not available in 19.04 (but works in 18.10)
summary: - HDMI sound output not available in 19.04 (but works in 18.10)
+ HDMI sound output not selectable in 19.04 (but works in 18.10)
Changed in pulseaudio (Ubuntu):
status: Incomplete → Invalid
Changed in gnome-control-center (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
importance: Undecided → High
Tim Lunn (darkxst) wrote :

I had the same issue a few weeks ago, now however with 3.31.92 (on Disco) I do get the configuration dropdown when selecting my HDMI Audio device. It came up blank initially, but appears to have saved the correct setting since.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Silvio Bierman (sbierman) wrote :

I have the same bug. I used to work around this by installing an alternative sound device selector shell extension but this one broke down when Gnome shell upgraded to 3.31.91. So now there is no way for me to switch to HDMI output any more.

The select box shows the correct devices but selecting a different one has no effect. It is also not saved and when reopening control center the default device is once again selected.

Julian Andres Klode (juliank) wrote :

FWIW, the same seems to apply to me, but not just HDMI.

I have:

* Digital output on external DAC
* Analog output on external DAC
* HDMI
* Speakers

I can change as I want to, the active output device does not change.

I think it's the same for recording devices, seeing as pacmd stat lists the same source before and after a change.

Julian Andres Klode (juliank) wrote :

Opening pavucontrol after changing the setting in gnome-control-center switches it half of the time, so there seems to be a problem in pulseaudio with listening to changes and applying them.

tags: added: desktop-trello-import
tags: removed: desktop-trello-import
Changed in pulseaudio (Ubuntu Disco):
status: Invalid → New

Tested with a cheap in-ear headphone
- when connecting it, gnome-shell prompts to use it, that works
- opening g-c-c 3.32, changing the output to the laptop audio and trying test still output to the headset
- closing/reopening g-c-c, the headset is selected
- installed pavucontrol, changing the device in g-c-c doesn't lead to a change pavucontrol
- enable cosmic apt source and install gnome-control-center/cosmic
- there selecting the laptop output makes pavucontrol updates immediatly, the sound stop outputing through the headset (but doesn't go to the speaker, which seems another bug)

-> seems like a g-c-c issue, closing the pulseaudio component one

Changed in pulseaudio (Ubuntu Disco):
importance: Undecided → High
status: New → Invalid
Changed in gnome-control-center (Ubuntu Disco):
status: Confirmed → Triaged
summary: - HDMI sound output not selectable in 19.04 (but works in 18.10)
+ Changing sound output doesn't work in g-c-c 3.32
no longer affects: pulseaudio (Ubuntu)
summary: - Changing sound output doesn't work in g-c-c 3.32
+ Changing sound output doesn't work in gnome-control-center 3.32
no longer affects: pulseaudio (Ubuntu Disco)
Silvio Bierman (sbierman) wrote :

I have installed the master branch of the "Sound Input & Output Device chooser" Gnome shell extension replacing the release version that got broken with the recent shell upgrade.
This extension now again works properly enabling switching devices so this makes it indeed very likely that the issue is purely a g-c-c one.

Franck (alci) wrote :

I can confirm the gnome shell extension Silvio mentions in his previous message works.

Robert Ancell (robert-ancell) wrote :

Fixed the obvious bug in the change not being applied in gnome-control-center 3.32.0.1-1ubuntu4 but please open new bugs in further issues occur after that.

Changed in gnome-control-center (Ubuntu Disco):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.32.0.1-1ubuntu4

---------------
gnome-control-center (1:3.32.0.1-1ubuntu4) disco; urgency=medium

  * debian/patches/0001-sound-Apply-device-changes.patch:
    - Fix sound output device change not being applied (LP: #1817338)

 -- Robert Ancell <email address hidden> Thu, 14 Mar 2019 11:05:45 +1300

Changed in gnome-control-center (Ubuntu Disco):
status: Fix Committed → Fix Released
Silvio Bierman (sbierman) wrote :

I can confirm it is working properly now. Thanks a lot for the fix.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers