gnome-control-center refuses to open if you try to open the Details panels

Bug #1814949 reported by Khairul Aizat Kamarudzzaman on 2019-02-06
114
This bug affects 19 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Critical
Unassigned

Bug Description

Workaround
==========
Run this command in your terminal:
gsettings reset org.gnome.ControlCenter last-panel

and then avoid opening the Details panels

Issue
=====
If you try to open the Details panel, gnome-control-center will crash.
It will then refuse to open.

Upstream Bug Report
===================
https://gitlab.gnome.org/GNOME/gnome-control-center/issues/285

See also
https://gitlab.gnome.org/GNOME/gnome-control-center/merge_requests/387

Original Bug Report
===================
Segmentation fault while trying to run via cli , the gnome setting doesn't working when click on setting menu

ProblemType: Crash
DistroRelease: Ubuntu 19.04
Package: gnome-control-center 1:3.30.2-4ubuntu2
ProcVersionSignature: Ubuntu 4.19.0-12.13-generic 4.19.18
Uname: Linux 4.19.0-12-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.10-0ubuntu20
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Feb 1 14:38:32 2019
ExecutablePath: /usr/bin/gnome-control-center
InstallationDate: Installed on 2017-05-04 (643 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170503)
ProcCmdline: gnome-control-center
SegvAnalysis:
 Segfault happened at: 0x7f783f52232d <__GI___libc_free+29>: mov -0x8(%rdi),%rax
 PC (0x7f783f52232d) ok
 source "-0x8(%rdi)" (0xfffffff8) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: gnome-control-center
StacktraceTop:
 __GI___libc_free (mem=0x100000000) at malloc.c:3085
 g_unix_mount_free () at /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ()
 ()
 g_type_create_instance () at /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: gnome-control-center crashed with SIGSEGV in __GI___libc_free()
UpgradeStatus: Upgraded to disco on 2018-11-06 (92 days ago)
UserGroups: adm cdrom dip libvirt lpadmin lxd plugdev sambashare sudo

information type: Private → Public

StacktraceTop:
 free () from /tmp/apport_sandbox_j7ab9k3r/lib/x86_64-linux-gnu/libc.so.6
 g_unix_fd_list_append (list=0x5594b868d3a0, fd=-1213470432, error=0x5594b868d3a0) at ../../../gio/gunixfdlist.c:333
 ?? ()
 ?? ()
 ?? ()

Changed in gnome-control-center (Ubuntu):
status: New → Invalid
Download full text (4.8 KiB)

Thank you for your report!

However, processing it in order to get sufficient information for the
developers failed (it does not generate a useful symbolic stack trace). This
might be caused by some outdated packages which were installed on your system
at the time of the report:

no debug symbol package found for binutils-common
no debug symbol package found for build-essential
no debug symbol package found for cpp
no debug symbol package found for dbus-user-session
no debug symbol package found for debianutils
no debug symbol package found for dnsmasq-base
no debug symbol package found for g++
no debug symbol package found for gcc
no debug symbol package found for gcc-8-base
no debug symbol package found for gcc-9-base
no debug symbol package found for gir1.2-atk-1.0
no debug symbol package found for gir1.2-freedesktop
no debug symbol package found for gir1.2-gdkpixbuf-2.0
no debug symbol package found for gir1.2-glib-2.0
no debug symbol package found for gir1.2-gtk-3.0
no debug symbol package found for gir1.2-ibus-1.0
no debug symbol package found for gir1.2-notify-0.7
no debug symbol package found for gir1.2-packagekitglib-1.0
no debug symbol package found for gir1.2-pango-1.0
no debug symbol package found for gir1.2-polkit-1.0
no debug symbol package found for gir1.2-secret-1
no debug symbol package found for gir1.2-vte-2.91
no debug symbol package found for gstreamer1.0-gl
no debug symbol package found for gstreamer1.0-pulseaudio
no debug symbol package found for gstreamer1.0-x
no debug symbol package found for isc-dhcp-common
no debug symbol package found for libavahi-common-data
libc-dev-bin version 2.28-0ubuntu1+maarten0 required, but 2.28-0ubuntu1 is available
libc6 version 2.28-0ubuntu1+maarten0 required, but 2.28-0ubuntu1 is available
no debug symbol package found for libc6
libc6-dev version 2.28-0ubuntu1+maarten0 required, but 2.28-0ubuntu1 is available
no debug symbol package found for libc6-dev
no debug symbol package found for libgcc-8-dev
libglib2.0-0 version 2.59.0-1 required, but 2.58.2-4 is available
libglib2.0-bin version 2.59.0-1 required, but 2.58.2-4 is available
libglib2.0-data version 2.59.0-1 required, but 2.58.2-4 is available
no debug symbol package found for libgssapi-krb5-2
no debug symbol package found for libgstreamer-gl1.0-0
no debug symbol package found for libgstreamer-plugins-base1.0-0
no debug symbol package found for libgstreamer-plugins-good1.0-0
no debug symbol package found for libk5crypto3
no debug symbol package found for libkrb5-3
no debug symbol package found for libkrb5support0
no debug symbol package found for libmagic-mgc
no debug symbol package found for libnl-genl-3-200
no debug symbol package found for libogg0
no debug symbol package found for libopus0
no debug symbol package found for libpcre2-8-0
no debug symbol package found for libperl5.28
no debug symbol package found for libpython2.7-minimal
no debug symbol package found for libpython2.7-stdlib
no debug symbol package found for libpython3-stdlib
no debug symbol package found for libpython3.7-minimal
no debug symbol package found for libpython3.7-stdlib
libsasl2-2 version 2.1.27+dfsg-1build1 required, but 2.1.27+dfsg-1 is available
libsa...

Read more...

tags: removed: need-amd64-retrace
Changed in gnome-control-center (Ubuntu):
importance: Undecided → High
status: Invalid → Triaged
Sebastien Bacher (seb128) wrote :

Looks like you have libglib2.0-0 2.59 which you probably installed from disco-proposed (which is not meant to be used but for automated tests&validation only), does it fix it if you downgrade to the disco 2.58.3 version?

i do as latest comment in GNOME Bug :

gsettings reset org.gnome.ControlCenter last-panel

then my gnome-control-center working again.

Sebastien Bacher (seb128) wrote :

Well, that's only changing the panel, do you still get the issue if you go to the details->info section?

Changed in gnome-control-center (Ubuntu):
status: Triaged → Incomplete
Changed in gnome-control-center (Ubuntu):
importance: High → Low

yes, still getting the issue .. its break again when to go info section

after i downgrade to libglib2 2.58.2-4 , i can go to info section without crash

Sebastien Bacher (seb128) wrote :

Closing then, it was an issue in a version of libglib that went only in disco-proposed and got deleted from there because it was buggy

Changed in gnome-control-center (Ubuntu):
status: Incomplete → Invalid
Jeremy Bicha (jbicha) wrote :

I'm reopening this bug, raising its severity and updating the description now that the new glib version has reached disco.

Changed in gnome-control-center (Ubuntu):
importance: Low → Critical
status: Invalid → Triaged
summary: - gnome-control-center crashed with SIGSEGV in __GI___libc_free()
+ gnome-control-center refuses to open if you try to open the Details
+ panels
description: updated
description: updated
Jeremy Bicha (jbicha) on 2019-02-13
tags: added: rls-dd-incoming
removed: third-party-packages
Francois Thirioux (fthx) wrote :

Yes I hit this bug today in Disco, after glib & control center upgrades. The workaround works.

Clemens Wasser (clemensw) wrote :

Same bug for me. (Disco)

Sebastien Bacher (seb128) wrote :
Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Committed

Tested the fix in disco-proposed ...

so far so good not crashing when go to info in setting ... thanks !!
On Feb 16 2019, at 1:34 am, Sebastien Bacher <email address hidden> wrote:
> The fix is in disco-proposed, https://launchpad.net/ubuntu/+source
> /gnome-control-center/1:3.31.90-1ubuntu3
>
> ** Changed in: gnome-control-center (Ubuntu)
> Status: Triaged => Fix Committed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1814949
>
> Title:
> gnome-control-center refuses to open if you try to open the Details
> panels
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1814949/+subscriptions
>

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.31.90-1ubuntu3

---------------
gnome-control-center (1:3.31.90-1ubuntu3) disco; urgency=medium

  * Add new info panel patch to debian/patches/series
  * Increase height in ubuntu-default-height.patch (for new Applications panel)
  * Modify 70_allow_sound_above_100.patch to add a frame around the system
    volume box

 -- Jeremy Bicha <email address hidden> Thu, 14 Feb 2019 08:48:46 -0500

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Ioannis Vardas (ioannisvardas) wrote :

I see that his bug is fixed, however I encountered it today in my system.
It is exactly as you described and the workaround works exactly as you say.
Is there a fix?

Sebastien Bacher (seb128) wrote :

Best to open a new report with apport if you still have the issue

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers