VLAN in GUI's network setting is under Bluetooth section

Bug #1785311 reported by Jorz on 2018-08-03
24
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
High
Unassigned

Bug Description

I install vlan package and setup VLAN successfully. But when I check the Network settings in GUI, the created VLAN interface is under Bluetooth section.

For reference, here is the screen shot of the issue.

Jorz (voxeljorz) wrote :
summary: - VLAN in GUI's setwork setting is under Bluetooth section
+ VLAN in GUI's network setting is under Bluetooth section
Joshua Powers (powersj) wrote :

Hi! Thanks for taking the time to file a bug. I have re-assigned this to network-manager as this isn't a bug with the vlan package, but with the UI itself. It may need to be moved to yet another package, but this should get the right people's attention.

Could you also let us know what version of Ubuntu you are using? (e.g. `cat /etc/os-release`)

Thanks!

affects: vlan (Ubuntu) → network-manager (Ubuntu)

Thank you for looking into it, I used Ubuntu 18.04, the latest released.

On Aug 7, 2018 12:21 AM, "Joshua Powers" <email address hidden> wrote:

Hi! Thanks for taking the time to file a bug. I have re-assigned this to
network-manager as this isn't a bug with the vlan package, but with the
UI itself. It may need to be moved to yet another package, but this
should get the right people's attention.

Could you also let us know what version of Ubuntu you are using? (e.g.
`cat /etc/os-release`)

Thanks!

** Package changed: vlan (Ubuntu) => network-manager (Ubuntu)

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1785311

Title:
  VLAN in GUI's network setting is under Bluetooth section

Status in network-manager package in Ubuntu:
  New

Bug description:
  I install vlan package and setup VLAN successfully. But when I check
  the Network settings in GUI, the created VLAN interface is under
  Bluetooth section.

  For reference, here is the screen shot of the issue.

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/1785311/+subscriptions

Sitxu (joretur) wrote :

I do confirm the issue Ubuntu 18.04

NAME="Ubuntu"
VERSION="18.04.1 LTS (Bionic Beaver)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 18.04.1 LTS"
VERSION_ID="18.04"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=bionic
UBUNTU_CODENAME=bionic

Burov Konstantin (sad-2-shade) wrote :

Hi, I confirm too on Ubuntu 18.04

NAME="Ubuntu"
VERSION="18.04.1 LTS (Bionic Beaver)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 18.04.1 LTS"
VERSION_ID="18.04"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=bionic
UBUNTU_CODENAME=bionic

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that's an upstream issue and known there as https://gitlab.gnome.org/GNOME/gnome-control-center/issues/190

affects: network-manager (Ubuntu) → gnome-control-center (Ubuntu)
Changed in gnome-control-center (Ubuntu):
importance: Undecided → High
status: New → Triaged
Michael (mwestwood) wrote :

Hi, confirmed on 18.10.

`nmcli c add type vlan dev enp0s25 id 100`

Also, the button on the side of the new VLAN in th GUI deleted the connection, rather than disabling it.

--
NAME="Ubuntu"
VERSION="18.10 (Cosmic Cuttlefish)"
ID=ubuntu
ID_LIKE=debian
PRETTY_NAME="Ubuntu 18.10"
VERSION_ID="18.10"
HOME_URL="https://www.ubuntu.com/"
SUPPORT_URL="https://help.ubuntu.com/"
BUG_REPORT_URL="https://bugs.launchpad.net/ubuntu/"
PRIVACY_POLICY_URL="https://www.ubuntu.com/legal/terms-and-policies/privacy-policy"
VERSION_CODENAME=cosmic
UBUNTU_CODENAME=cosmic

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.32.1-1ubuntu1

---------------
gnome-control-center (1:3.32.1-1ubuntu1) disco; urgency=medium

  * New upstream stable version, based on the Debian update
    - Only show Bluetooth devices in Bluetooth section (lp: #1785311)
  * Remove the patches included in the new version

 -- Sebastien Bacher <email address hidden> Fri, 05 Apr 2019 23:01:07 +0200

Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers