gnome-control-center (ERROR) ../shell/cc-panel-list.c → 926 → cc_panel_list_set_active_panel → assertion failed → (data != NULL)

Bug #1766799 reported by errors.ubuntu.com bug bridge on 2018-04-25
48
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Unassigned

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding gnome-control-center. This problem was most recently seen with package version 1:3.28.1-0ubuntu1, the problem page at https://errors.ubuntu.com/problem/73835fe215683e2f5f85df231eb2750a57e96c65 contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker and are a software developer, you can request it at http://forms.canonical.com/reports/.

summary: - /usr/bin/gnome-control-center:ERROR:../shell/cc-panel-
- list.c:926:cc_panel_list_set_active_panel: assertion failed: (data !=
- NULL)
+ gnome-control-center (ERROR) ../shell/cc-panel-list.c → 926 →
+ cc_panel_list_set_active_panel → assertion failed → (data != NULL)
Sebastien Bacher (seb128) wrote :
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Sebastien Bacher (seb128) wrote :

The reports seem to come from non GNOME users trying to use gnome-control-center (e.g under xubuntu)

Ben Roberts (ben-l-roberts) wrote :

I get this trying to use gnome-control-center under the "Gnome Classic" session.

Changed in gnome-control-center (Ubuntu):
status: Triaged → In Progress
Pat Suwalski (pat-suwalski) wrote :

I have this error occurring when I run the regular GNOME session.

In Ubuntu session, control panel works. In GNOME session, settings does not launch. Launching "gnome-control-center" from terminal provides the core dump message initially reported.

MBWD (xmbwd) wrote :

Running Ubuntu 18.04 in a GNOME Xorg session, I get the same error when attempting to launch 'gnome-control-center':

`ERROR:../shell/cc-panel-list.c:926:cc_panel_list_set_active_panel: assertion failed: (data != NULL)
Aborted (core dumped)`

Nathan Graule (solarliner) wrote :

I was able to reproduce the problem by having both the Ubuntu and GNOME session.

1. Login with Ubuntu session
2. Select the Dock settings panel
3. Logout, then back in with GNOME session
4. Launch gnome-control-center

It will try to open back the (now non-existent) Dock settings panel and SEGFAULT. It appears to do that when trying to show a non-existent panel.

Workaround:

1. Login into Ubuntu session
2. Open Settings, and select a panel that exists on both sessions (so any panel except the Dock it seems)
3. Log back out, and then back into the GNOME session.

Now the settings should open without SEGFAULT.

Jeremy Bicha (jbicha) wrote :

Nathan, thank you very much for the Test Case and Workaround.

This sounds like it would be fixed by
https://gitlab.gnome.org/GNOME/gnome-control-center/commit/73c40aa3

Pat Suwalski (pat-suwalski) wrote :

Good find, #6. I came about the same result but couldn't explain why my control center stopped crashing.

I needed to make some online account changes, so I had switched to the Ubuntu session to get that done, and the control center worked flawlessly in Gnome ever since. Your explanation seems correct.

Nathan Graule (solarliner) wrote :

Not knowing the codebase, and going with the data != NULL assertion shown with the crashes, it seems #7's link points to the fix.

Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.28.1-0ubuntu4

---------------
gnome-control-center (1:3.28.1-0ubuntu4) cosmic; urgency=medium

  [ Andrea Azzarone ]
    * debian/patches/git_invalid_dereferencing.patch:
    - Avoid dereferencing invalid pointer (lp: #1759468)

 -- Sebastien Bacher <email address hidden> Fri, 25 May 2018 16:25:16 +0200

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers