gnome-control-center crashed with SIGSEGV in actualize_printers_list()

Bug #1754924 reported by Bulent Besim on 2018-03-11
668
This bug affects 73 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Unassigned

Bug Description

Test Case
=========
From Ubuntu 18.04, click the top right of the screen to open the system status menu.
Click the gear button at the bottom to open the Settings app.
In the Settings app, click Devices > Printers.
Close the Settings app and then use the system status menu to re-open Settings.
Navigate to the Printers panel.

gnome-control-center crashes

Other Info
==========
I can reproduce the crash in Debian Buster also.

This is also reproducible by opening the Settings app from the Activities Overview.

This is not reproducible by running gnome-control-center from the command line.

It's also odd that running gnome-control-center will always open the last opened panel (this is a GNOME 3.28 feature), but running it from either the Activities Overview or from the system status menu will only open the last opened panel if it is not in the Details or Devices submenus.

ProblemType: Crash
DistroRelease: Ubuntu 18.04
Package: gnome-control-center 1:3.27.92-1ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-12.13-generic 4.15.7
Uname: Linux 4.15.0-12-generic x86_64
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Sat Mar 10 22:33:39 2018
ExecutablePath: /usr/bin/gnome-control-center
InstallationDate: Installed on 2018-03-03 (7 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180301)
ProcCmdline: gnome-control-center --overview
ProcEnviron:
 PATH=(custom, user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x562f4ba335f1: mov 0x90(%rbp),%rsi
 PC (0x562f4ba335f1) ok
 source "0x90(%rbp)" (0x00000090) not located in a known VMA region (needed readable region)!
 destination "%rsi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-control-center
StacktraceTop:
 ?? ()
 ?? ()
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: gnome-control-center crashed with SIGSEGV in g_main_context_dispatch()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Bulent Besim (bbesim) wrote :

StacktraceTop:
 actualize_printers_list (self=0x562f4c7004f0) at ../panels/printers/cc-printers-panel.c:998
 cups_status_check_cb (source_object=<optimized out>, result=0x562f4cec0b40, user_data=0x562f4c7004f0) at ../panels/printers/cc-printers-panel.c:1235
 g_task_return_now (task=0x562f4cec0b40) at ../../../../gio/gtask.c:1148
 complete_in_idle_cb (task=0x562f4cec0b40) at ../../../../gio/gtask.c:1162
 g_main_dispatch (context=0x562f4c1e6280) at ../../../../glib/gmain.c:3177

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
summary: - gnome-control-center crashed with SIGSEGV in g_main_context_dispatch()
+ gnome-control-center crashed with SIGSEGV in actualize_printers_list()
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
information type: Private → Public
tags: added: bugpattern-needed
Cliff Carson (ccarson1) wrote :

Seen this problem twice when going to Settings-Devices-Printer. The Settings window and the apport error is displayed. The second time Settings-Devices-Printer is selected the Printer selection window appears.

Jeremy Bicha (jbicha) on 2018-03-28
description: updated
Sebastien Bacher (seb128) wrote :

The fix is in 3.28.1

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers