gnome-control-center windows remains open after using the launch-panel/online-accounts/add "API"

Bug #1754651 reported by Andrea Azzarone on 2018-03-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Andrea Azzarone

Bug Description

To reproduce:

1) open gnome-calendar
2) go to calendar-settings
3) activate a row in order to add an account
4) close the new-account dialog

Expected result:
- The gnome-control-center main window is closed

Actual result:
- The gnome-control-center main window remains open

Andrea Azzarone (azzar1) on 2018-03-09
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
assignee: nobody → Andrea Azzarone (azzar1)
status: New → In Progress
Andrea Azzarone (azzar1) wrote :

Please find attached a possible fix. Please notice that I'm not forwarding this upstream as I would prefer to have a cleaner solution upstream. Possibly we might need to extend gnome-online-accounts api to improve the client-side add-account dialog.

The attachment "gcc.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Jeremy Bicha (jbicha) on 2018-03-19
Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.28.0-0ubuntu1

---------------
gnome-control-center (1:3.28.0-0ubuntu1) bionic; urgency=medium

  [ Jeremy Bicha ]
  * New upstream release

  [ Gunnar Hjalmarsson ]
  * debian/rules:
    - Add X-Ubuntu-Gettext-Domain to .desktop files and strip inline
      translations (LP: #1755473).
    - Build gnome-control-center-2.0.pot.
  * Modify 71_ubuntu_dock_settings.patch:
    - Drop non-existing gnome-ubuntu-panel.desktop.in from POTFILES.in.

  [ Daniel van Vugt ]
  * Add 0004-Expose-touchpad-settings-if-synaptics-is-in-use.patch
    - Allow touchpad settings to work with xserver-xorg-input-synaptics
      Note that this is unneeded on GNOME on Wayland where libinput is
      always used. (LP: #1686081)

  [ Andrea Azzarone ]
  * Add auto_quit_after_goa_add.patch:
    - Hide window after adding an online account from another app.
      (LP: #1754651)

 -- Jeremy Bicha <email address hidden> Mon, 19 Mar 2018 08:37:32 -0400

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers