"Login Screen" button not present in Region & Language

Bug #1730900 reported by Gunnar Hjalmarsson on 2017-11-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Gnome Documentation
Fix Released
Medium
gnome-control-center (Ubuntu)
Undecided
Unassigned
gnome-user-docs (Ubuntu)
High
Unassigned

Bug Description

On my Ubuntu 17.10, which was upgraded from 17.04, the Settings -> Region & Language window includes a "Login Screen" button at the top right, which allows me to set language, format and input sources also system wide, i.e. affecting the login screen. The Ask Ubuntu answer <https://askubuntu.com/a/973915> shows its location.

However, on an (almost) fresh install of Ubuntu 17.10, that button is not present.

I don't know what the intended design is in this respect.

* If the button is supposed to be there, some dependency necessary for it to function might be missing.

* If the button is not supposed to be there, is there some other GUI way to control those settings system wide?

Jeremy Bicha (jbicha) wrote :

I see the Login Screen button here, so I think we need more information about how to reproduce this bug.

Are you able to duplicate this issue from a new Ubuntu 17.10 install?

Changed in gnome-control-center (Ubuntu):
status: New → Incomplete
Gunnar Hjalmarsson (gunnarhj) wrote :

Well, I think I have figured it out.

The behavior is easy to reproduce if there is only one user account on the system. Then the Login Screen button is not shown, but OTOH changes of language/format/input sources are written to /etc/default/locale respective /etc/default/keyboard without asking for it explicitly.

If you add another user, the button shows up.

So this seems to be about the GNOME thinking in this respect which I'm not used to, and right now I don't like it either. Look at the Ask Ubuntu answer I linked to. I tried to help the OP based on what I saw on my own machine (with more than one user account), but the OP didn't understand what I was talking about.

The GNOME folks seem to be too smart for their own good. Things like this cause confusion!! :(

Closing. (Some day, when I'm in a better mood, I may file an upstream bug.)

Changed in gnome-control-center (Ubuntu):
status: Incomplete → Invalid
Jeremy Bicha (jbicha) wrote :

> I may file an upstream bug.

It's probably worth mentioning in the user help that button and when it shows up.

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2017-11-09 06:12, Jeremy Bicha wrote:
>> I may file an upstream bug.
>
> It's probably worth mentioning in the user help that button and when
> it shows up.

Right. I'll consider that too. Adding a gnome-user-docs task to remember it.

Changed in gnome-user-docs (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in gnome-user-docs:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in gnome-user-docs:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-user-docs - 3.28.0+git20180331-0ubuntu1

---------------
gnome-user-docs (3.28.0+git20180331-0ubuntu1) bionic; urgency=medium

  * Latest upstream git (LP: #1682548, LP: #1730900)
  * debian/rules:
    - Drop sed() command for controlling the HTML build (moved to build
      script in the ubuntu-docs branch).

 -- Gunnar Hjalmarsson <email address hidden> Sun, 01 Apr 2018 23:25:00 +0200

Changed in gnome-user-docs (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.