Details are not visible (adwaita) by default and hide important configuration

Bug #1728450 reported by Paul Smith on 2017-10-29
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Confirmed
Medium
gnome-control-center (Ubuntu)
Low
Unassigned

Bug Description

When I open the gnome-control-center, I see the following menu items down the left side: Wi-Fi, Bluetooth, Background, Notifications, Search, Region & Language, Universal Access, Online Accounts, Privacy, Sharing, Sound, Power, Network, Devices (with a sub-menu). Screenshot attached.

If I happen to move my mouse into the menu area I _may_ notice a very thin "scroll area" show up briefly before it disappears again, or I _may_ notice very subtle dotted lines at the bottom of the menu, and I _may_ notice that there is actually another menu item at the bottom that I have to scroll down to see: Details.

And if I happen to find that and click on that sub-menu, I will find critically important items in there such as Date & Time configuration (what I was looking for to get an AM/PM clock, and couldn't find at all), Users configuration (couldn't find that either so had to add users by hand from the CLI), and Default Applications (also important so I can change the default mail client etc.)

What does "Details" even mean? This menu might as well be named "Miscellaneous". Really that would be MORE helpful: at least it would be clear that there's a bunch of random stuff below that menu, which is the reality. The only thing in "Details" that feels appropriate to the name is the "About" menu.

I really like the format change of gnome-control-center from the "rows of icons" to the left-side menu: it looks nice and avoiding the "go back and select something else" by just clicking along the left side is a very pleasant experience. But the menu organization here is really confusing and hard to use, and needs serious attention.

There needs to be enough top-level menus to be sure everything fits on the screen without scrolling.

The About menu item should be on the top-level menu at the bottom of the list... people think it's not important but it's actually REALLY important, so inexperienced people can easily obtain critical system details when asking for help.

And the grouping of these menus needs love: for example, why is "Wi-Fi" a separate menu item from "Network"? I would think that Wi-Fi, Network, Online Accounts and Sharing could all be combined into one sub-menu like "Internet" or similar. Actually I don't have a Wi-Fi adapter in my system so I don't know what shows up there: maybe "Wi-Fi" is more about the hardware, and belongs under "Devices"? Either way.

Also I think "Region & Language", "Universal Access", and possibly "Date & Time" could be grouped together.

And "Background", "Privacy", and "Notifications" could be grouped under some sort of "desktop" menu. Or maybe "Region & Language" would stay a top-level item and "Universal Access" and "Date & Time" would be added to "Desktop".

Anyway. I realize there are lots of ways to chop these items up and people will have disagreements, but the current situation is really very not good: the control center needs to avoid the need for scrolling to see all the options and if things are moved into sub-menus the names of those menus HAVE to be evocative and clear.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: gnome-control-center 1:3.26.1-0ubuntu4
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia
ApportVersion: 2.20.7-0ubuntu3.1
Architecture: amd64
CurrentDesktop: GNOME
Date: Sun Oct 29 15:18:20 2017
InstallationDate: Installed on 2017-10-21 (8 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

Paul Smith (psmith-gnu) wrote :
Jeremy Bicha (jbicha) wrote :

I believe you'll find that if you change your theme to Ambiance (the default in the Ubuntu session), the Settings sidebar is tall enough to show all items without a vertical scrollbar.

The sidebar being too short by default is https://bugzilla.gnome.org/789372

Discussion about ordering and grouping the panels is https://bugzilla.gnome.org/786810

Since they are really two separate issues, could you please split this into another bug?

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Triaged
summary: - Details are not visible by default and hide important configuration
+ Details are not visible (adwaita) by default and hide important
+ configuration
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Confirmed
Sebastien Bacher (seb128) wrote :
Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.30.2-4ubuntu2

---------------
gnome-control-center (1:3.30.2-4ubuntu2) disco; urgency=medium

  * debian/patches/71_ubuntu_dock_settings.patch,
    debian/patches/ubuntu-default-height.patch:
    - change the default height so all category are on screen,
      we previously increased the value in the dock patch since we add an
      entry there but that's not enough so let's split that part now
      (lp: #1728450)

 -- Sebastien Bacher <email address hidden> Thu, 31 Jan 2019 15:10:30 +0100

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.