Unable to access more than 20 languages in 1080p

Bug #1727710 reported by Caleb Jensen on 2017-10-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Wishlist
gnome-control-center (Ubuntu)
High
Gunnar Hjalmarsson
Bionic
High
Gunnar Hjalmarsson

Bug Description

There is no scroll bar on the language selection GUI, causing issues if you install more than 20 language selections. The ... button is on the bottom off the screen, meaning you can't access it. On resolutions smaller than 1080p, you could expect the same issues but with less language options.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. What Ubuntu version and desktop environment do you use?

Changed in language-selector (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Caleb Jensen (irishman2020) wrote :

16.04 and Gnome, but I've also tested it in Gnome Classic. This appears to be a GUI issue in all versions of Gnome.

Gunnar Hjalmarsson (gunnarhj) wrote :

I think you are talking about the gnome-control-center GUI, not language-selector. Changing the affected package.

Out of curiosity: Why do you have so many languages installed? ;)

affects: language-selector (Ubuntu) → gnome-control-center (Ubuntu)
Changed in gnome-control-center (Ubuntu):
status: Incomplete → Confirmed
Caleb Jensen (irishman2020) wrote :

It's an OEM style server. When it reaches the destination, it could potentially be used by 30-40 languages and will potentially be offline.

Caleb Jensen (irishman2020) wrote :

Also this occurs in the Users account language selection.

Sebastien Bacher (seb128) wrote :

could you make a screenshot of the UI you are using?

Caleb Jensen (irishman2020) wrote :

Going to "Settings> Region & Language> Language" goes to this screen. The same occurs when going to Settings> User > Language.

Gunnar Hjalmarsson (gunnarhj) wrote :

This is related to an Ubuntu patch of the cc_common_language_get_initial_languages() function, which makes the UI show language options for actually installed languages instead of a fixed list of some big languages whether they are installed or not.

http://bazaar.launchpad.net/~ubuntu-desktop/gnome-control-center/ubuntu/view/head:/debian/patches/52_region_language.patch#L157

My belief is that 'the Ubuntu way' makes more sense for most users, but apparently the initial window isn't designed to handle a long list for the case many languages are installed.

Caleb Jensen (irishman2020) wrote :

Adding a scroll bar to that area would resolve these issues, or simply a limiter (possibly based on resolution?).

tags: added: rls-bb-incoming
Gunnar Hjalmarsson (gunnarhj) wrote :
Changed in gnome-control-center (Ubuntu):
assignee: nobody → Gunnar Hjalmarsson (gunnarhj)
status: Confirmed → In Progress
tags: added: patch
Sebastien Bacher (seb128) wrote :

Thanks for the work Gunnar but why limiting the list rather than making it possible to scroll down in it?

Gunnar Hjalmarsson (gunnarhj) wrote :

On 2017-11-21 11:47, Sebastien Bacher wrote:
> why limiting the list rather than making it possible to scroll down
> in it?

The reason, if any, would be to not add to the complexity of the Ubuntu specific patch(es) in this respect. Otherwise, adding a scroll bar would be more elegant, of course, even if I don't know how to do it.

Gunnar Hjalmarsson (gunnarhj) wrote :

I figured out how to add a scrollbar (proved to be a tiny change) and submitted a merge proposal (linked above). Also took the opportunity in this MP to hide "Install More..." at the bottom of the window, since we won't(?) be able to install languages that way in 18.04.

Changed in gnome-control-center (Ubuntu):
importance: Low → High
Gunnar Hjalmarsson (gunnarhj) wrote :

After having talked with Iain Lane on #ubuntu-desktop, I upstreamed the scrolling part of my proposal.

Changed in gnome-control-center:
importance: Unknown → Wishlist
status: Unknown → Confirmed
Gunnar Hjalmarsson (gunnarhj) wrote :

As regards installation of language packs I take it that we have two options.

The best would be if the user could simply open the second Language window and install from there. In that case the item list should reasonably consist of language packs and not all the locales.

If there is not sufficient time to fix that in 18.04, I think we should hide the second Language window as I propose in the MP and keep providing language-selector-gnome for managing installed languages.

Will Cooke (willcooke) on 2018-03-06
tags: removed: rls-bb-incoming
Iain Lane (laney) wrote :

OK, I think we should hide the 'install more' thing for 18.04. It doesn't work on Ubuntu and I don't think we're going to get to fix it before the release.

It's been a 'known' item for us for a while, and we would like to fix it but it requires some thought/effort/coordination/time that we haven't put into the problem yet.

I'll look into this soon, possibly at the start of next week. Thanks for your work so far.

Iain Lane (laney) wrote :

Uploaded, please try it out once it lands in bionic.

Changed in gnome-control-center (Ubuntu Bionic):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.28.0-0ubuntu2

---------------
gnome-control-center (1:3.28.0-0ubuntu2) bionic; urgency=medium

  [ Gunnar Hjalmarsson ]
   * debian/patches/52_region_language.patch:
    - Enable scrollbar in "Language" window when needed (LP: #1727710).
    - Hide the "Install More..." thing since we can't install languages
      that way yet.

  [ Iain Lane ]
  * debian/patches/0005-Show-scrollbar-on-first-Language-window-if-needed.patch:
    Split out from 52_region_language as forwarded upstream.

 -- Iain Lane <email address hidden> Mon, 19 Mar 2018 15:34:01 +0000

Changed in gnome-control-center (Ubuntu Bionic):
status: Fix Committed → Fix Released
Gunnar Hjalmarsson (gunnarhj) wrote :

@Iain: Seems to work as expected. Actually I think it's a bit better compared to my original more 'hackish' variant. While the window was a bit too high with my original MP, the height is now quite ok.

Thanks!

Gunnar Hjalmarsson (gunnarhj) wrote :
Changed in gnome-control-center (Ubuntu Bionic):
status: Fix Released → In Progress
Iain Lane (laney) wrote :

...this should be a different bug, right?

Gunnar Hjalmarsson (gunnarhj) wrote :

Submitted bug #1758979.

Changed in gnome-control-center (Ubuntu Bionic):
status: In Progress → Fix Released
Changed in gnome-control-center:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.