gnome-control-center crashed with SIGSEGV

Bug #1724738 reported by Dmitriy Geels on 2017-10-19
178
This bug affects 39 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Unassigned

Bug Description

g-c-c hangs then crashes after successful adding online account

ProblemType: Crash
DistroRelease: Ubuntu 17.10
Package: gnome-control-center 1:3.26.1-0ubuntu4
Uname: Linux 4.13.7-041307-generic x86_64
NonfreeKernelModules: 8723bu
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
CurrentDesktop: GNOME
Date: Thu Oct 19 11:13:19 2017
ExecutablePath: /usr/bin/gnome-control-center
InstallationDate: Installed on 2017-08-30 (49 days ago)
InstallationMedia: Ubuntu-GNOME 17.04 "Zesty Zapus" - Release amd64 (20170412)
ProcCmdline: gnome-control-center background
SegvAnalysis:
 Segfault happened at: 0x7f85caf39b3b: mov 0x8(%rax),%rax
 PC (0x7f85caf39b3b) ok
 source "0x8(%rax)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: gnome-control-center
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/mesa-egl/libEGL.so.1
 ?? () from /usr/lib/x86_64-linux-gnu/mesa-egl/libEGL.so.1
 ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
 ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
 ?? () from /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
Title: gnome-control-center crashed with SIGSEGV
UpgradeStatus: Upgraded to artful on 2017-10-19 (0 days ago)
UserGroups: adm cdrom dip i2c lpadmin plugdev sambashare sudo video

Dmitriy Geels (dmig) wrote :

StacktraceTop:
 update_buffers (dri2_surf=dri2_surf@entry=0x5559931f44d0) at ../../../src/egl/drivers/dri2/platform_wayland.c:541
 image_get_buffers (driDrawable=driDrawable@entry=0x555992e1cb20, format=<optimized out>, stamp=stamp@entry=0x555992e1cb50, loaderPrivate=loaderPrivate@entry=0x5559931f44d0, buffer_mask=buffer_mask@entry=1, buffers=buffers@entry=0x7ffc75728760) at ../../../src/egl/drivers/dri2/platform_wayland.c:669
 intel_update_image_buffers (drawable=0x555992e1cb20, brw=0x5559942e9630) at ../../../../../../src/mesa/drivers/dri/i965/brw_context.c:1657
 intel_update_renderbuffers (context=context@entry=0x555992cfd6d0, drawable=drawable@entry=0x555992e1cb20) at ../../../../../../src/mesa/drivers/dri/i965/brw_context.c:1325
 intel_prepare_render (brw=brw@entry=0x5559942e9630) at ../../../../../../src/mesa/drivers/dri/i965/brw_context.c:1346

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Andrea Azzarone (azzar1) on 2017-10-20
information type: Private → Public
Alberto (jarargentina-gmail) wrote :

Ocurre al agregar una cuenta en linea (facebook, ...)

Andrea (andrevergamito) wrote :

Issue presented on a 17.04 system after update to 17.10, not a fresh install.

It happenned just after adding a Google account.

It happenned just after adding a Google account. +1

It happened just after adding a Google account. +1

It happened after I tried add a Google account, but without success. Then I tried add a facebook acount, when gnome-control-center crashed.

Yeah, I'm seeing the same almost immediately after adding a Google account.

description: updated
Changed in gnome-control-center (Ubuntu):
assignee: nobody → Md.Mosaddek-UZ-Zaman (jayed-kum)
assignee: Md.Mosaddek-UZ-Zaman (jayed-kum) → nobody
Daniel C Aragao (daniebrno) wrote :

Issue presented on a 17.10, a fresh install.

Ronan TISON (kara-age-kun) wrote :

It happened just after adding a Google account. +1

Muhammad Darwish (mbdarwish) wrote :

Happened right after logging in to a google account

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers