Enable switch option to set volume above 100% from media keys and gnome shell UI

Bug #1706524 reported by Didier Roche on 2017-07-26
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME Settings Daemon
Confirmed
Medium
gnome-control-center (Ubuntu)
Undecided
Unassigned
gnome-session (Ubuntu)
Undecided
Unassigned
gnome-settings-daemon (Ubuntu)
Undecided
Unassigned
gnome-shell (Ubuntu)
Undecided
Unassigned

Bug Description

Some devices have very office-oriented hardware and so, low volume power speakers.
The normal usage can make the sound unhearable on those configurations.

We added in u-c-c an option to switch it above 100%, per max volume capability, and unity was picking up this value in its indicator and u-s-d.

We desire thus to bring the same experience in the new ubuntu GNOME Shell session: gnome-control-center have a slider enabling setting the volume above 100%, however, this settings is only available in that panel, and if you use the media key or the GNOME Shell controls, volume is reset at 100% at max.

Upstream GNOME doesn't seem to have genuine interests in enabling that feature (see the discussion on the linked bug report). The proposal is thus:
- only enabling that feature in the *ubuntu* sessions. Don't let the sound (even if the key was enabled in the ubuntu session) goes above 100% in the gnome sessions to preserve upstream desired experience.
- reuse the same gsettings key (as long as it's not upstream) as we used to have. Easy migrations, user's setting preservation and such
- add this switch to gnome-control-center
- modify GNOME Shell agregate menu (volume settings) to represent the % in the volume slider corresponding to actual setting. We approach this as a distro patch and not an extension. The extension approach was hacky (overriding a callback, copying logic), and may work badly with well-designed other extensions. Hence this untrusive distro-patch.
- patch gnome-settings-daemon volume plugin for respecting this settings in the global OSD and react to media keys
- add a dependency from the ubuntu-session package on the schema, as reading the schema is conditioned on the session name.

Related branches

Changed in gnome-settings-daemon:
importance: Unknown → Medium
status: Unknown → Confirmed
Daniel van Vugt (vanvugt) wrote :

I'm not sure what >100% means but if it means there might be distortion or clipping then those would be reasons to not allow >100% by default.

If the volume isn't loud enough by default then maybe the user should find some form of external amplification (that won't have distortion or clipping problems that might arise from >100% setting).

Just a guess/concern...

Didier Roche (didrocks) wrote :

This isn't a good answer for people working with laptops, where this issue occurs the most. I don't want have speakers with me everwhere I'm travelling :p

Note that this option is already shown in gnome-control-center, just not available from main UI. The option is off by default and people know what to expect when they switch it on. It's already available in Unity since 14.04.

Daniel van Vugt (vanvugt) wrote :

Yeah it's a good option to have. I'm just suggesting it should not be possible to accidentally push volume over 100% by pressing the volume keys. You should have to enable the option explicitly and it should not be on by default. Because distortion and clipping may (will?) occur.

Didier Roche (didrocks) wrote :

That was already the case and still will be, hence the switch and the default key being off in gnome-control-center.

Julian Alarcon (alarconj) wrote :

Hi!

Just be careful with this I hear many people that damaged their speakers because of this option.
I think that there should be an advise.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.24.3-0ubuntu3

---------------
gnome-control-center (1:3.24.3-0ubuntu3) artful; urgency=medium

  * Add patch to expose settings allowing setting volume above 100%:
    - debian/patches/70_allow_sound_above_100.patch, adapt the patch from
      unity-control-center to only add a slightely reshaped UI (use of
      gtk switch and rephrasing). Only show the above 100% volume option if:
      1. you are in an ubuntu session
      2. the selected output supports amplified volume. If so:
         present the settings to google that on and off. It will enable
         GNOME Shell and media keys to set the sound above 100%. If not
         enabled, volume and sliders are all capped to 100%. (LP: #1706524)

 -- Didier Roche <email address hidden> Wed, 16 Aug 2017 08:30:52 +0200

Changed in gnome-control-center (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-shell - 3.24.3-0ubuntu3

---------------
gnome-shell (3.24.3-0ubuntu3) artful; urgency=medium

  * Add patch to allow setting volume above 100%:
    - debian/patches/70_allow_sound_above_100.patch, which allows the volume
      slider in the aggregatemenu to reflect and set correct current volume
      position. (LP: #1706524)
  * Add debian/patches/50_add_ubuntu_desktop_detect.patch to centralize
    current desktop detection.

 -- Didier Roche <email address hidden> Wed, 16 Aug 2017 08:29:17 +0200

Changed in gnome-shell (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-settings-daemon - 3.24.3-0ubuntu3

---------------
gnome-settings-daemon (3.24.3-0ubuntu3) artful; urgency=medium

  * Add patch to allow setting volume above 100%:
    - debian/patches/70_allow_sound_above_100.patch, adapt the patch from
      ubuntu-settings-daemon to latest g-s-d. (LP: #1706524)

 -- Didier Roche <email address hidden> Wed, 16 Aug 2017 08:29:43 +0200

Changed in gnome-settings-daemon (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.