Add on/off switch for network connectivity check

Bug #1704162 reported by Jeremy Bicha on 2017-07-13
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
NetworkManager
Fix Released
Medium
gnome-control-center
Expired
Medium
gnome-control-center (Ubuntu)
Medium
Unassigned
network-manager (Ubuntu)
Medium
Unassigned

Bug Description

For Ubuntu 17.10, the Desktop Team would like to enable NetworkManager's connectivity check (LP: #997200) to detect captive portals. This has been supported by other GNOME distros for a couple years. Fedora in particular makes it opt out which we plan to do also in Ubuntu.

This bug is a feature request to add an on/off switch for this connectivity check to gnome-control-center. I suggest that it be added to the Privacy panel although it might also work in the Network panel.

I think there are two ways the switch could work. It could either write directly to a config file or it could use PackageKit to install or uninstall the distro-specific package that contains the connectivity config file. The advantage of the separate binary package is that it's easy to install or uninstall it for people that don't use gnome-control-center.

See the upstream bug for a bit more details.

Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Changed in network-manager:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in network-manager:
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) on 2017-08-24
Changed in network-manager (Ubuntu):
status: New → Fix Committed
importance: Undecided → Medium
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.8.2-1ubuntu3

---------------
network-manager (1.8.2-1ubuntu3) artful; urgency=medium

  [ James Henstridge ]
  * Backport connectivity checking API from master. (LP: #1704162)

  [ Jeremy Bicha ]
  * NetworkManager.conf: disable MAC randomization feature. There is no
    easy way for desktop users to disable this feature yet. And there are
    reports that it doesn't work well with some systems. (LP: #1681513)

 -- James Henstridge <email address hidden> Tue, 22 Aug 2017 17:18:49 +0800

Changed in network-manager (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.24.3-0ubuntu5

---------------
gnome-control-center (1:3.24.3-0ubuntu5) artful; urgency=medium

  * Add connectivity-check.patch:
    - Apply James Henstridge's proposed patch to add Connectivity Check
      on/off switch to Privacy panel (LP: #1704162)

 -- Jeremy Bicha <email address hidden> Wed, 23 Aug 2017 22:01:16 -0400

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-control-center:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.