gnome-control-center crashed with SIGSEGV in strlen()

Bug #1618290 reported by Marty Goetting on 2016-08-30
136
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
High
Unassigned
gnome-control-center (Ubuntu)
High
Unassigned

Bug Description

Crash after Printer setup in Settings was chosen, then force closed.

ProblemType: Crash
DistroRelease: Ubuntu 16.10
Package: gnome-control-center 1:3.20.1-2ubuntu1
ProcVersionSignature: Ubuntu 4.4.0-9136.55-generic 4.4.16
Uname: Linux 4.4.0-9136-generic x86_64
ApportVersion: 2.20.3-0ubuntu7
Architecture: amd64
CrashCounter: 1
CurrentDesktop: GNOME
Date: Mon Aug 29 21:07:24 2016
ExecutablePath: /usr/bin/gnome-control-center
InstallationDate: Installed on 2016-08-27 (3 days ago)
InstallationMedia: Ubuntu-GNOME 16.10 "Yakkety Yak" - Alpha amd64 (20160824)
ProcCmdline: gnome-control-center --overview
ProcEnviron:
 PATH=(custom, user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f43cb9a1f06 <strlen+38>: movdqu (%rax),%xmm4
 PC (0x7f43cb9a1f06) ok
 source "(%rax)" (0x295c8f0c) not located in a known VMA region (needed readable region)!
 destination "%xmm4" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: gnome-control-center
StacktraceTop:
 strlen () at ../sysdeps/x86_64/strlen.S:106
 g_strdup () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? ()
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
Title: gnome-control-center crashed with SIGSEGV in strlen()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Marty Goetting (maddog25046) wrote :

StacktraceTop:
 strlen () at ../sysdeps/x86_64/strlen.S:106
 g_strdup () from /tmp/apport_sandbox_pnd6dh/lib/x86_64-linux-gnu/libglib-2.0.so.0
 printer_selection_changed_cb (selection=<optimized out>, user_data=0x55f629668230) at cc-printers-panel.c:768
 _g_closure_invoke_va () from /tmp/apport_sandbox_pnd6dh/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_emit_valist () from /tmp/apport_sandbox_pnd6dh/usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
tags: added: bugpattern-needed
Jeremy Bicha (jbicha) on 2016-09-30
information type: Private → Public
fossfreedom (fossfreedom) wrote :
Download full text (4.8 KiB)

ok - some feedback here - ubuntu gnome 16.10 beta 2 with an apt full-update installed in virtualbox VM + virtualbox guest additions and dkms.

1. Settings - Printer icon - no crash. It detects my HP Wifi based printer on the "add a new printer" dialog
2. Selecting the printer and clicking the add button displays the message "failed to add new printer"

Looking at journal -ae --full these are the relevant trace issues:

Oct 01 17:52:16 dad-VirtualBox dbus[596]: [system] Activating service name='org.opensuse.CupsPkHelper.Mechanism' (using servicehelper)
Oct 01 17:52:16 dad-VirtualBox dbus[596]: [system] Successfully activated service 'org.opensuse.CupsPkHelper.Mechanism'
Oct 01 17:52:16 dad-VirtualBox audit[2274]: AVC apparmor="DENIED" operation="capable" profile="/usr/sbin/cupsd" pid=2274 comm="usb" capability=35 ca
Oct 01 17:52:16 dad-VirtualBox kernel: audit_printk_skb: 39 callbacks suppressed
Oct 01 17:52:16 dad-VirtualBox kernel: audit: type=1400 audit(1475340736.806:25): apparmor="DENIED" operation="capable" profile="/usr/sbin/cupsd" pid
Oct 01 17:52:17 dad-VirtualBox gnome-control-center.desktop[2240]: mkdir failed on directory /var/cache/samba: Permission denied
Oct 01 17:52:26 dad-VirtualBox dbus-daemon[1097]: Activating service name='org.fedoraproject.Config.Printing'
Oct 01 17:52:26 dad-VirtualBox org.fedoraproject.Config.Printing[1097]: /usr/bin/scp-dbus-service: 3: exec: /usr/share/system-config-printer/scp-dbus
Oct 01 17:52:26 dad-VirtualBox dbus-daemon[1097]: Activated service 'org.fedoraproject.Config.Printing' failed: Process org.fedoraproject.Config.Prin
Oct 01 17:52:26 dad-VirtualBox gnome-control-c[2240]: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.fedoraproject.Config.Prin
Oct 01 17:52:26 dad-VirtualBox dbus-daemon[1097]: Activating service name='org.fedoraproject.Config.Printing'
Oct 01 17:52:26 dad-VirtualBox org.fedoraproject.Config.Printing[1097]: /usr/bin/scp-dbus-service: 3: exec: /usr/share/system-config-printer/scp-dbus
Oct 01 17:52:26 dad-VirtualBox dbus-daemon[1097]: Activated service 'org.fedoraproject.Config.Printing' failed: Process org.fedoraproject.Config.Prin
Oct 01 17:52:26 dad-VirtualBox gnome-control-c[2240]: GDBus.Error:org.freedesktop.DBus.Error.Spawn.ChildExited: Process org.fedoraproject.Config.Prin
Oct 01 17:52:26 dad-VirtualBox /hpfax[2304]: [2304]: error: Failed to create /var/spool/cups/tmp/.hplip
Oct 01 17:52:26 dad-VirtualBox dbus-daemon[1097]: Activating service name='org.fedoraproject.Config.Printing'
Oct 01 17:52:26 dad-VirtualBox org.fedoraproject.Config.Printing[1097]: /usr/bin/scp-dbus-service: 3: exec: /usr/share/system-config-printer/scp-dbus
Oct 01 17:52:26 dad-VirtualBox dbus-daemon[1097]: Activated service 'org.fedoraproject.Config.Printing' failed: Process org.fedoraproject.Config.Prin
Oct

To solve the 'cupsd DENIED' type messages I did:

sudo apt install apparmor-utils

To solve the /var/cache/samba permission denied I did:

sudo apt install samba-common

To solve the daemon messages "Oct 01 17:52:26 dad-VirtualBox org.fedoraproject.Config.Printing[1097]: /usr/bin/scp-dbus-service: 3: exec: /usr/share/system-config-printer/scp-dbus"

sudo apt install s...

Read more...

Jeremy Bicha (jbicha) on 2016-10-02
Changed in gnome-control-center (Ubuntu):
importance: Medium → High
Changed in ubuntu-gnome:
importance: Undecided → High
status: New → Confirmed
Jeremy Bicha (jbicha) wrote :

I don't have a printer here and the panel doesn't crash for me. I did a new upload of gnome-control-center today to yakkety. I don't think it would affect this crash but could someone try 1:3.20.1-2ubuntu2 to verify whether it still crashes?

J.Ar (j.ar) wrote :

@Jeremy Bicha

I have updated my System and the new package is running...now i can open the printer configuration without a crash. Thanks :)

Jeremy,

  yep the update works. Cheers :)

Please note though - I had to manually install
system-config-printers-gnome first before I could add a network
printer. Suggest there is a dependency/recommendation missing
somewhere. Please let me know which package should (or will) have
this dependency/recommendation ... thanks in advance.

David

On 5 October 2016 at 06:27, J.Ar <email address hidden> wrote:
> @Jeremy Bicha
>
> I have updated my System and the new package is running...now i can open
> the printer configuration without a crash. Thanks :)
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1627866).
> https://bugs.launchpad.net/bugs/1618290
>
> Title:
> gnome-control-center crashed with SIGSEGV in strlen()
>
> Status in Ubuntu GNOME:
> Confirmed
> Status in gnome-control-center package in Ubuntu:
> Confirmed
>
> Bug description:
> Crash after Printer setup in Settings was chosen, then force closed.
>
> ProblemType: Crash
> DistroRelease: Ubuntu 16.10
> Package: gnome-control-center 1:3.20.1-2ubuntu1
> ProcVersionSignature: Ubuntu 4.4.0-9136.55-generic 4.4.16
> Uname: Linux 4.4.0-9136-generic x86_64
> ApportVersion: 2.20.3-0ubuntu7
> Architecture: amd64
> CrashCounter: 1
> CurrentDesktop: GNOME
> Date: Mon Aug 29 21:07:24 2016
> ExecutablePath: /usr/bin/gnome-control-center
> InstallationDate: Installed on 2016-08-27 (3 days ago)
> InstallationMedia: Ubuntu-GNOME 16.10 "Yakkety Yak" - Alpha amd64 (20160824)
> ProcCmdline: gnome-control-center --overview
> ProcEnviron:
> PATH=(custom, user)
> XDG_RUNTIME_DIR=<set>
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SegvAnalysis:
> Segfault happened at: 0x7f43cb9a1f06 <strlen+38>: movdqu (%rax),%xmm4
> PC (0x7f43cb9a1f06) ok
> source "(%rax)" (0x295c8f0c) not located in a known VMA region (needed readable region)!
> destination "%xmm4" ok
> SegvReason: reading unknown VMA
> Signal: 11
> SourcePackage: gnome-control-center
> StacktraceTop:
> strlen () at ../sysdeps/x86_64/strlen.S:106
> g_strdup () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> ?? ()
> ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> g_signal_emit_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
> Title: gnome-control-center crashed with SIGSEGV in strlen()
> UpgradeStatus: No upgrade log present (probably fresh install)
> UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu-gnome/+bug/1618290/+subscriptions

Jeremy Bicha (jbicha) wrote :

Yes, gnome-control-center now recommends system-config-printer-gnome so it will be installed by default (again) from now on.

https://launchpad.net/ubuntu/+source/gnome-control-center/1:3.20.1-2ubuntu3

I'm going to go ahead and mark this bug fixed since I'm told that the Printers panel works now. Thanks!

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntu-gnome:
status: Confirmed → Fix Released
To post a comment you must log in.