Appearance Preferences offer Visual Effects without installed Compiz

Bug #159996 reported by cybernoid on 2007-11-04
6
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

A standard Ubuntu Hardy installation has no dependency on the compiz packages, only a recommendation. The Appearance Preferences on the other hand always offer visual effects, even if the compiz packages are not installed.

There should be either a dependency on compiz or the preferences app should detect whether compiz is available and offer visual effects only in that case.

Pedro Villavicencio (pedro) wrote :

Thank you for your comments. This does not appear to be a bug report and we are closing it. We appreciate the difficulties you are facing, but it would make more sense to raise your question in the support tracker. https://answers.launchpad.net/ubuntu

Changed in gnome-control-center:
status: New → Invalid
Nikolaus Rath (nikratio) wrote :

I think what the original submitter means is that visual effects can still be enabled from appearance preferences even if Compiz has not been installed. This is something I can reproduce and I'd consider it a bug.

Either appearance preferences should detect whether compiz is available, or the gnome-control-center (or maybe ubuntu-desktop) package should depend on Compiz.

Changed in gnome-control-center:
status: Invalid → New
description: updated
Changed in gnome-control-center:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Confirmed

Disabling the tab when compiz is not installed would be quite easy. Just a case of checking for NULL from g_find_program_in_path ("compiz"). I'll have a crack at doing this.

This debdiff disables the "effects" tab if the command "compiz" isn't found.

cybernoid (marciocastro) wrote :

This is what I call 'cracked by angels' ;)))

In fact I realise this is a VERY ANNOYING bug, special
to women (My wife included). They all would like to see the compyz going on with their portable x86,
but I realize that theres a lot of portable computers with no 3D acceleration!!!
In fact 50% of the portable computers hasnt got 3D, They all have Intel Video Cards, very very
closed to the S3 virgen somewhat.

But YES - my wife loves Ubuntu and dosnt like XP nomore.

Im also was a fEDORA fanatic, but... well when I can have a running system 20% faster than fedora
with no repositories bugs, ultra packages updates, etc... - I had to change.
I can prove this with Audacity benchmark.

My OS number 1 is Workbench 3.1 - That one with a simple basic arexx script could hide easaly that bug.
Because It's an ugly bug. Women hate to see that they click and dosnt work. I think begginer users general.
I think myself if I didnt have a geforce 5200...

I dont like arexx... but I bet Amiga Commodore wouldnt have that bug anyway :)

So let talks about put that patch as an update for gnome settings...
Even greater was that to Ubuntu recognize by glance - no 3d ready card??? -> no compiz effect -> disable 3d effects. Like a good Oporto wine ;)

Greetz from Portugal! ((((())))

Bryce Harrington (bryce) wrote :

Hi Bruce,

In general the patch looks okay, but I notice it touches a lot of other files unnecessarily. It appears you constructed the diff between two different versions of g-c-c. Would you mind redoing the patch more cleanly, so it doesn't touch so many files?

Changed in gnome-control-center:
status: Confirmed → In Progress

It was just the output of cdbs-edit-patch and debdiff. In fact, it only touches two files, debian/changelog and debian/patches/95_desktop-effects-integration.patch, it's just that this patch patches a patch.

Sebastien Bacher (seb128) wrote :

there is a new version available in intrepid, could you update the debdiff?

Actually, there is a typo in the changelog, "only show effects tab is compiz is installed" should be "only show effects tab if compiz is installed"

The above debdiffs doesn't actually work, as the tab wasn't actually hidden. (effects_init doesn't show the tab like I thought it did) Here's one which works.

Michael Vogt (mvo) wrote :

Thanks for your bugreport and your patch,

I would prefer if instead of hidding the tab the compiz settings would be set "set_sensivite(False)". Even better would be if we could offer to install compiz if the user clicks on it, but that is probably jaunty material.

If you could update the patch to use this, that would be much appreciated.

This isn't actually my bug, but I've hijacked it now.

Indeed hiding the tab's contents is better (I remember something in the HIG about that), so here's a new patch.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:2.24.0.1-0ubuntu5

---------------
gnome-control-center (1:2.24.0.1-0ubuntu5) intrepid; urgency=low

  * debian/patches/95_desktop-effects-integration.patch:
    - change by Bruce Cowan to allow selecting the desktop effects only when
      the compiz binary is installed (lp: #159996)

 -- Sebastien Bacher <email address hidden> Wed, 15 Oct 2008 15:19:28 +0200

Changed in gnome-control-center:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers