sharing panel fails to properly launch required daemons

Bug #1518813 reported by Tim on 2015-11-23
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ubuntu GNOME
Low
Unassigned
gnome-control-center (Ubuntu)
Low
Unassigned
gnome-user-share (Ubuntu)
Low
Unassigned
vino (Ubuntu)
Low
Robert Hönig

Bug Description

This is caused by outdated gnome-user-share and vino.

both gnome-user-share (webdav) and vino daemons fail to launch properly in a GNOME session via g-s-d sharing plugin

Caused by code in the daemons, that relies on deprecated "enabled" keys, no longer used by g-s-d/g-c-c

ProblemType: BugDistroRelease: Ubuntu 16.04
Package: gnome-control-center 1:3.18.2-1ubuntu2
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.19.2-0ubuntu6
Architecture: amd64
CurrentDesktop: GNOME
Date: Mon Nov 23 13:23:44 2015
InstallationDate: Installed on 2012-09-23 (1156 days ago)
InstallationMedia: Ubuntu GNOME Remix 12.10 "Quantal Quetzal" - Alpha amd64(20120922)SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

Tim (darkxst) wrote :
Changed in ubuntu-gnome:
milestone: none → xenial
Changed in gnome-control-center (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in ubuntu-gnome:
status: New → Triaged
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

what would be required to be changed in gnome-user-share and vino?

Changed in gnome-user-share (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Changed in vino (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Tim (darkxst) wrote :

at the very least, patching the OnlyShowIn settings in desktop files

Sebastien Bacher (seb128) wrote :

I guess it would be useful to summarize what changed upstream, what is g-c-c expecting and what are our current packages doing. Then we can discuss possible solutions and their impact...

Tim (darkxst) wrote :

seb, g-s-d added a sharing plugin in 3.10 or so, that manages the sharing daemons (gnome-user-share, vino and rygel) on a per-network basis, rather than having gnome-session launch them. Though moving to that would require new UI for u-c-c.

I'll dig a bit deeper over the next few days, and update more then.

Tim (darkxst) on 2015-11-29
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-user-share - 3.14.2-2ubuntu1

---------------
gnome-user-share (3.14.2-2ubuntu1) xenial; urgency=medium

  * New Upstream release (LP: #1518813)
  * Merge with Debian, Remaining changes:
    - Suggests the apache2.2-bin and libapache2-mod-dnssd binaries rather than
      depends on those, we want obex push to work out of the box but we don't
      really need webdav and the apache binaries on the default installation.
    - debian/patches:
      + 0001-revert-remove-preferences-application.patch
        0002-revert-data-get-started-by-gsd-sharing.patch
        0003-revert-webdav-fix-launching-server.patch:
         Bring back the preferences app for Unity and modify to allow g-s-d sharing
         panel to also work
      + 01_notification.patch: Display an alert box instead of a notification
        for files received.
    - debian/rules:
      + Don't change path to httpd
      + Remove apache 2.2 config
  * 04_webdav_optional.patch, 05_autostart_delay.patch: Refreshed
  * 06_nodisplay_autostart.patch,
    07_onlyshowin_unity.patch: dropped, applied in preferences patches

 -- Tim Lunn <email address hidden> Fri, 27 Nov 2015 21:05:42 +1100

Changed in gnome-user-share (Ubuntu):
status: Incomplete → Fix Released
Amr Ibrahim (amribrahim1987) wrote :

Will be there an update to vino?

Sebastien Bacher (seb128) wrote :

The update doesn't bring much out of dropping the standalone settings dialogs that are used out of GNOME, it's more likely than we backport needed commits rather than update vino

Basar Qari (qaribasar) on 2015-12-30
Changed in vino (Ubuntu):
assignee: nobody → Basar Qari (qaribasar)
status: Incomplete → Confirmed
Amr Ibrahim (amribrahim1987) wrote :

The problem with staying with a much older version is that upstream will be reluctant to fix bugs and backporting fixes will get harder when the code diverges.

Sebastien Bacher (seb128) wrote :

right, if that's the case and updating is a better option than backporting fixes then we can revisit and do the update...

Changed in vino (Ubuntu):
assignee: Basar Qari (qaribasar) → Robert Hönig (indielives010)
status: Confirmed → In Progress
Robert Hönig (indielives010) wrote :

So here is a small and easy fix, no backporting but simply bypassing the enabled key check if vino runs under GNOME.

Changed in vino (Ubuntu):
status: In Progress → Fix Committed
Tim (darkxst) wrote :

Hi Robert,
   The logic of your patch is good, however there is one more check that you missed (in a seperate file).
   Also there is a spurious quilt patch in your debdiff, can you remove that.

The attachment "vino_3.8.1-0ubuntu8.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Changed in vino (Ubuntu):
status: Fix Committed → In Progress
Robert Hönig (indielives010) wrote :

Ok, new debdiff. Modified the check in vino-prefs.c and removed the "spurious" quilt patch :P

Robert Hönig (indielives010) wrote :

New clarified debdiff:

Tim (darkxst) wrote :

Hi Robert,
   you broke the logic in vino-prefs if statement on your rebase. also you seem to have double bumped the version number in the changelog. Both of those were correct in the previous debdiff.

Robert Hönig (indielives010) wrote :

Ok, fixed these issues.

Tim (darkxst) wrote :

vino (3.8.1-0ubuntu8) xenial; urgency=low

  * Fixes the bug with vino not launching when starting user sharing under
    GNOME due to its reliance on "enabled" gsettings key. (LP :#1518813)

 -- Robert Hoenig <<email address hidden> (indielives010: 179) (indielives010: 179) > Sun, 10 Jan 2016 10:51:46 +0100

Changed in vino (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-gnome:
status: Triaged → Fix Released
Changed in gnome-control-center (Ubuntu):
status: Triaged → Invalid
5a54a (5a54a) wrote :

Bug is still open (Ubuntu Gnome 16.04). See my temp solution: #1246243 (comment #2).

I can confirm that this bug is still here in 16.04. Under the user point of view, is as screen sharing is simply not working ( regression from 14.04).

Vassilis Kehayas (vkehayas) wrote :

I can also confirm that this bug is still present on Ubuntu Gnome 16.04.

Jeremy Bicha (jbicha) wrote :

Let's use bug 1607663 to track the 'vino sharing panel broken in Ubuntu GNOME 16.04' issue. The fix for that is in progress.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers