defaults to 'normal effects' even when the driver does not support compositing

Bug #144913 reported by Martin Pitt on 2007-09-25
4
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Michael Vogt

Bug Description

Binary package hint: gnome-control-center

When using a driver that does not support compositing (such as nv, vesa, in vmware...), the effects setting still defaults to 'normal'. Switching to 'more effects' has no effect, and switching to 'off' and back looks confusing.

Ideally, in this case this should show a message that desktop effects are not supported with the graphics card driver in use.

restricted-manager already checks at first boot whether a proprietary driver is available, so I don't think that c-c needs to do anything special about it.

Martin Pitt (pitti) on 2007-09-25
Changed in gnome-control-center:
assignee: nobody → macslow
importance: Undecided → Medium
Michael Vogt (mvo) wrote :

The problem is that the code currently checks only for the currently configured wm, but not the running one:

        WindowManager wm = current_configured_wm (data, &error);
        data->compiz_running = (wm == COMPIZ);

This needs to be fixed.

Changed in gnome-control-center:
status: New → Confirmed
Michael Vogt (mvo) wrote :

Fix uploaded, waiting in the queue.

Changed in gnome-control-center:
assignee: macslow → mvo
status: Confirmed → Fix Committed
Michael Vogt (mvo) wrote :

gnome-control-center (1:2.20.0-0ubuntu4) gutsy; urgency=low

  * debian/patches/95_desktop-effects-integration.patch:
    - check for currently running wm instead of configured wm
      (LP: #144913)
    - show custom button if there are custom setting, hide
      only ccsm start button if ccsm is not installed
    - fix fixed sizing in glade file

 -- Michael Vogt <email address hidden> Wed, 26 Sep 2007 10:17:28 +0200

Changed in gnome-control-center:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers