"use network time" is not installing ntp?

Bug #1420698 reported by Romano Giannetti on 2015-02-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Undecided
Unassigned

Bug Description

I discovered that, even if I checked "use network time" in the control panel, the package ntp was not installed (just ntpdate).

This caused a drift in time in my desktop (which is always on); after a couple of days if I deselect the the option and select it again I have:

SYS: Feb 11 08:47:58 pern kernel: [775917.016524] systemd-timedated[14157]: Set NTP to disabled
SYS: Feb 11 08:47:59 pern kernel: [775918.305488] systemd-timedated[14157]: Set NTP to enabled
SYS: Feb 11 08:48:59 pern ntpdate[14170]: step time server 91.189.94.4 offset 53.842810 sec
SYS: Feb 11 08:49:01 pern dovecot: imap: Warning: Time jumped forwards 53 seconds

I solved it manually by install ntp --- but shouldn't this be automatically done if I choose "use network time"? It doesn't seem a "one shot" option at all --- it stays put (it is not like a button to "read network time now" or similar).

Thanks!

Steven Howell (steven-c-howell) wrote :

I similarly noticed that one of my three computers running Ubuntu 14.04 did not update the time for DST. Looking into it further, I realized the one that did not update did not have ntp installed. After manually installing, it solved the problem. I never manually installed this on either of the other computers so I am not sure why I had to for one of three.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers