Gnome settings daemon doesn't work

Bug #138277 reported by LCID Fire on 2007-09-08
18
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-panel

I changed to a custom theme and now every second or so login I get a nasty message that the settings daemon could not be started.

LCID Fire (lcid-fire) wrote :
LCID Fire (lcid-fire) wrote :

I am on gutsy and what really bothers me that it sometimes works - which is really arkward

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Does it happens with another theme provided by Ubuntu or it's just happen with that custom theme?

Changed in gnome-panel:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Incomplete
Guido Conaldi (guido-conaldi) wrote :

Today, after the latest updates on my gutsy i686 gnome-settings-daemon stopped working. I get the same message as in the screenshot.

Calling g-s-d from the command line I get:

gfipm@gvaio:~$ gnome-settings-daemon
The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 915 error_code 2 request_code 147 minor_code 35)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
[1190036777,000,xklavier.c:xkl_engine_start_listen/] The backend does not require manual layout management - but it is provided by the applicationfipm@gvaio:

Morten Siebuhr (msiebuhr) wrote :

Likewise here. My error contain slightly different values, though:

The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 502 error_code 2 request_code 146 minor_code 35)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
[1190042028,000,xklavier.c:xkl_engine_start_listen/] The backend does not require manual layout management - but it is provided by the application

Mike Basinger (mike.basinger) wrote :

The gnome-settings-daemon is not starting when I login. I did not see this bug till I upgraded gnome-control-center on 17-Sept-2007.

Output of running gnome-settings-daemon from command line.
The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 973 error_code 2 request_code 149 minor_code 35)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
[1190043093,000,xklavier.c:xkl_engine_start_listen/] The backend does not require manual layout management - but it is provided by the application

Mike Basinger (mike.basinger) wrote :

Many people are reporting this problem on the forums.
http://ubuntuforums.org/showthread.php?t=553094

Paul Coleman (pdcoleman) wrote :

Me too. Just different errors.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 1303 error_code 2 request_code 145 minor_code 35)

Stéphane Travostino (eazy87) wrote :

The upgrade shipped today for gnome-control-center (1:2.19.92-0ubuntu3) broke everything.
I've reopened bug #36090, since it seems to be exactly the same bug.

Searching on the bug reports someone says it's related to evdev, but it's not enabled/used in my system.

Joey Stanford (joey) wrote :

me too.

  (Details: serial 2882 error_code 2 request_code 147 minor_code 35)

Matthew Garrett (mjg59) wrote :

The BadValue errors are a separate bug to the original one filed here.

Hi folks,

After the updates of today, on stratup I get the same error as in the screenshot originally posted by LCID fire. I tryed to restart the gnome settings daemon from the console and got one of those error messages (see below) mine differs for some number too but I guess it just varies from machine to machine. Rebooting or relogging doesn't seem to help in my case, it never loaded right in some ten attempts.

daniele@daniele-laptop:~$ gnome-settings-daemon
The program 'gnome-settings-daemon' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadValue (integer parameter out of range for operation)'.
  (Details: serial 1388 error_code 2 request_code 147 minor_code 35)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
[1190057791,000,xklavier.c:xkl_engine_start_listen/] The backend does not require manual layout management - but it is provided by the applicationdaniele@daniele-laptop:~$

Thanks for the attention and good luck (sorry, I'm just a diplomathics student, can't help further).

Daniele

Joey Stanford (joey) wrote :

Hi,

I've applied the fix that just hit the repositories. It worked however I am unable to launch gnome-appearance-properties now. In fact, my terminal font is so small that I've had to copy and paste this error into gedit :-)

joey@c14n:~$ gnome-appearance-properties

(gnome-appearance-properties:6491): GdkPixbuf-CRITICAL **: gdk_pixbuf_new: assertion `width > 0' failed

(gnome-appearance-properties:6491): GdkPixbuf-CRITICAL **: gdk_pixbuf_scale_simple: assertion `src != NULL' failed

(gnome-appearance-properties:6491): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(gnome-appearance-properties:6491): GdkPixbuf-CRITICAL **: gdk_pixbuf_new: assertion `width > 0' failed

(gnome-appearance-properties:6491): GdkPixbuf-CRITICAL **: gdk_pixbuf_scale_simple: assertion `src != NULL' failed

(gnome-appearance-properties:6491): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed

(gnome-appearance-properties:6491): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion `pixbuf != NULL' failed

(gnome-appearance-properties:6491): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion `pixbuf != NULL' failed

(gnome-appearance-properties:6491): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_width: assertion `pixbuf != NULL' failed

(gnome-appearance-properties:6491): GdkPixbuf-CRITICAL **: gdk_pixbuf_get_height: assertion `pixbuf != NULL' failed
The program 'gnome-appearance-properties' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadPixmap (invalid Pixmap parameter)'.
  (Details: serial 314 error_code 4 request_code 54 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
joey@c14n:~$

I'm wondering if clearing out parts of .gnome2 might be worth a shot.

Joey Stanford (joey) wrote :

The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 134 error_code 11 request_code 53 minor_code 0)

Joey Stanford (joey) wrote :

I've just confirmed on my non-synaptics machine that this is also broken with the recent changes so perhaps it's not directly related to this bug.

Mary Gardiner (puzzlement) wrote :

The bug Joey mentions with gnome-appearance-properties has been filed as bug 133084.

Mary Gardiner (puzzlement) wrote :

As for the gnome-settings-daemon problem that most people are discussing as of mid-September, maybe it should be discussed in bug 139761. It sounds like the original reporter of this bug had a different problem.

Morten Siebuhr (msiebuhr) wrote :

The problem disappeared for me with the latest Gutsy-updates - gnome-control-center (1:2.19.92-0ubuntu3).

uga (yegor-jbanov) wrote :

(Dell Inspiron 6400, Core 2 Duo, ATI X1400, Gutsy Tribe 5 + all software upgrades)

The problem comes and goes. It came back after the latest software update (Sept 17, 2007).

I see a dialogue box shortly after login reading:

"There was an error starting the GNOME Settings Daemon.

Some things, such as themes, sounds, or background settings may not work correctly.

The last error message was:

Failed to connect to socket /tmp/dbus-NFZ8GYvPtQ: Connection refused

GNOME will still try to restart the Settings Daemon next time you log in."

If there is any information I can provide, please let me know where I can dig it out.

Thanks

Sebastien Bacher (seb128) wrote :

Does anybody still get the bug? The dbus error is likely not a gnome-control-center bug

On 9/21/07, Sebastien Bacher <email address hidden> wrote:
> Does anybody still get the bug? The dbus error is likely not a gnome-
> control-center bug

I dont. I upgraded my ubuntu next day and rebooted my box, and this
error is gone.

--
bvk-chaitanya

bvk (bvk) wrote :

On 9/21/07, BVK <email address hidden> wrote:
>
> I dont. I upgraded my ubuntu next day and rebooted my box, and this
> error is gone.
>

IIRC, i was facing the problem with 1:2.19.92-0ubuntu2. Now i
upgraded to 1:2.19.92-0ubuntu3 and gnome-settings-daemon is working
fine.

--
bvk-chaitanya

Sebastien Bacher (seb128) wrote :

closing the bug, if somebody still get an issue you should open a new bug about it

Changed in gnome-control-center:
status: Incomplete → Fix Released
Nick Fishman (bsdlogical) wrote :

I've been having the same issue on a clean install of Gutsy, even with the latest updates. Bug #146946 describes my issue perfectly.

Henriël Veldtmann suggested a fix that has solved my problems so far: installing the dbus-X11 package. I'm not positive why this solves things, but it does for me.

The issue might not be related to gnome-control-center, but either way it's worth investigating further. Clean installations of Gutsy shouldn't be giving errors like this.

skippy (skippy) wrote :

I've been having this same problem since upgrading to Hardy Heron on my x86_64 system. The symptom is not reliably reproducible: sometimes it happens when I select any item from the System->Preferences menu; sometimes when I click the "browse" button a web page file upload form; sometimes when I click a shortcut button I've added to my top GNOME bar.

Manually executing gnome-settings-daemon after this problem occurs gives me an error about the dbus socket. If I `sudo gnome-settings-daemon` then I get the errors listed above.

I have installed the dbus-x11 package, to no apparent effect.

skippy (skippy) wrote :

I tried adding gnome-settings-daemon to my GNOME Session (System - > Preferences -> Session), but that does not seem to have made any difference.

There's no reliable way for me to reproduce this bug. Instead, it happens randomly: sometimes when I launch a new application from my GNOME bar, sometimes when I do something within an already-running application (open a file dialog, ask XChat to connect to a server, etc).

Here's the tail end of my .xsession-errors
** (nm-applet:6912): WARNING **: <WARN> nma_dbus_init(): org.freedesktop.DBus.Error.NoServer raised:
 Failed to connect to socket /var/run/dbus/system_bus_socket: Connection refused

** (nm-applet:6912): WARNING **: <WARN> nma_dbus_init(): org.freedesktop.DBus.Error.NoServer raised:
 Failed to connect to socket /var/run/dbus/system_bus_socket: Connection refused

** (nm-applet:6912): WARNING **: <WARN> nma_dbus_init(): org.freedesktop.DBus.Error.NoServer raised:
 Failed to connect to socket /var/run/dbus/system_bus_socket: Connection refused

DBus connection has been lost, trackerd will now shutdown
** Message: Got disconnected from the session message bus; retrying to reconnect every 10 seconds

(nautilus:7134): nautilus-extension-gnome-mount-WARNING **: Cannot connect to system bus: org.freedesktop.DBus.Error.NoServer : Failed to connect to socket /var/run/dbus/system_bus_socket: Connection refused

(nautilus:7134): nautilus-extension-gnome-mount-WARNING **: Could not initialize hal context

seahorse nautilus module initialized
Initializing nautilus-share extension

** (gnome-panel:7137): WARNING **: Couldn't connect to system bus: Failed to connect to socket /var/run/dbus/system_bus_socket: Connection refused

** (gnome-panel:7137): CRITICAL **: dbus_g_connection_get_connection: assertion `gconnection' failed

** (nautilus:7134): WARNING **: Unable to add monitor: Operation not supported
Nautilus-Share-Message: Called "net usershare info" but it failed: 'net usershare' returned error 255: net usershare: cannot open usershare directory /var/lib/samba/usershares. Error No such file or directory
Please ask your system administrator to enable user sharing.

Perhaps more annoyingly, when this happens I am unable to browse the contents of my home directory. I can click on Places->Desktop, Places->Documents, Places->Music, etc; but clicking on Places->Home Folder gives me an empty window and a spinning cursor. The same situation holds true for any "File Open" dialog: I can't see the contents of my home directory.

skippy (skippy) wrote :

A full re-install of Ubuntu 8.04 did not resolve this problem: random dbus crashes occurred within hours of logging into the freshly-installed copy.

uga (yegor-jbanov) wrote :

Hi Skippy,

I suggest that you post your hardware specs here as it seems there is a serious incompatibility issue with your hardware.

skippy (skippy) wrote :
Download full text (3.4 KiB)

It's a Hewlett Packard xw4400 workstation. Below are /proc/cpuinfo and `lspci`. If there's something else you need to see, please let me know. Alas, I've installed Red Hat Enterprise Linux Desktop 5 so that I can use this machine without interruption. I'll happily re-install Ubuntu if/when this situation is resolved.

$ cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
stepping : 6
cpu MHz : 1596.000
cache size : 4096 KB
physical id : 0
siblings : 2
core id : 0
cpu cores : 2
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx est tm2 cx16 xtpr lahf_lm
bogomips : 4803.55
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

processor : 1
vendor_id : GenuineIntel
cpu family : 6
model : 15
model name : Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
stepping : 6
cpu MHz : 1596.000
cache size : 4096 KB
physical id : 0
siblings : 2
core id : 1
cpu cores : 2
fpu : yes
fpu_exception : yes
cpuid level : 10
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm syscall nx lm constant_tsc pni monitor ds_cpl vmx est tm2 cx16 xtpr lahf_lm
bogomips : 4800.09
clflush size : 64
cache_alignment : 64
address sizes : 36 bits physical, 48 bits virtual
power management:

$ /sbin/lspci
00:00.0 Host bridge: Intel Corporation 82975X Memory Controller Hub
00:01.0 PCI bridge: Intel Corporation 82975X PCI Express Root Port
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1c.4 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 5 (rev 01)
00:1c.5 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express Port 6 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 RAID bus controller: Intel Corporation 82801GR/GH (ICH7 Family) SATA RAID Controller (rev 01)
01:00.0 VGA co...

Read more...

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers