[i915] Unfortunate Selection of Primary Display on Dell Latitude X1 (i915GMS) with a Dell 2405FPW connected to the VGA port

Bug #134669 reported by Andreas Schildbach on 2007-08-25
20
This bug affects 2 people
Affects Status Importance Assigned to Milestone
X.Org X server
Fix Released
Unknown
gnome-control-center (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: xserver-xorg-video-intel

Gutsy Tribe 5, on a Dell Latitude X1 (i915GMS) with a Dell 2405FPW connected to the VGA port:

$ xrandr
VGA connected 1920x1200+0+0 [... this is my external Dell 2405 FPW ...]
   [...]
LVDS connected 1280x768+0+0 [... this is the internal display on my Notebook ...]
   [...]

I suspect the ordering of this randr 1.2 query results is responsible for Ubuntu to treat the external display as primary. This is leads to some problems, mainly having important use interface elements (popups, gdm login, taskbar) unaccessible if your screen is connected but not switched on.

I'd like to propose that in typical "laptop+external monitor" configurations, the internal display of the laptop should always be primary (and listed first in enumerations).

Bryce Harrington (bryce) on 2007-10-20
Changed in xserver-xorg-video-intel:
importance: Undecided → Medium
status: New → Confirmed
slazZ (slazz) wrote :

Can confirm this.
Is there a workarround to flip the primary?

Brian Pitts (bpitts) wrote :

Confirmed.

David de Hoog (daviddehoog) wrote :

As far as I know, it's a "feature" of the Intel driver that the external monitor has to be the primary display:
http://www.thinkwiki.org/wiki/Xorg_RandR_1.2#Notes_for_X31.2CT30_.2F_Radeon_7000.2CRadeon_7500_users
http://www.intellinuxgraphics.org/dualhead.html
The detail here:
http://lists.freedesktop.org/archives/xorg/2007-August/027670.html

NB: I have similar issues with my (open-source driver) ATI Radeon-driven ThinkPad T42. These issues occur in both Windows XP and Linux (any flavour).

As a work-around, I'd suggest writing a small script (which is run at login to your profile) that checks if the VGA-0 device is "connected" before configuring multiple screens ... See for example: http://ubuntuforums.org/showthread.php?t=581947&highlight=Dual+Head

Andreas Schildbach (schildbach) wrote :

Im afraid your script wouldn't help much, because connected but switched off displays are also detected via randr.

Changed in xorg-server:
status: Unknown → Confirmed
Bryce Harrington (bryce) wrote :

[This is an automatic notice.]

We'd like to forward your bug upstream, however upstream requires
that you first test it against their newer driver code.

To save you the effort of building the driver from source, we've built
packages for the driver and its new dependencies.

So you have a couple options:

 1. Download and test .debs for intrepid, from:
     https://edge.launchpad.net/~intel-gfx-testing/+archive

 -or-

 2. Download and test the Jaunty alpha-2 (or newer) Live CD,
     (which includes a beta of the new xserver 1.6 as well).
     See http://cdimage.ubuntu.com/releases/9.04/ for ISOs

Thanks ahead of time! You can simply reply to this email to report your
findings.

P.S., if you wish to forward your bug upstream yourself, please follow
these directions to do so:
  http://intellinuxgraphics.org/how_to_report_bug.html

Changed in xserver-xorg-video-intel:
status: Confirmed → Incomplete
Bryce Harrington (bryce) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in xserver-xorg-video-intel:
status: Incomplete → Invalid
Andreas Schildbach (schildbach) wrote :

On Jaunty alpha 3, the behaviour is still the same.

Changed in xserver-xorg-video-intel:
status: Invalid → Confirmed
Bryce Harrington (bryce) on 2009-01-28
Changed in xserver-xorg-video-intel:
status: Confirmed → Triaged
Andrew Ash (ash211) wrote :

David's link to the FreeDesktop mailing list should actually be:
http://lists.freedesktop.org/archives/xorg/2007-August/027498.html

It appears that the LVDS (laptop) display can only be set to crtc 1, not the first (crtc 0). This causes attached monitors to be placed at crtc 0. Then Gnome defaults to putting the menubar and user interface on the first xinerama output, which is the exterior monitor. It seems like the best way to approach this issue is something with a script run on Gnome startup to try to set user interface elements to be placed on the correct screen.

But I'm no expert, so this could all be off.

A very good resource on this issue is here:
http://www.thinkwiki.org/wiki/Xorg_RandR_1.2#Xorg_mailing_list

xrandr allows you to set a primary output now (see the --primary option), so it sounds like this is really an RFE for the GNOME display applet to support this feature, if it doesn't already.

Changed in xorg-server:
status: Confirmed → Fix Released
Bryce Harrington (bryce) wrote :

[Retargeting as per comment #9]

affects: xserver-xorg-video-intel (Ubuntu) → gnome-control-center (Ubuntu)
Changed in gnome-control-center (Ubuntu):
status: Triaged → New
Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

Changed in gnome-control-center (Ubuntu):
importance: Medium → Wishlist
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.