Gnome-Control-Panel fails to install functional Canon MP280 driver

Bug #1248105 reported by Cefn on 2013-11-05
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Unassigned

Bug Description

I attempted to use Gnome-Control-Center to install a USB-attached Canon MP280 printer and it failed.

I then proceeded to install the .deb packages using gdebi which were hidden inside the tar.gz package from http://support-nz.canon.co.nz/contents/NZ/EN/0100301402.html [incidentally the ./install.sh logic inside the tar.gz aiming to automate this process fails now that both rpm and deb are installed on Ubuntu - violating it's implicit assumptions].

I'm not sure if the MP280 driver was even needed, as I believe the same error was delivered by gnome-control-center before and after installing this package. The error from the console reads...

(gnome-control-center:21465): printers-cc-panel-WARNING **: Installation of the new printer failed.

However, I was disappointed to find that logging in to CUPS (localhost:631) and installing the printer that way worked first time. There's some kind of issue with gnome-control-center not being able to add the appropriate CUPS printer driver and it's impossible to tell what because of the terrible error reporting it provides (hiding the originating issue).

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: gnome-control-center 1:3.6.3-0ubuntu44
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic i686
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: i386
Date: Tue Nov 5 10:12:52 2013
InstallationDate: Installed on 2013-10-29 (7 days ago)
InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Release i386 (20131017)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_GB:en
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_gnome-control-center: deja-dup 27.3.1-0ubuntu1

Cefn (6-launchpad-net-cefn-com) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Setting as "low", we don't use that g-c-c panel by default because it's not quality ready, I guess you use a non default session there...

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
Cefn (6-launchpad-net-cefn-com) wrote :

Thanks, Sebastien.

I'm using Ubuntu Gnome and as far as I know, that's the only Printer control panel I have. Is it unsupported? What is in fact supported?

For the debugging report, I may have launched an unusual session (by running 'gnome-control-center printers') from the command line, because I wanted a better error report than 'printer install has failed'. However the same error was reported to the console too, with no more details, hence my concern.

Sebastien Bacher (seb128) wrote :

> Is it unsupported? What is in fact supported?

Under Unity we use system-config-printer, it should work fine under GNOME as well

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers