Can't set keyboard layout change to Alt+Shift

Bug #1245926 reported by Vaclav Cermak on 2013-10-29
96
This bug affects 20 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Unassigned

Bug Description

In Ubuntu 12.04 I was able to set keyboard layout switching shortcut to Alt+Shift.
In Ubuntu 13.10 I can't set it from gnome-control-center/Text Entry.

And the default "Super + Space" combination does not work as well (this is bug 1245136).

----------
For other layout switching problems introduced in Ubuntu 13.10 you can see bug 1218322.
----------
---
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
DistroRelease: Ubuntu 13.10
InstallationDate: Installed on 2013-02-27 (244 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
NonfreeKernelModules: nvidia
Package: gnome-control-center 1:3.6.3-0ubuntu44
PackageArchitecture: amd64
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Tags: saucy
Uname: Linux 3.11.0-12-generic x86_64
UpgradeStatus: Upgraded to saucy on 2013-10-29 (0 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
usr_lib_gnome-control-center:
 activity-log-manager 0.9.7-0ubuntu4
 deja-dup 27.3.1-0ubuntu1
 gnome-control-center-datetime 13.10.0+13.10.20131016.2-0ubuntu1
 gnome-control-center-signon 0.1.7~+13.10.20130724.1-0ubuntu1
 gnome-control-center-unity 1.3+13.10.20131004-0ubuntu1

Norbert (nrbrtx) wrote :

Thank you, Vaclav! I updated description of bug 1218322.

tags: added: saucy
Norbert (nrbrtx) on 2013-10-29
description: updated
Norbert (nrbrtx) wrote :

You can add some logs to this bug report by executing 'apport-collect 1245926' in terminal from installed Ubuntu Saucy.

Also - reporting bugs from running Ubuntu system is simpler. For example, this bug may be reported with 'apport-bug gnome-control-center'.

apport information

tags: added: apport-collected
description: updated

apport information

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Norbert (nrbrtx) on 2013-10-31
tags: added: keyboard-layout-switching-hotkeys
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Could you try with the current version in saucy-updates and saucy-proposed? Setting alt-shift works for me there

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Norbert (nrbrtx) wrote :

With latest packages (gnome-control-center 1:3.6.3-0ubuntu45.1, gnome-settings-daemon 3.8.5-0ubuntu11.1.) Alt+Shift works.

Changed in gnome-control-center (Ubuntu):
status: Incomplete → Fix Released
Nikolay Yordanov (nyordanov) wrote :

Alt+Shift still doesn't work for me (using the latest versions in saucy-proposed).

Vassili Platonov (vassilip) wrote :

In saucy there are no problems.

But in trusty I found some strange behavior of g-c-c/Text entry:
1) there is [Alt+Shift_L] in g-c-c/Text entry
2) getting preference of 'org.freedesktop.ibus.general.hotkey next-engine' set it to ['Alt+Shift_L']
3) default settings in '/etc/default/keyboard' are 'XKBOPTIONS="grp:alt_shift_toggle,grp_led:scroll"'

But after each log in I can switch on next layout by [Shift+Alt_L] only (i.e. I should hold Shift first then press Alt and release), not [Alt+Shift_L].

Is there a bug in trusty or in g-s-d?

gnome-settings-daemon: 3.8.6.1-0ubuntu2
gnome-control-center: 1:3.6.3-0ubuntu46

Vassili Platonov (vassilip) wrote :

How can I try g-c-c 1:3.6.3-0ubuntu48 ?
Sebastian had uploaded it to main on 2013-11-29.
Since g-c-c 1:3.6.3-0ubuntu45.2 released (November, 19), I have difficulty to set layout to 'Alt+Shift_L'. Each relogin returns me to 'Shift+Alt_L'.
~$ apt-cache policy gnome-control-center
gnome-control-center:
  Установлен: 1:3.6.3-0ubuntu45.2
  Кандидат: 1:3.6.3-0ubuntu45.2
  Таблица версий:
 *** 1:3.6.3-0ubuntu45.2 0
        500 http://archive.ubuntu.com/ubuntu/ saucy-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     1:3.6.3-0ubuntu45.1 0
        500 http://archive.ubuntu.com/ubuntu/ saucy-updates/main amd64 Packages
     1:3.6.3-0ubuntu44 0
        500 http://archive.ubuntu.com/ubuntu/ saucy/main amd64 Packages

Shahar Or (mightyiam) wrote :

I confirm Vasili's finding that shift has to be the first press in trusty.

Shahar Or (mightyiam) wrote :

I've reported bug 1266179 for that.

Charis Kouzinopoulos (charis) wrote :

I am affected in saucy. I can't set "Switch to next source" to "Alt+Shift" either by pressing Alt first, pressing Shift first or pressing both keys simultaneously

Doctor Rover (doctor-rover) wrote :

The terrible thing is that shift-has -to-be-pressed-first bug 1266179 (https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/1266179) has just suddenly appeared again in saucy!

Serge (chapkin) wrote :

I confirm that as stated above, I CAN set language switch to ALT SHIFT L and WORKS like it shoud TILL THE NEXT LOG IN.
After the next log in ALT+SHIFT stops working, but SHIFT+ALT( Shift first) works.

using 13.10 x64 on over 5 machines, all are updated regulargly from official repos, all are affected, the behaviour is just the same.
If you set combination again to be ALT+SHIFT then it works again till the next log in.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers