Can't set keyboard layout change to Shift+Shift

Bug #1245272 reported by Norbert on 2013-10-27
42
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Unassigned

Bug Description

In Ubuntu 12.04 I was able to set keyboard layout switching shortcut to Shift+Shift.
In Ubuntu 13.10 I can't set it from gnome-control-center keyboard.
----------
For other layout switching problems introduced in Ubuntu 13.10 you can see bug 1218322.
----------

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: gnome-control-center 1:3.6.3-0ubuntu45
ProcVersionSignature: Ubuntu 3.11.0-13.20-generic 3.11.6
Uname: Linux 3.11.0-13-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: i386
Date: Mon Oct 28 00:32:03 2013
InstallationDate: Installed on 2013-10-20 (7 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Release i386 (20131016.1)
MarkForUpload: True
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_gnome-control-center:
 activity-log-manager 0.9.7-0ubuntu4
 deja-dup 27.3.1-0ubuntu1
 gnome-control-center-datetime 13.10.0+13.10.20131016.2-0ubuntu1
 gnome-control-center-signon 0.1.7~+13.10.20130724.1-0ubuntu1
 gnome-control-center-unity 1.3+13.10.20131004-0ubuntu1

Norbert (nrbrtx) wrote :
Norbert (nrbrtx) wrote :

Installed packages from ppa:attente/1218322
(
gnome-control-center 3.6.3-0ubuntu45ppa1
gnome-control-center-data 3.6.3-0ubuntu45ppa1
libgnome-control-center1 3.6.3-0ubuntu45ppa1
)
Now I can set Shift+Shift (indicates as Shift+Shift R) and use them.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Norbert (nrbrtx) on 2013-10-29
description: updated
Norbert (nrbrtx) on 2013-10-31
tags: added: keyboard-layout-switching-hotkeys
Felipe Castillo (fcastillo.ec) wrote :

I can say that this has been fixed with package version 1:3.6.3-0ubuntu45.1 from the proposed repository. I'm following the same information as the original bug and tagging this one as verification-done.
I tested it in various applications and all works flawlessly.

tags: added: verification-done
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, is that still an issue with the current SRU versions?

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: Confirmed → Incomplete
Norbert (nrbrtx) wrote :

With latest packages (gnome-control-center 1:3.6.3-0ubuntu45.1, gnome-settings-daemon 3.8.5-0ubuntu11.1.) Shift+Shift works.

Changed in gnome-control-center (Ubuntu):
status: Incomplete → Fix Released
Ross Golder (ross-golder) wrote :

With latest packages (gnome-control-center 1:3.6.3-0ubuntu45.1, gnome-settings-daemon 3.8.5-0ubuntu11.1.) Shift+Shift still does not work for me. When I try to set it in thecontrol panel UI, it sets it as 'Disabled'.

Also, even though it's marked as Disabled in the control panel, the keyboard indicator applet still changes between the two sources when Shift+Shift are pressed - however, the source doesn't actually change - so regardless of what is displayed in the indicator, it keeps typing in the original source. It seems I have to grab the mouse and change the layout using the keyboard indicator, which is fairly frustrating/confusing.

Another unusual behaviour is that, despite only having 'US International' and 'Thai' chosen for layouts in the control panel, I seem to randomly end up in a UK layout (shift-3 being a UK pound sign), and have to grab for the mouse again to get back to US. I have language set to 'English (United Kingdom)'), but that should not affect the keyboard layout, should it? Can anyone shed any light on this unexpected behaviour?

Vassili Leonov (vleolml) wrote :

Shift + Shift works in Ubuntu 14.04.1,

but now it does not work in Ubuntu 14.10 beta 1

Norbert (nrbrtx) wrote :

Works for me in Ubuntu Utopic 14.10 final in Unity session.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers