[background]: gnome-control-center crashed with SIGSEGV in g_type_check_instance_cast()

Bug #1196196 reported by Stephen Morrish on 2013-06-30
108
This bug affects 12 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Medium
Unassigned

Bug Description

Changing wallpaper, As this is a fresh install of Ubuntu-Gnome Saucy not sure if this is a new bug or a re-occurrence of an old one...

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: gnome-control-center 1:3.6.3-0ubuntu29
ProcVersionSignature: Ubuntu 3.10.0-1.8-generic 3.10.0-rc7
Uname: Linux 3.10.0-1-generic x86_64
ApportVersion: 2.10.2-0ubuntu3
Architecture: amd64
Date: Sun Jun 30 09:31:05 2013
ExecutablePath: /usr/bin/gnome-control-center
InstallationDate: Installed on 2013-06-29 (0 days ago)
InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Alpha amd64 (20130629)
MarkForUpload: True
ProcCmdline: gnome-control-center background
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x7f0236567fec <g_type_check_instance_cast+28>: mov (%rax),%rdi
 PC (0x7f0236567fec) ok
 source "(%rax)" (0xaaaaaaaaaaaaaaaa) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: gnome-control-center
StacktraceTop:
 g_type_check_instance_cast () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/control-center-1/panels/libbackground.so
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: [background]: gnome-control-center crashed with SIGSEGV in g_type_check_instance_cast()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
usr_lib_gnome-control-center: deja-dup 27.3.1-0ubuntu1

Related branches

StacktraceTop:
 g_type_check_instance_cast (type_instance=type_instance@entry=0x7f0238c31030, iface_type=139647518830528) at /build/buildd/glib2.0-2.37.3/./gobject/gtype.c:4008
 dir_enum_async_ready (source=0x7f0238928b80, res=0x7f0238be2c10, user_data=user_data@entry=0x7f0238c31030) at bg-pictures-source.c:456
 g_task_return_now (task=0x7f0238be2c10) at /build/buildd/glib2.0-2.37.3/./gio/gtask.c:1108
 complete_in_idle_cb (task=0x7f0238be2c10) at /build/buildd/glib2.0-2.37.3/./gio/gtask.c:1117
 g_main_dispatch (context=0x7f023881d0d0) at /build/buildd/glib2.0-2.37.3/./glib/gmain.c:3058

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1196196

tags: added: iso-testing
Jeremy Bicha (jbicha) on 2013-07-24
information type: Private → Public
Tim Lunn (darkxst) wrote :

To reproduce this crash, go into gnome background panel and select a new background before the thumbnails have finished loading. I have no idea why the thumbnails are loading really really slowly, however if you wait a while so all images are loaded then selecting a new background does not cause it to crash.

This only happens in 3.6.3, I cannot reproduce is 3.8, however I also can't see any obvious differences in the code that might affect this.

tags: added: bugpattern-needed
Martin Pitt (pitti) wrote :

The fix was committed to the packaging bzr; uploading this is blocked by landing indicator-keyboard, but that should happen today. Anyway, nothing further to be done for sponsors here, unsubscribing.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.6.3-0ubuntu31

---------------
gnome-control-center (1:3.6.3-0ubuntu31) saucy; urgency=low

  [ Jeremy Bicha ]
  * debian/control.in:
    - Build-depend on cheese for webcam integration in User Accounts panel
      (LP: #853994)
    - Don't build-depend on gnome-doc-utils
    - Depend on minimum gnome-settings-daemon built with ibus
  * debian/patches/git-rename-bluetooth-panel.patch:
    - Rename the bluetooth panel to its 3.8 filename so that the
      Bluetooth Settings link in GNOME Shell 3.8 works

  [ William Hua ]
  * debian/control.in:
    - Add IBus (build) dependency.
  * debian/rules:
    - Enable IBus.
  * debian/patches/revert_new_ibus_keyboard_use.patch:
  * debian/patches/10_keyboard_layout_on_unity.patch:
    - Drop patches, use input sources panel.
  * debian/patches/rename_screenshot_media_keys.patch:
    - Since Ubuntu's gnome-screenshot doesn't save to the Pictures directory
      automatically, don't say that it does in Keyboard>Shortcuts
  * debian/patches/input-sources-text-entry.patch:
    - Implement text entry panel by modifying input sources panel.

  [ Tim Lunn ]
  * debian/patches/git-fix-background-panel-crash.patch:
    git patch to fix crash after selecting new background in gnome
    background panel (LP: #1196196)
 -- William Hua <email address hidden> Wed, 21 Aug 2013 11:24:36 -0400

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Released
markb (mark-blakeney) wrote :

It says above that this bug was fixed in gnome-control-center 1:3.6.3-0ubuntu31 but I cleanly installed Ubuntu GNOME 13.10 today with gnome-control-center 1:3.8.3-0ubuntu1~saucy2 and it still crashes as soon as I try to change the background. I see the following segfault each time in my syslog:

Oct 21 22:16:24 pc kernel: [17906.827359] gnome-control-c[8265]: segfault at 7f416bf72000 ip 00007f4162a1b664 sp 00007fffdc71f880 error 4 in libgdk-3.so.0.1000.0[7f41629ee000+ab000]

Iain Lane (laney) wrote :

Hi markb, I'm afraid we can't help with bugs from PPA packages. Please see if this still happens if you purge the PPA from your system. If it does, then please report a new bug. Otherwise you can take it up with the Ubuntu GNOME guys independently.

Tim Lunn (darkxst) wrote :

Hi markb,
Can't do anything much without a backtrace.
So please file a new bug using the apport crash popup or find the crash file under
/var/crash/_usr_bin_gnome-control-center...crash
and then run `ubuntu-bug <file>`

markb (mark-blakeney) wrote :

Tim, in the process of doing that I discovered that this problem seems to be not directly due to gnome-control-center so I won't raise a bug on the crash. I will append a comment on my Ubuntu GNOME list post which presumably is what pointed you here.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers