[power]: gnome-control-center crashes if indicator-power is not installed in Unity

Bug #1195481 reported by Jeremy Bicha
128
This bug affects 13 people
Affects Status Importance Assigned to Milestone
One Hundred Papercuts
Fix Released
High
Papercuts Ninjas
gnome-control-center (Ubuntu)
Fix Released
High
Iain Lane
Saucy
Fix Released
High
Iain Lane

Bug Description

[ Description ]

gnome-control-center's power panel crashes when indicator-power isn't installed.

[ Test case ]

1. Uninstall indicator-power
2. Open System Settings and click Power
3. System Settings crashes

At 3 it shouldn't crash. If you have indicator-power installed, you should see the option to configure whether it shows.

[ Regression potential ]

This adds some new code to check if the GSettings schema is installed, since
that's a reliable way to check for indicator-power's presence, and is what the
code modifies. It also makes the option appear in DEs other than Unity.

There's a chance that the GSettings schema-detection work could be wrong. It
also wouldn't hurt to check non-Unity environments such as a gnome-panel
session.

[ Original report ]

I see that unity recommends indicator-power; let's make it a depends instead.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: gnome-control-center 1:3.6.3-0ubuntu29
ProcVersionSignature: Ubuntu 3.9.0-7.15-generic 3.9.7
Uname: Linux 3.9.0-7-generic x86_64
NonfreeKernelModules: ufs qnx4 hfsplus hfs minix ntfs msdos jfs xfs reiserfs ext2 overlayfs nls_utf8 isofs pci_stub vboxpci vboxnetadp vboxnetflt vboxdrv parport_pc ppdev rfcomm bnep dm_crypt intel_powerclamp coretemp kvm_intel kvm joydev crc32_pclmul ghash_clmulni_intel arc4 cryptd ath9k dm_multipath scsi_dh ath9k_common ath9k_hw uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core ath snd_hda_codec_hdmi snd_hda_codec_conexant mac80211 snd_hda_intel videodev ath3k btusb snd_hda_codec bluetooth cfg80211 snd_hwdep snd_pcm psmouse microcode toshiba_acpi toshiba_bluetooth serio_raw sparse_keymap snd_page_alloc snd_seq_midi snd_seq_midi_event snd_rawmidi snd_seq snd_seq_device snd_timer snd mei soundcore lpc_ich mac_hid lp parport btrfs xor zlib_deflate raid6_pq libcrc32c dm_mirror dm_region_hash dm_log ums_realtek usb_storage i915 i2c_algo_bit drm_kms_helper drm atl1c ahci libahci wmi video
ApportVersion: 2.10.2-0ubuntu3
Architecture: amd64
Date: Thu Jun 27 17:42:04 2013
ExecutablePath: /usr/bin/gnome-control-center
InstallationDate: Installed on 2013-06-14 (13 days ago)
InstallationMedia: Ubuntu-GNOME 13.10 "Saucy Salamander" - Alpha amd64 (20130613)
MarkForUpload: True
ProcCmdline: gnome-control-center
Signal: 5
SourcePackage: gnome-control-center
StacktraceTop:
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_new_valist () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_object_new () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/control-center-1/panels/libpower.so
Title: [power]: gnome-control-center crashed with signal 5 in g_object_new_valist()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sbuild sudo
usr_lib_gnome-control-center:
 activity-log-manager-control-center 0.9.5-0ubuntu1
 deja-dup 27.3.1-0ubuntu1
 gnome-control-center-signon 0.1.7~+13.10.20130625-0ubuntu1
 gnome-control-center-unity 1.3daily13.06.14.1-0ubuntu1
 indicator-datetime 12.10.3daily13.06.19-0ubuntu1

Related branches

Revision history for this message
Jeremy Bicha (jbicha) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 g_settings_set_property (object=<optimized out>, prop_id=<optimized out>, value=<optimized out>, pspec=<optimized out>) at /build/buildd/glib2.0-2.37.3/./gio/gsettings.c:492
 object_set_property (nqueue=0x7f9e84039660, value=<optimized out>, pspec=0x7f9e8412b850, object=0x7f9e84055ba0) at /build/buildd/glib2.0-2.37.3/./gobject/gobject.c:1363
 g_object_new_internal (class=class@entry=0x7f9e8412ecd0, params=params@entry=0x7fff9cce3c50, n_params=1) at /build/buildd/glib2.0-2.37.3/./gobject/gobject.c:1776
 g_object_new_valist (object_type=object_type@entry=140318797394272, first_property_name=first_property_name@entry=0x7f9e811b19d3 "schema-id", var_args=var_args@entry=0x7fff9cce3da8) at /build/buildd/glib2.0-2.37.3/./gobject/gobject.c:1999
 g_object_new (object_type=140318797394272, first_property_name=first_property_name@entry=0x7f9e811b19d3 "schema-id") at /build/buildd/glib2.0-2.37.3/./gobject/gobject.c:1556

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Jeremy Bicha (jbicha)
information type: Private → Public
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Changed in unity (Ubuntu):
status: New → Confirmed
Revision history for this message
Anca Emanuel (anca-emanuel) wrote :

sudo apt-get install indicator-power
[sudo] password for emanuel:
Reading package lists... Done
Building dependency tree
Reading state information... Done
indicator-power is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

I do not think the bug 1215474 is a duplicate of this. I used the language switch yesterday before upgrade.

tags: added: bugpattern-needed
Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

Since this bug renders essential features or functionality of the application or dependencies broken or ineffective, it has a priority of 'High'.

Changed in gnome-control-center (Ubuntu):
importance: Medium → High
Changed in unity (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
Changed in hundredpapercuts:
status: New → Confirmed
assignee: nobody → Paper Cuts Ninja (papercuts-ninja)
Iain Lane (laney)
Changed in unity (Ubuntu):
status: Triaged → Invalid
Changed in gnome-control-center (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Iain Lane (laney)
Iain Lane (laney)
description: updated
Revision history for this message
Adam Conrad (adconrad) wrote : Please test proposed package

Hello Jeremy, or anyone else affected,

Accepted gnome-control-center into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-control-center/1:3.6.3-0ubuntu45 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote : [gnome-control-center/saucy] possible regression found

As a part of the Stable Release Updates quality process a search for Launchpad bug reports using the version of gnome-control-center from saucy-proposed was performed and bug 1245199 was found. Please investigate this bug report to ensure that a regression will not be created by this SRU. In the event that this is not a regression remove the "verification-failed" tag from this bug report and tag 1245199 "bot-stop-nagging". Thanks!

tags: added: verification-failed
Changed in hundredpapercuts:
status: Confirmed → Triaged
importance: Undecided → Low
Revision history for this message
Iain Lane (laney) wrote :

That's nothing to do with this change

tags: removed: verification-failed
no longer affects: unity (Ubuntu)
Revision history for this message
Sebastien Bacher (seb128) wrote :

Testing the proposed version, it does fix the issue

tags: added: verification-done
removed: verification-needed
Changed in hundredpapercuts:
status: Triaged → In Progress
Changed in gnome-control-center (Ubuntu Saucy):
importance: Undecided → High
status: New → In Progress
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Changed in gnome-control-center (Ubuntu Saucy):
assignee: nobody → Iain Lane (laney)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.6.3-0ubuntu45

---------------
gnome-control-center (1:3.6.3-0ubuntu45) saucy; urgency=low

  [ Iain Lane ]
  * debian/patches/97_unity_power_ui.patch: Don't crash if indicator-power
    isn't installed. When deciding whether to display/not display the
    indicator-power options, use the presence of indicator-power instead of
    just checking if Unity is the DE in use. (LP: #1195481)
  * debian/control.in: Build-Depend on glib >= 2.31.2 for
    g_settings_schema_source_ref.

  [ William Hua ]
  * debian/patches/input-sources-text-entry.patch:
    - support modifier-only input-source switching (lp: #1218322)
 -- Iain Lane <email address hidden> Fri, 18 Oct 2013 12:47:01 +0100

Changed in gnome-control-center (Ubuntu Saucy):
status: In Progress → Fix Released
Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Released
Changed in hundredpapercuts:
status: In Progress → Fix Released
importance: Low → High
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

Since https://errors.ubuntu.com/problem/ffc5f8523b653f5864bfae1e20b19c59114016c9 is still happening in jammy and kinetic I will redirect this to a new bug 1989312.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.