Unable to save mouse speed setting

Bug #1186666 reported by Sah Lee on 2013-06-02
86
This bug affects 37 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Medium
gnome-control-center (Ubuntu)
Low
Unassigned
Raring
Low
Unassigned
Saucy
Low
Unassigned

Bug Description

To reproduce:

1. Click on "Gear button"; select "System Settings...".
2. Click on "Mouse & Touchpad".
3. Drag that "indicator" (I don't know what is it in English, sorry...) to the left end on the bar besides "Pointer speed"
4. Close the window.
5. Re-do step 1 and 2.

Expected:

The indicator is at the left end of bar as we just put it there.

Actually:
The indicator is at the same old position as if we didn't perform step 3.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: gnome-control-center 1:3.6.3-0ubuntu24
ProcVersionSignature: Ubuntu 3.8.0-23.34-generic 3.8.11
Uname: Linux 3.8.0-23-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.9.2-0ubuntu8
Architecture: amd64
Date: Sun Jun 2 11:24:00 2013
ExecutablePath: /usr/bin/gnome-control-center
InstallationDate: Installed on 2012-08-12 (294 days ago)
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
MarkForUpload: True
ProcEnviron:
 XDG_RUNTIME_DIR=<set>
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SourcePackage: gnome-control-center
UpgradeStatus: Upgraded to raring on 2013-04-26 (36 days ago)
XsessionErrors: (process:2826): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
usr_lib_gnome-control-center:
 activity-log-manager-control-center 0.9.4-0ubuntu6.1
 deja-dup 26.0-0ubuntu1
 gnome-control-center-signon 0.1.6bzr13.04.05-0ubuntu1.1
 gnome-control-center-unity 1.2daily13.04.09-0ubuntu1
 indicator-datetime 12.10.3daily13.03.26-0ubuntu1

Sah Lee (leesah) wrote :
Rajiv Shah (rajivshah3) on 2013-06-03
Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-control-center:
status: New → Invalid
Jeremy Bicha (jbicha) on 2013-09-11
Changed in gnome-control-center:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Jeremy Bicha (jbicha) on 2013-09-11
Changed in gnome-control-center (Ubuntu Raring):
importance: Undecided → Low
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.6.3-0ubuntu36

---------------
gnome-control-center (1:3.6.3-0ubuntu36) saucy; urgency=low

  * git_hide_unavailable_layout_settings_button.patch:
    - Only show layout settings button when it's usable
      (i.e. for certain ibus input methods) since it's too confusing
      to have the button visible but insensitive
  * git_show_per_window_input_settings.patch:
    - Show separate-layout-per-window option for GNOME too
  * git_restore_mouse_speed.patch:
    - Restore mouse & touchpad pointer speed (LP: #1186666)
 -- Jeremy Bicha <email address hidden> Wed, 11 Sep 2013 11:11:08 -0400

Changed in gnome-control-center (Ubuntu Saucy):
status: Triaged → Fix Released
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Fix Released
Christopher Townsend (townsend) wrote :

This bug has been bothering the heck out of me since I got a new mouse. I saw that it is fixed in Saucy and who knows if and when the fix will be SRU'd to Raring. So I backported the fix from Saucy into Raring and put it in my PPA.

If you are affected by this, you can add my PPA from here (https://launchpad.net/~townsend/+archive/gnome-control-center-test) and give it a try.

Rolf Leggewie (r0lf) wrote :

raring has seen the end of its life and is no longer receiving any updates. Marking the raring task for this ticket as "Won't Fix".

Changed in gnome-control-center (Ubuntu Raring):
status: Triaged → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.