mouse preferences acceleration not saving

Bug #118593 reported by bubba_84120 on 2007-06-04
14
Affects Status Importance Assigned to Milestone
gnome-control-center (Debian)
Fix Released
Unknown
gnome-control-center (Ubuntu)
Low
Ubuntu Desktop Bugs
gnome-panel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-panel

In the System, Preferences, Mouse. The acceleration setting in the motion tab is not saving - it seems to be stuck on Slow.

ProblemType: Bug
Architecture: i386
Date: Sun Jun 3 21:39:21 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/gnome-panel
Package: gnome-panel 1:2.18.1-0ubuntu3.1
PackageArchitecture: i386
ProcCmdline: gnome-panel --sm-client-id default1
ProcCwd: /home/jason
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-panel
Uname: Linux IBM-2 2.6.20-16-generic #2 SMP Wed May 23 01:46:23 UTC 2007 i686 GNU/Linux

bubba_84120 (bubba-84120) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug. What sort of device do you use? Do you need a special module for it? Does changing the acceleration has any visible effect?

Changed in gnome-panel:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: Unconfirmed → Needs Info

Thanks for the reply.

It is a PS2 mouse attached to an IBM NetVista PC. After the initial installation, the mouse speed was normal. After going in to change the acceleration setting, the speed of the cursor when moving the mouse is stuck at very slow. The acceleration slider will still move left and right, but it now has no effect on the actual spped of the cursor.

I hope this answers your question.

----- Original Message ----
From: Sebastien Bacher <email address hidden>
To: <email address hidden>
Sent: Tuesday, June 12, 2007 1:50:12 PM
Subject: [Bug 118593] Re: mouse preferences acceleration not saving

Thank you for your bug. What sort of device do you use? Do you need a
special module for it? Does changing the acceleration has any visible
effect?

** Changed in: gnome-control-center (Ubuntu)
Sourcepackagename: gnome-panel => gnome-control-center
   Importance: Undecided => Low
     Assignee: (unassigned) => Ubuntu Desktop Bugs
       Status: Unconfirmed => Needs Info

--
mouse preferences acceleration not saving
https://bugs.launchpad.net/bugs/118593
You received this bug notification because you are a direct subscriber
of the bug.

____________________________________________________________________________________
Don't pick lemons.
See all the new 2007 cars at Yahoo! Autos.
http://autos.yahoo.com/new_cars.html

Bryan McLellan (btm) wrote :

I've had this issue as well for a while. I've been overriding gnome-control-center with 'xset m default'.

Mouse speed is normal at gdm. When I log in, it immediately goes to a crawl. 'xset q | grep accel' reports acceleration: 3/10 threshold: 0.

If I remove .gconf/desktop/gnome/peripherals/mouse/%gconf.xml and log out, the problem does not re-occur on next log in until I open the mouse applet again. When I first open the mouse applet the slider is in the middle. If I move it, it goes to the left and my mouse speed is back to 3/10. When running gnome-control-panel in the foreground of a shell, the mouse applet reports:

(gnome-mouse-properties:8550): capplet-common-WARNING **: Unable to find a default value for key for /desktop/gnome/peripherals/mouse/motion_acceleration.
I'll assume it is an integer, but that may break things.
Please be sure that the associated schema is installed

(gnome-mouse-properties:8550): GConf-CRITICAL **: gconf_value_free: assertion `value != NULL' failed

(gnome-mouse-properties:8550): GConf-CRITICAL **: gconf_value_get_float: assertion `value->type == GCONF_VALUE_FLOAT' failed

After modification of the acceleration slider, .gconf/desktop/gnome/peripherals/mouse/%gconf.xml contains the following line (among others):

        <entry name="motion_acceleration" mtime="1181840944" type="float" value="0.20000000298023224">

Note that 'xset q | grep accel' returns acceleration: 2/1 and threshold: 4 after 'xset m default'

It may be worth noting that I have a similar problem with keyboard autorepeat.

Sebastien Bacher (seb128) wrote :

that's not a gnome-panel bug

Changed in gnome-panel:
status: New → Invalid
Changed in gnome-control-center:
status: Incomplete → New
Stephan Ruegamer (sadig) wrote :

Sebastien,

I have the same bug, plain normal usb mouse...on all machines I have.
saving the accel setting doesn't work..settings don't have any effects on it.

Regards,

\sh

goto (gotolaunchpad) wrote :

I had this bug as well, with my synaptics touchpad. I understand the mouse and touchpad settings are different, but I'm going with my experience from Fedora where adjusting the mouse speed fixed the speed immediately for the touchpad.

For Ubuntu, I resolved it by adjusting AccelFactor with synclient and saving the setting in xorg.conf. Anybody who's not following what I'm saying can leave a comment at http://kkvv.wordpress.com/2007/09/29/3/ and I'll try to help. But, unfortunately, this is not a solution for those who are using standard mice and not touchpads.

Sebastien Bacher (seb128) wrote :

Not confirming, to send upstream by somebody getting the issue

Daniele Dellafiore (ildella) wrote :

todays my gutsy desktop start to have this behavior.
to solve:
launch gconf-editor from terminal
browse to desktop | gnome | peripherals | mouse
change mouse_acceleration properties.

i found the property just searching for "accel" also in key names.

just as a note, the problems arise seemingly from nothing, just yesterday the system updated gnome-tools to latest version from official repo.
At the same time, also the keyboard stop reapitin chars when a key is pressed. This problem still unsolved.
Gnome system menus icons also disappeared, still unsolved.

Gildas (gildas-bayard) wrote :

Got the exact same problem with several plain standard usb mouses. Quite annoying bug.
I tried to change the mouse speed and I'm now stuck at very low speed.
Gildas

Daniele Dellafiore (ildella) wrote :

I cannot believe!
This is back with a vengeance!

I tried to change the mouse acceleration from the gui and immediatly the accelerations has gone away. Then I remember about this bug, get here and now there is no mouse_acceleration properties anywhere at all!!!
And if I create a key well... nothing happens, maybe I do not know, I have created an integer key and tried different values, from 0, 1, 10, 100, 1000 but nothing happens...

Pedro Villavicencio (pedro) wrote :

Can someone getting the issue send the bug upstream?

Changed in gnome-control-center:
status: New → Incomplete
Daniele Dellafiore (ildella) wrote :

What is the bug upstream? :)

Anyway, The last time, I just restarted gdm and settings was in their place. Wrong, but there was.

The problem here is that I can only change mouse acceleration from gconf-editor and if I try to use the gui, acceleration is set to 0 with no chance to change it anymore (without using the gconf-editor, of course)

What do you need?

will_in_wi (will-in-wi) wrote :

I am seeing this exact bug in a fully updated x64 ubuntu gutsy. Intel Core 2 Duo.

Changed in gnome-control-center:
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

Could you run gconf-editor and look if /desktop/gnome/peripherals/mouse/motion_acceleration is changed when moving the slide?

Changed in gnome-control-center:
status: Confirmed → Incomplete
Tordanik (tordanik) wrote :

I experience the same bug with fully updated Ubuntu 7.10 x86 and a standard USB mouse with PS2 hardware adapter.

Having both gconf-editor and the mouse preferences open, moving the slides will produce the following effects:
a) Moving the slide associated with acceleration will cause /desktop/gnome/peripherals/mouse/motion_acceleration to change to a low value (0.20000000298023224) as soon as I release the mouse button (no matter where). The slide will instantly go to the far left.
b) Once motion_acceleration has the 0.20… value, moving the slide will no longer affect it at all. The slide itself will, however, remain in the position where I dragged it.
c) If I enter the mouse preferences dialog with the 0.20… value already set, the behavior will be like b) from the beginning.
d) motion_threshold and drag_threshold are not affected by the bug, they will instantly represent changes to their associated slides.

tlo (web-pterodactyl) wrote :

I've just experienced this, and I was able to fix it. My symptoms were loss of menu icons and the mouse moution_acceleration not working (as well as some other missing gconf values).

The problem is corrupt or missing gconf files. In my case, it was due to a system crash, with a corresponding fsck of my ext2 filesystem (old system) ending up losing some files, but I suppose it could end up happening in many different ways, including unreliable hard drives. Fortunately, there is a way to recover, which I found after much googling.values).

The full solution is here: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=446212

But if you don't care about what the problem is, you just want it fixed, here is what you need to do. As root:
        rm -f /var/lib/gconf/defaults/*
        gconf-schemas --register $(ls /usr/share/gconf/schemas)

Changed in gnome-control-center:
status: Unknown → Fix Released
Sebastien Bacher (seb128) wrote :

could you try if that's still an issue in hardy?

Well it has been a long time so I don't remember exactly how the bug showed
up at first :)
Anyway I just played with mouse acceleration rignt now in Hardy and it's
fine (but not the same computer, not the same mouse)
Gildas

2008/10/10 Sebastien Bacher <email address hidden>

could you try if that's still an issue in hardy?
>
> --
> mouse preferences acceleration not saving
> https://bugs.launchpad.net/bugs/118593
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Work fine for me now as well in Hardy.

----- Original Message ----
From: Sebastien Bacher <email address hidden>
To: <email address hidden>
Sent: Friday, October 10, 2008 3:51:38 AM
Subject: [Bug 118593] Re: mouse preferences acceleration not saving

could you try if that's still an issue in hardy?

--
mouse preferences acceleration not saving
https://bugs.launchpad.net/bugs/118593
You received this bug notification because you are a direct subscriber
of the bug.

Sebastien Bacher (seb128) wrote :

closing the bug since that works correctly now

Changed in gnome-control-center:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.