Details panel has a logo with harcoded version string, this is not efficient.

Bug #1181442 reported by John Kim on 2013-05-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Confirmed
Medium
gnome-control-center (Ubuntu)
Low
Unassigned

Bug Description

The "Details" panel in gnome-control-center features an About Ubuntu logo that includes the distro's version. This is an awful approach, as the image needs to be updated every cycle. We should just put the log in the image, and the text in a text string.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: gnome-control-center 1:3.6.3-0ubuntu25
ProcVersionSignature: Ubuntu 3.9.0-2.6-generic 3.9.2
Uname: Linux 3.9.0-2-generic x86_64
ApportVersion: 2.10.1-0ubuntu1
Architecture: amd64
Date: Fri May 17 17:30:59 2013
InstallationDate: Installed on 2013-04-27 (20 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Release amd64 (20130424)
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_US
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: Upgraded to saucy on 2013-05-12 (5 days ago)
usr_lib_gnome-control-center:
 activity-log-manager-control-center 0.9.4-0ubuntu6.1
 deja-dup 26.0-0ubuntu1
 gnome-control-center-signon 0.1.6bzr13.04.05-0ubuntu2
 gnome-control-center-unity 1.2daily13.04.09-0ubuntu1
 indicator-datetime 12.10.3daily13.05.06.1-0ubuntu1

John Kim (kotux) wrote :
tags: added: bitesize
summary: - gnome-control-center reads 'Ubuntu 13.04'u
+ gnome-control-center reads 'Ubuntu 13.04'
John Kim (kotux) on 2013-05-18
summary: - gnome-control-center reads 'Ubuntu 13.04'
+ gnome-control-center reads 'Ubuntu 13.04' on Saucy

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
John Kim (kotux) on 2013-05-18
description: updated
tags: removed: bitesize
Adam Conrad (adconrad) wrote :

Assigning to the person who provided us with the updated image last cycle. ;)

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Adam Conrad (adconrad)
assignee: Adam Conrad (adconrad) → Xi Zhu (xi.zhu)
Adam Conrad (adconrad) wrote :

It would be lovely if we had the preferred form of modification for this image in the source package, so others could edit/update it too. *cough*

Jeremy Bicha (jbicha) wrote :

Hi, could we please just use a slightly modified version of the patch Fedora uses instead:
https://bugzilla.gnome.org/show_bug.cgi?id=695691

With the current workflow, the version number in that panel tends to be out of date for much of the release cycle and it makes backports more difficult.

Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Won't Fix
Adolfo Jayme (fitojb) on 2013-05-18
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
John Kim (kotux) wrote :

I agree with Adam. Even the image should be transparent for the community to modify, if possible.

Adolfo Jayme (fitojb) wrote :

Let's not make this another "Canonical vs. community" discussion, please. I agree with Jeremy, and I'd prefer if we used the Fedora approach instead of images with static text.

John Kim (kotux) wrote :

Any luck yet? Why wasn't the image open sourced?

Sebastien Bacher (seb128) wrote :

@John: the image is opensource, it's in the debian directory of the source package, it just requires somebody with gimp skills to update it

Adolfo Jayme (fitojb) wrote :

> Why wasn't the image open sourced?

Sorry, but that's nonsense. A pixel image has no "source". It has an open source license, of course, because it's included in the package, and you're free to modify it. But "Why wasn't the image open sourced?"... Wow.

John Kim (kotux) wrote :

> But "Why wasn't the image open sourced?"... Wow.

Sorry, I didn't realize that. I know better now. :-)

John Kim (kotux) wrote :

By the way, can someone explain why this bug report has been marked duplicate despite having been reported a month before 1188208?

Adolfo Jayme (fitojb) wrote :

Clarified this bug's scope (now that the image has been updated) and unmarked as duplicate.

summary: - gnome-control-center reads 'Ubuntu 13.04' on Saucy
+ Details panel has a logo with harcoded version string, this is not
+ efficient.
Changed in gnome-control-center (Ubuntu):
assignee: Xi Zhu (xi.zhu) → nobody
status: Confirmed → Triaged
description: updated
Changed in gnome-control-center:
status: Won't Fix → Confirmed
Jeremy Bicha (jbicha) wrote :

It took a few years, but I finally went ahead and implemented what I proposed in comment #5 for Ubuntu 17.10.

Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.