Gnome Control Center Crashes when attempting to open "Details" (Ubuntu 13.10)

Bug #1179659 reported by Jonas De Moor on 2013-05-13
60
This bug affects 9 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Critical
gnome-control-center (Ubuntu)
Undecided
Unassigned
Raring
High
Unassigned

Bug Description

[Impact]
* Gnome control center will crash when Clicking on the Details tab.
* only affects the virtualbox glX driver

[Testcase]
- Load VirtualBox VM with 3D enabled.
- Open gnome-control-center and click 'details'
- This will crash gnome-control-center, 100% reproducible

[Regression Potential]
Very low, this patch adds a glXQueryVersion call, which forces the virtualbox glX driver to correctly initialise before calling glXChooseFBConfig. This is entirely redundant on any other glX drivers and unlikely to cause any regressions.

=== Original Bug Report ===
On Ubuntu 13.10, when I search for "Details " in the dash, I see the mouse cursor (meaning it's loading something). But then gnome-control-panel crashes and I get "Ubuntu 13.10 has encountered an internal error".

This also happens when I go to System Settings from the launcher and then to "Details".

NOTE: I'm running 13.10 in a virtual machine on Ubuntu 12.04.

Bug Details
----------------
1) Ubuntu version: Ubuntu 13.10 x64
2) Package version: gnome-control-center 1:3.6.3-0ubuntu25
3) Expectation: I expected that the Details section of the Control Panel would open.
4) Reality: Nothing happened; not even a window opened. I only get an error (mentioned above).

Virtual Machine Details
--------------------------------
- Dedicated four CPU Cores (CPU: AMD FX-8150 8 core CPU @ 3.6 GHz) to OS.
- Dedicated 5 GB RAM to OS.
- Dedicated 128 MB Video Memory (Maximum) to OS.
- 40 GB Virtual Hard Drive

Native System Details
-----------------------------
- CPU: AMD FX-8150 8 Core CPU @ 3.6 Ghz
- GPU: Nividia GTX 550Ti 1024 MB
- PSU: Antec High Current Gamer Bronze 620 Watts
- Motherboard: ASUS Sabertooth 990 FX
- OS: Ubuntu 12.04.2 LTS

Jonas De Moor (jonas-12) on 2013-05-16
summary: - Gnome Control Center Crashes when attempring to open "Details"
+ Gnome Control Center Crashes when attempring to open "Details" (Ubuntu
+ 13.10)
summary: - Gnome Control Center Crashes when attempring to open "Details" (Ubuntu
+ Gnome Control Center Crashes when attempting to open "Details" (Ubuntu
13.10)
Tim Lunn (darkxst) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in gnome-control-center (Ubuntu):
status: New → Incomplete
Changed in gnome-control-center:
importance: Unknown → Critical
status: Unknown → Incomplete
Tim Lunn (darkxst) wrote :
Changed in gnome-control-center (Ubuntu):
status: Incomplete → Confirmed
Jonas De Moor (jonas-12) wrote :

Hello,

Unfortunately, I can't obtain a backtrace anymore because I had to format my PC , so all my VM's are gone :(

Martin Pitt (pitti) on 2013-05-27
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.6.3-0ubuntu26

---------------
gnome-control-center (1:3.6.3-0ubuntu26) saucy; urgency=low

  * debian/patches/git_no_glxinfo.patch:
    updated to fix details panel crash on vbox glx driver (LP: #1179659)
 -- Tim Lunn <email address hidden> Mon, 27 May 2013 09:53:26 +0200

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Tim Lunn (darkxst) on 2013-05-28
description: updated
Changed in gnome-control-center (Ubuntu Raring):
status: New → Triaged
importance: Undecided → High
Brian Murray (brian-murray) wrote :

I've uploaded this to raring.

Hello Jonas, or anyone else affected,

Accepted gnome-control-center into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-control-center/1:3.6.3-0ubuntu24.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-control-center (Ubuntu Raring):
status: Triaged → Fix Committed
tags: added: verification-needed
Tim Lunn (darkxst) wrote :

tested update in proposed. details pane no longer crashes and correctly displays glx renderer string.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.6.3-0ubuntu24.1

---------------
gnome-control-center (1:3.6.3-0ubuntu24.1) raring; urgency=low

  * debian/patches/git_no_glxinfo.patch:
    updated to fix details panel crash on vbox glx driver (LP: #1179659)
 -- Tim Lunn <email address hidden> Thu, 30 May 2013 15:20:27 -0700

Changed in gnome-control-center (Ubuntu Raring):
status: Fix Committed → Fix Released
Sebastian Berthold (sleif) wrote :

Same error with:
apt-cache policy gnome-control-center
gnome-control-center:
  Installed: 1:3.6.3-0ubuntu24.1
  Candidate: 1:3.6.3-0ubuntu24.1
  Version table:
 *** 1:3.6.3-0ubuntu24.1 0
        500 http://de.archive.ubuntu.com/ubuntu/ raring-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1:3.6.3-0ubuntu24 0
        500 http://de.archive.ubuntu.com/ubuntu/ raring/main amd64 Packages

Error:
(gnome-control-center:16410): info-cc-panel-WARNING **: PackageKit version 7.4.0 not supported
Segmentation fault (core dumped)

Tim Lunn (darkxst) wrote :

Sebastian,
   The packagekit warning is unrelated to any crash. Please file a new bug with 'ubuntu-bug gnome-control-center', so can we get a backtrace and investigate further.

Changed in gnome-control-center:
status: Incomplete → New
Changed in gnome-control-center:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.