[printers]: gnome-control-center crashed with SIGABRT in __libc_message()

Bug #1155825 reported by Thomas deerheart on 2013-03-15
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Medium
gnome-control-center (Ubuntu)
Medium
Robert Ancell

Bug Description

just tried to add a HP LazerJet 5 printer which is already up & running on all my other Linux Distros

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: gnome-control-center 1:3.6.3-0ubuntu15
ProcVersionSignature: Ubuntu 3.8.0-12.21-generic 3.8.2
Uname: Linux 3.8.0-12-generic i686
ApportVersion: 2.9.1-0ubuntu1
Architecture: i386
Date: Fri Mar 15 18:28:10 2013
ExecutablePath: /usr/bin/gnome-control-center
InstallationDate: Installed on 2013-03-15 (0 days ago)
InstallationMedia: Ubuntu-GNOME 13.04 "Raring Ringtail" - Alpha i386 (20130313)
MarkForUpload: True
ProcCmdline: gnome-control-center --overview
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 6
SourcePackage: gnome-control-center
StacktraceTop:
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
 ?? () from /lib/i386-linux-gnu/libc.so.6
Title: [printers]: gnome-control-center crashed with SIGABRT in raise()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
usr_lib_gnome-control-center:
 deja-dup 25.5-0ubuntu1
 gnome-control-center-signon 0.1.2bzr12.12.05-0ubuntu1

Revision history for this message
Thomas deerheart (uckc-thomas) wrote :
Revision history for this message
Apport retracing service (apport) wrote :

StacktraceTop:
 __libc_message (do_abort=do_abort@entry=2, fmt=fmt@entry=0xb6d3a530 "*** Error in `%s': %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:199
 malloc_printerr (action=<optimized out>, str=<optimized out>, ptr=0xb87cd448) at malloc.c:4902
 _int_free (av=0xb6d7b440 <main_arena>, p=0xb87cd440, have_lock=0) at malloc.c:3758
 standard_free (mem=0xb87cd448) at /build/buildd/glib2.0-2.35.8/./glib/gmem.c:98
 g_free (mem=0xb87cd448) at /build/buildd/glib2.0-2.35.8/./glib/gmem.c:252

Revision history for this message
Apport retracing service (apport) wrote : Stacktrace.txt
Revision history for this message
Apport retracing service (apport) wrote : StacktraceSource.txt
Revision history for this message
Apport retracing service (apport) wrote : ThreadStacktrace.txt
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Medium
summary: - [printers]: gnome-control-center crashed with SIGABRT in raise()
+ [printers]: gnome-control-center crashed with SIGABRT in
+ __libc_message()
tags: removed: need-i386-retrace
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
tags: added: saucy
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
information type: Private → Public
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → Fix Released
Revision history for this message
Robert Ancell (robert-ancell) wrote :

The bug is an error object being freed and then accessed when adding a printer. Bug was fixed upstream and patch applied to package.

Changed in gnome-control-center (Ubuntu):
assignee: nobody → Robert Ancell (robert-ancell)
status: Triaged → In Progress
Revision history for this message
Steve Langasek (vorlon) wrote :

As a medium-severity bug, this does not make sense to include as a last-minute fix in saucy and should be handled as an SRU instead. Robert, could you please populate this bug report with the necessary SRU information?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.6.3-0ubuntu44

---------------
gnome-control-center (1:3.6.3-0ubuntu44) saucy; urgency=low

  * debian/patches/git_add_printer_crash.patch:
    - Fix crash when adding a printer (LP: #1155825)
 -- Robert Ancell <email address hidden> Wed, 16 Oct 2013 15:51:53 +1300

Changed in gnome-control-center (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.