GNOME Printer Setup Tool: HP printers discovered by both usb and hp CUPS backends -> Two indistinguishable entries in the list of discovered printers

Bug #1115701 reported by Till Kamppeter on 2013-02-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
High
gnome-control-center (Ubuntu)
High
Unassigned

Bug Description

I have several HP printers. If I connect one of them via USB and click the "+" button to add a new printer in GNOME's printer setup tool, I get two entries where a user will not see the difference:

HP-LaserJet-3390
HP-LaserJet-3390-2

To find out why I got two entries, I added two print queues, one using the first entry, another using the second entry. Then I ran the command

lpstat -v

and got

device for HP-LaserJet-3390: usb://HP/LaserJet%203390?serial=00CNMJP81545
device for HP-LaserJet-3390-2: hp:/usb/HP_LaserJet_3390?serial=00CNMJP81545

So the first comes from the HP LaserJet 3390 discovered via the "usb" CUPS backend and the second from the same printer via the "hp" backend.

The preferred backend is the latter, as it is made by HP especially for HP printers. Therefore there should be only one entry, using the "hp" backend. system-config-printer does this correctly, so usingf the D-Bus service of system-config-printer one should be able to join these entries to one using the "hp" backend.

Note that this is not a duplicate of bug 1115669. That bug is about making duplicate entries distinguishable, this bug is about making the "hp" backend used with HP printers.

Till Kamppeter (till-kamppeter) wrote :

This is a regression compared to Quantal. There system-config-printer was used which did it correctly.

Changed in gnome-control-center:
importance: Unknown → High
status: Unknown → New
Changed in gnome-control-center (Ubuntu):
status: New → Triaged
Changed in gnome-control-center (Ubuntu):
milestone: ubuntu-13.04-feature-freeze → ubuntu-13.04-beta-2
Changed in gnome-control-center:
status: New → Confirmed
Changed in gnome-control-center:
status: Confirmed → Fix Released
Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.