GNOME Printer Setup Tool: List of discovered printers should better describe duplicate entries

Bug #1115669 reported by Till Kamppeter on 2013-02-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Wishlist
gnome-control-center (Ubuntu)
High
Unassigned
unity-control-center (Ubuntu)
Low
Unassigned

Bug Description

When adding a printer a list of discovered printers is shown. If there are duplicate entries, for example if the same network printer is discovered with different network protocols (LPD, IPP, ...), these entries are usually grouped into one by using the D-Bus service of system-config-printer. system-config-printer groups entries coming from the network connection of the printer and groups entries coming from the USB connection of the printer, but it does not group network results with USB results, as system-config-printer separates them by a tree view. This means that when one connects one printer by both network and USB one gets two entries, one generated from all appearances under the discovered network printers and one from all appearances under the discovered USB printers (and if theis printer does Bluetooth there would be a third entry). Now the g-c-c printer tool lists these entries as

<model name>
<model name>-2

This way the user does not know which is the network printer and which is the USB printer. The results dhould look like

<model name> (USB)
<model name> (Network)

To reproduce connect a printer with both network and USB (or Bluetooth) input by both network and USB, then try to set it up with the preferred connection type.

Till Kamppeter (till-kamppeter) wrote :

This is a regression compared to Quantal. There system-config-printer was used which did it correctly.

Changed in gnome-control-center:
importance: Unknown → High
status: Unknown → New
Changed in gnome-control-center:
importance: High → Wishlist
Changed in gnome-control-center:
status: New → Fix Released
Till Kamppeter (till-kamppeter) wrote :

Now the first step of making the entries distinguishable is done. Next step is pre-selecting the best entry for a printer:

https://bugzilla.gnome.org/show_bug.cgi?id=693186

Changed in unity-control-center (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Settings low for unity-control-center since we don't use the printer panel there

Changed in unity-control-center (Ubuntu):
importance: Medium → Low
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.