GNOME Printer Setup Tool: Printers are discovered only through a hard-coded list of CUPS backends

Bug #1115653 reported by Till Kamppeter on 2013-02-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
High
gnome-control-center (Ubuntu)
High
Unassigned

Bug Description

For development of printing infrastructure I use a test CUPS backend (attached, to be installed in /usr/lib/cups/backend/ and to be made executable) reporting printers as detected which in reality do not exist, so that I do not need the actual printer models for the test. Other users use manufacturer-supplied printer drivers which bring their own CUPS backends, and Ubuntu also ships the "hpfax" backend which is not in the hard-coded list.

The source code of gnome-control-center, file panels/printers/pp-utils.c contains

----------
[...]
static void
get_device_attributes_async_scb (GHashTable *result,
                                 gpointer user_data)
{
  [...]
  const gchar *backends[] =
    {"hpfax", "ncp", "beh", "bluetooth", "snmp",
     "dnssd", "hp", "ipp", "lpd", "parallel",
     "serial", "socket", "usb", NULL};
  [...]
----------

and tests show that the tool is actually only discovering printers through these backends. It is easy to make CUPS using all backends for detecting printers, one can do it by a single function call. Other printer setup tools do it this way and I expect gnome-control-center to also use all CUPS backends, so that users who use special backends can set up their printers.

Till Kamppeter (till-kamppeter) wrote :

This is a regression compared to Quantal. There system-config-printer was used which did it correctly.

Changed in gnome-control-center (Ubuntu):
status: New → Triaged
Changed in gnome-control-center:
importance: Unknown → High
status: Unknown → New
Sebastien Bacher (seb128) wrote :

(changing the milestone since we are past feature freeze, setting to beta2)

Changed in gnome-control-center (Ubuntu):
milestone: ubuntu-13.04-feature-freeze → ubuntu-13.04-beta-2
Changed in gnome-control-center:
status: New → Fix Released
Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.