gnome-control-center segment error during selection of image

Bug #1100308 reported by Finn Årup Nielsen on 2013-01-16
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Undecided
Unassigned

Bug Description

In Oneiric:

$ gnome-control-center
Press "Brugerkonti" (user accounts)
Press on image icon
select image
-> "Segmentfejl" (segmentation error)

My user name does not show in gdm. My name does not show in the upper right menu in Gnome. In user accounts I do not see a value at "Kontotype" (account type), "Sprog" (language). I see a dash at the right side of the user icon.

What should I provide? strace?

Description: Ubuntu 11.10
Release: 11.10

gnome-control-center:
  Installeret: 1:3.2.2-0ubuntu1
  Kandidat: 1:3.2.2-0ubuntu1
  Versionstabel:
 *** 1:3.2.2-0ubuntu1 0
        500 http://dk.archive.ubuntu.com/ubuntu/ oneiric-updates/main i386 Packages
        100 /var/lib/dpkg/status
     1:3.2.0-0ubuntu6 0
        500 http://dk.archive.ubuntu.com/ubuntu/ oneiric/main i386 Packages

Finn Årup Nielsen (fn) wrote :

The error might be related to bug 841280. There the user Scott Stensland (scottstensland) describes similarly "then after its window opens I use mouse and click on icon : User Accounts Segmentation fault (core dumped)". However, that bug is "Fix Released" and pertained to 1:3.1.90-0ubuntu2, while I got:

 /usr/bin/gnome-control-center --version
gnome-control-center 3.2.2

Finn Årup Nielsen (fn) wrote :

This issue is reproducible and seems to be related to the user number. I had a user number in the /etc/passwd set to 300 and something. Now changing that to 1000 and with appropriate "sudo chown -R myusername /home/myusername" and "sudo chgrp -R myusername /home/myusername" I no longer get the error: the username is shown in lightdm, the username is shown in the upper right corner, I see my self in the "User account" is system settings, and pressing the icon does not generate a crash, but selects the icon alright.

Before that I tried "minimum-uid=300" in /etc/lightdm/users.conf" but I did not get that to work.

There seems to be multiple issues (including a crash) related to a too low user number.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers