Ubuntu

gnome-control-center keyboard shortcuts does not manage keyboard power button keybindings properly

Reported by Stephen on 2012-11-15
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Confirmed
Low
gnome-control-center (Ubuntu)
Low
Unassigned

Bug Description

My keyboard has a "sleep" button on it. I wish to reassign it to open a terminal rather than shut down my computer. To do so, I click on gnome-control-center -> keyboard -> shortcuts -> launchers -> Launch Terminal, then I press the "sleep" button on my keyboard. The "sleep" button appears to be properly assigned to run the terminal command. However, when I press the "sleep" button now, I would expect it to launch a terminal. Instead it puts the computer to sleep.

Digging further, it appears that the power buttons on the computer (including those on the keyboard) are controlled by the following dconf settings:
org.gnome.settings-daemon.plugins.power button-hibernate
org.gnome.settings-daemon.plugins.power button-power
org.gnome.settings-daemon.plugins.power button-sleep
org.gnome.settings-daemon.plugins.power button-suspend

If I use dconf-editor to set these values to 'nothing', then the "sleep" button on my keyboard opens the terminal as expected. The gnome-control-center keyboard shortcuts GUI does not disable the power settings for this button automatically for me.

The gnome-control-center keyboard shortcuts GUI should know about and manage the org.gnome.settings-daemon.plugins.power button settings. It should allow the buttons to be re-assigned like other keyboard buttons.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gnome-control-center 1:3.4.2-0ubuntu19
ProcVersionSignature: Ubuntu 3.5.0-18.29-generic 3.5.7
Uname: Linux 3.5.0-18-generic i686
ApportVersion: 2.6.1-0ubuntu6
Architecture: i386
Date: Thu Nov 15 08:33:50 2012
ExecutablePath: /usr/bin/gnome-control-center
InstallationDate: Installed on 2012-10-31 (14 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
MarkForUpload: True
SourcePackage: gnome-control-center
UpgradeStatus: Upgraded to quantal on 2012-11-01 (14 days ago)
usr_lib_gnome-control-center:
 activity-log-manager-control-center 0.9.4-0ubuntu4
 deja-dup 24.0-0ubuntu1
 gnome-control-center-signon 0.0.18-0ubuntu1
 indicator-datetime 12.10.2-0ubuntu3

Stephen (1012web) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
Stephen (1012web) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for sending it to GNOME

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-control-center:
status: New → Invalid
Changed in gnome-control-center:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in gnome-control-center:
importance: Unknown → Low
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.