Swiss keyboard layout with Apple keyboard (period instead of comma)

Bug #1043336 reported by Michael Tanner on 2012-08-29
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Undecided
Unassigned

Bug Description

It is a known bug that two keys on an Apple keyboard are swapped. There is another bug which occurs on Swiss keyboards with an Apple model.
In Switzerland people have a period instead of a comma on their numpad. Also there is something weird with the default mapping of the upper left key below "ESC".
To correct this there is a workaround with xmodmap:

keycode 91 = period period
keycode 94 = section degree

I think this is not the best solution so I report this as a new bug.

Michael Tanner (thonixx) on 2012-08-31
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed

For a temporary layout switch fix:

echo 0 | sudo tee /sys/module/hid_apple/parameters/iso_layout

for a definitive fix, insert into /etc/modprobe.d/hid_apple.conf:

options hid_apple iso_layout=0

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Invalid
Michael Tanner (thonixx) wrote :

Why did you close the bug report? I think it is not fixed if I have to insert a line into a file so that it works.

ceg (ceg) wrote :

The hid_apple module will have set iso_layout=0 for some locales (all non-US?).

Changed in gnome-control-center (Ubuntu):
status: Invalid → Confirmed
ceg (ceg) wrote :

set it _automatically_ of course

Michael Tanner (thonixx) wrote :

Luca, this does not work. The wrong keys are not fixed with that.

Michael Tanner (thonixx) wrote :

ceg, do you have updates?

ceg (ceg) wrote :

No updates, manually setting iso_layout=0 fixed the swapped keys for me, so someone still needs to fix that module.

Michael Tanner (thonixx) wrote :

It still persists in the newest Ubuntu 13.10 release. Someone needsd to still fix it.

Michael Tanner (thonixx) wrote :

Still there after two years. Is there no one interested in it? Unfortunately I don't have any knowledge to create a fix by myself.

Simon Collis (zippy72) wrote :

I can confirm that I have tried this tonight on 18.04.1 LTS with a Portuguese layout Apple wired keyboard, and iso_layout=0 doesn't fix the problem for me either

Simon Collis (zippy72) wrote :

Correction - it did fix it after a reboot.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers