gnome-control-center and desktop environment crashes when trying to change full name in User Accounts

Bug #1041756 reported by Eric Appleman
72
This bug affects 11 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Undecided
Unassigned
pango1.0 (Ubuntu)
Undecided
Unassigned

Bug Description

1. Open User Accounts page in g-c-c
2. Click on your name on the right (not the one in the list)
3. Text should get huge for a brief instant and then g-c-c should crash, your WM or decorator may also crash

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gnome-control-center 1:3.4.2-0ubuntu11
ProcVersionSignature: Ubuntu 3.5.0-11.11-generic 3.5.2
Uname: Linux 3.5.0-11-generic x86_64
ApportVersion: 2.5.1-0ubuntu2
Architecture: amd64
Date: Sun Aug 26 02:39:15 2012
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120606.2)
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_gnome-control-center:
 activity-log-manager-control-center 0.9.4-0ubuntu3
 deja-dup 23.90-0ubuntu1
 gnome-control-center-signon 0.0.13-0ubuntu1
 indicator-datetime 12.10.0-0ubuntu1

Revision history for this message
Eric Appleman (erappleman) wrote :
Revision history for this message
Eric Appleman (erappleman) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Changed in pango1.0 (Ubuntu):
status: New → Confirmed
summary: - gnome-control-center crashes when trying to change full name in User
- Accounts
+ gnome-control-center and desktop environment crashes when trying to
+ change full name in User Accounts
Revision history for this message
Eric Appleman (erappleman) wrote :
Revision history for this message
Jason Conti (jconti) wrote :

Attaching a debdiff with the upstream commit that fixes the issue.

Changed in pango1.0 (Ubuntu):
status: Confirmed → Invalid
Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "gnome-control-center_fix-big-editable-labels.debdiff" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Revision history for this message
Jason Conti (jconti) wrote :

Updated the debdiff, forgot to bump the gtk+3.0 build-depends to 3.5.13 for the new gtk_entry_set_attributes() function in the patch.

Revision history for this message
Rainer Rohde (rainer-rohde) wrote :
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.4.2-0ubuntu15

---------------
gnome-control-center (1:3.4.2-0ubuntu15) quantal; urgency=low

  * debian/patches/git_fix_big_editable_labels.patch:
    - Cherrypick from git to fix unconstrained font growth (LP: #1041756)
  * debian/control.in:
    - Bump gtk+3.0 build-deps to 3.5.13 for gtk_entry_set_attributes().
 -- Jason Conti <email address hidden> Sat, 08 Sep 2012 17:51:05 -0400

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers