[soundnua] Can't select Digital stereo duplex profile

Bug #1015073 reported by David Henningsson on 2012-06-19
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Low
Unassigned
Precise
Low
Sebastien Bacher

Bug Description

Impact:
Some configurations can't be selected with the new sound configuration dialog

Test Case:
 1) Go to output tab and select "Digital Output (S/PDIF)"
 2) Go to input tab and select "iec958-digital-input"
 3) Go back to output tab, notice that "Digital Output (S/PDIF)" is no longer selected.

Regression potential:
The profiles listed in the sound capplet could be wrong or incomplete or not correctly applied

---

More info:
When selecting "Digital Output (S/PDIF)", soundnua sets the card's profile to "output:iec958-stereo+input:analog-stereo". When selecting "iec958-digital-input", soundnua sets the card's profile to "output:analog-stereo+input:iec958-stereo", instead of the expected "output:iec958-stereo+input:iec958-stereo".

As selecting iec958-stereo on one side unexpectedly flips it back to analog-stereo on the other side there is no way to select "output:iec958-stereo+input:iec958-stereo".

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-control-center 1:3.4.2-0ubuntu0.2
ProcVersionSignature: Ubuntu 3.2.0-25.40-generic 3.2.18
Uname: Linux 3.2.0-25-generic x86_64
ApportVersion: 2.0.1-0ubuntu9
Architecture: amd64
Date: Tue Jun 19 12:08:10 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120421)
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)
usr_lib_gnome-control-center:
 activity-log-manager-control-center 0.9.4-0ubuntu3
 deja-dup 22.0-0ubuntu2
 gnome-bluetooth 3.2.2-0ubuntu5
 indicator-datetime 0.3.94-0ubuntu2

David Henningsson (diwic) wrote :
description: updated
David Henningsson (diwic) wrote :

For reference, the output of "pactl list". It's the Built-In Audio card ("HDA ATI SB") I'm referring to in the bug report.

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.4.2-0ubuntu6

---------------
gnome-control-center (1:3.4.2-0ubuntu6) quantal; urgency=low

  [ David Henningsson ]
  * debian/patches/96_sound_nua_panel.patch:
    - update, including profiles get,set rewrite (lp: #1015073)

  [ Iain Lane ]
  * Add Build-Depends on libxkbfile-dev
 -- Sebastien Bacher <email address hidden> Mon, 25 Jun 2012 16:49:37 +0200

Changed in gnome-control-center (Ubuntu):
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

Ok, I've uploaded that to quantal so it gets testing, we can look at backporting for a precise SRU next

Changed in gnome-control-center (Ubuntu Precise):
importance: Undecided → Low
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
Changed in gnome-control-center (Ubuntu Precise):
status: New → Triaged
Changed in gnome-control-center (Ubuntu Precise):
milestone: none → ubuntu-12.04.1
Sebastien Bacher (seb128) wrote :

Could anyone confirm the quantal version fixes the issue and doesn't create new problems before we backport it?

Changed in gnome-control-center (Ubuntu Precise):
assignee: nobody → Sebastien Bacher (seb128)
Raymond (superquad-vortex2) wrote :

does the patch fix the bug which cannot select analog mono duplex in unity but can select in gnome?

David Henningsson (diwic) wrote :

> does the patch fix the bug which cannot select analog mono duplex in unity but can select in gnome?

It should, yes.

Sebastien Bacher (seb128) wrote :

Ok, I've uploaded that patch as a SRU for precise since the quantal testing didn't show any regression so far

description: updated
Changed in gnome-control-center (Ubuntu Precise):
status: Triaged → In Progress

Hello David, or anyone else affected,

Accepted gnome-control-center into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-control-center/1:3.4.2-0ubuntu0.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-control-center (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Sebastien Bacher (seb128) wrote :

Could those who had the issue check if the SRU fix it for them?

Sebastien Bacher (seb128) wrote :

I can't test since I don't have the hardware for, but there are no regression here so maybe we should set it verified on that basis?

David Henningsson (diwic) wrote :

Sorry for the delay - I've been on vacation.

I can confirm that with -0.4 I can select digital duplex (by selecting digital out and digital in) and with -0.3 I can't do that.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.4.2-0ubuntu0.4

---------------
gnome-control-center (1:3.4.2-0ubuntu0.4) precise-proposed; urgency=low

  * debian/patches/96_sound_nua_panel.patch:
    - update, including profiles get,set rewrite (lp: #1015073)
 -- David Henningsson <email address hidden> Tue, 17 Jul 2012 17:59:17 +0200

Changed in gnome-control-center (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers