cannot set bmp as desktop background (and no reason given)

Bug #927302 reported by Teo on 2012-02-05
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-control-center
Fix Released
Medium
gnome-control-center (Ubuntu)
Low
Unassigned
gnome-control-center-unity (Ubuntu)
Low
Unassigned

Bug Description

* right-click on the desktop
* select "change desktop background"
* click on the "+" sign on the bottom
* browse and select some bmp file

expected: the file should appear on the left and you should be able to select it as a background (this happens with jpg files)

observed: the file browser closes but the file is not added. No error message is given

If the bmp file format is not supported (which I don't see why it shouldn't be) or if anything is wrong with the file itself, an error message should be given.

I attach a bmp file that exhibits the issue just in case it's this file in particular

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: unity 4.28.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-16.28-generic 3.0.17
Uname: Linux 3.0.0-16-generic i686
NonfreeKernelModules: nvidia
.proc.driver.nvidia.gpus.0: Error: [Errno 21] Is a directory: '/proc/driver/nvidia/gpus/0'
.proc.driver.nvidia.registry: Binary: ""
.proc.driver.nvidia.version:
 NVRM version: NVIDIA UNIX x86 Kernel Module 280.13 Wed Jul 27 16:55:43 PDT 2011
 GCC version: gcc version 4.6.1 (Ubuntu/Linaro 4.6.1-9ubuntu3)
.tmp.unity.support.test.0:

ApportVersion: 1.23-0ubuntu4
Architecture: i386
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
Date: Sun Feb 5 21:08:14 2012
DistUpgraded: Log time: 2011-12-07 19:34:40.350850
DistroCodename: oneiric
DistroVariant: ubuntu
GraphicsCard:
 nVidia Corporation G84 [GeForce 9500M GS] [10de:0405] (rev a1) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:15d2]
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
JockeyStatus:
 xorg:nvidia_173 - NVIDIA accelerated graphics driver (Proprietary, Disabled, Not in use)
 xorg:nvidia_173_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
 xorg:nvidia_current - NVIDIA accelerated graphics driver (Proprietary, Enabled, In use)
 pkg:sl-modem-daemon - Software modem (Proprietary, Disabled, Not in use)
 xorg:nvidia_current_updates - NVIDIA accelerated graphics driver (post-release updates) (Proprietary, Disabled, Not in use)
MachineType: ASUSTeK Computer Inc. M51Sn
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-16-generic root=UUID=173acbf5-26a0-49e3-8d2b-f1c142582cbf ro quiet splash vt.handoff=7
SourcePackage: unity
UpgradeStatus: Upgraded to oneiric on 2011-12-07 (59 days ago)
dmi.bios.date: 12/24/2007
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 303
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: M51Sn
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: 1.0
dmi.chassis.asset.tag: ATN12345678901234567
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK Computer Inc.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr303:bd12/24/2007:svnASUSTeKComputerInc.:pnM51Sn:pvr1.0:rvnASUSTeKComputerInc.:rnM51Sn:rvr1.0:cvnASUSTeKComputerInc.:ct10:cvr1.0:
dmi.product.name: M51Sn
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK Computer Inc.
version.compiz: compiz 1:0.9.6+bzr20110929-0ubuntu6.1
version.libdrm2: libdrm2 2.4.26-1ubuntu1
version.libgl1-mesa-dri: libgl1-mesa-dri 7.11-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.11-0ubuntu3
version.nvidia-graphics-drivers: nvidia-graphics-drivers N/A
version.xserver-xorg: xserver-xorg 1:7.6+7ubuntu7.1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.6.0-1ubuntu13
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.99~git20110811.g93fc084-0ubuntu1
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.15.901-1ubuntu2.1
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110411+8378443-1

Teo (teo1978) wrote :
Teo (teo1978) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

affects: unity (Ubuntu) → gnome-control-center (Ubuntu)
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
Robert Roth (evfool) on 2012-02-06
Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
Robert Roth (evfool) on 2012-02-13
Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-control-center:
importance: Unknown → Medium
status: Unknown → New
Changed in gnome-control-center (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-control-center:
status: New → Fix Released
Jeremy Bicha (jbicha) wrote :

This has been fixed in System Settings 3.6.3 which has been uploaded to raring for Ubuntu 13.04.

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Teo (teo1978) wrote :

I think the "Fix Committed" status should be used only when the fix is available for the current Ubuntu version.

Teo (teo1978) wrote :

I meant "Fix Released", sorry

Jeremy Bicha (jbicha) wrote :

Fix Released means that it was fixed in the development release. You can nominate for a previous release if you think this is a good candidate for a Stable Release Update:
https://wiki.ubuntu.com/Bugs/Status
https://wiki.ubuntu.com/StableReleaseUpdates

Actually, I'm reopening this because this has only been fixed in the GNOME Background panel, not the Appearance panel used in Unity.
http://git.gnome.org/browse/gnome-control-center/commit/?id=3d79e11

Changed in gnome-control-center-unity (Ubuntu):
importance: Undecided → Low
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.