UbuntuOne account plugin does not work

Bug #1287640 reported by Michał Sawicz
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Online Accounts: GNOME Control Center
High
Alberto Mardegan
webapps-sprint
Undecided
Alberto Mardegan
gnome-control-center-signon (Ubuntu)
Critical
Unassigned
Xenial
Critical
Unassigned
ubuntuone-credentials (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned

Bug Description

When ubuntuone-credentials-common is installed, the Ubuntu One account is listed under the possible account types in gnome-control-center, but upon opening only a grey page is visible and errors are reported:

(unity-control-center:22553): account-plugin-WARNING **: ap_client_load_plugin: module /usr/lib/libaccount-plugin-1.0/providers/libubuntuone.so not found: /usr/lib/libaccount-plugin-1.0/providers/libubuntuone.so: nie można otworzyć pliku obiektu dzielonego: Nie ma takiego pliku ani katalogu

(unity-control-center:22553): credentials-cc-panel-CRITICAL **: cc-credentials-authorization-page.vala:54: No valid plugin found for provider ubuntuone

What's more, it's currently possible to remove account-plugin-ubuntuone, but that doesn't remove the -common package above, so the account type is still listed as available.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: unity-control-center-signon 0.1.7~+14.04.20140211.2-0ubuntu3
ProcVersionSignature: Ubuntu 3.11.0-12.19-generic 3.11.3
Uname: Linux 3.11.0-12-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 2.13.2-0ubuntu5
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Mar 4 11:30:18 2014
SourcePackage: gnome-control-center-signon
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Revision history for this message
Michał Sawicz (saviq) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center-signon (Ubuntu):
status: New → Confirmed
Changed in ubuntuone-credentials (Ubuntu):
status: New → Confirmed
Revision history for this message
Robert Ancell (robert-ancell) wrote :

I'm struggling to find any package that provides /usr/lib/libaccount-plugin-1.0/providers/libubuntuone.so in xenial - is it still in the archive?

Changed in gnome-control-center-signon (Ubuntu):
importance: Undecided → Critical
Revision history for this message
Alberto Mardegan (mardy) wrote :

AFAICR, creating the U1 account from the Unity control center has never been possible. The reason why the software is complaining about the missing libubuntuone.so module is because by default when we want to create an account for the provider <X> we load the lib<X>.so module.
My guess is that the ubuntuone.provider file was added to ubuntuone-credentials-common because of the phone.

As I can see it, the possible solutions are:
1) Find some packaging tricks so that ubuntuone.provider is installed only on phone images
2) The unity-control-center-signon should check for the existance of the plugins before showing the providers as available

I think that for the convergence story, where you have both unity7 and unity8 installed on the same machine, fixing (2) is absolutely a must.

Changed in gnome-control-center-signon:
assignee: nobody → Alberto Mardegan (mardy)
status: New → Confirmed
importance: Undecided → High
Changed in webapps-sprint:
assignee: nobody → Alberto Mardegan (mardy)
Alberto Mardegan (mardy)
Changed in gnome-control-center-signon:
status: Confirmed → In Progress
Changed in webapps-sprint:
milestone: none → sprint-17
status: New → In Progress
Revision history for this message
Robert Ancell (robert-ancell) wrote :

What would it take to make this work, i.e. to be able to create an Ubuntu One account from the control center? I'd like to do this if it's not too hard. How did the old Ubuntu One support work (e.g. Shotwell) - did it use the control center or something else?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center-signon - 0.1.8+16.04.20151208-0ubuntu1

---------------
gnome-control-center-signon (0.1.8+16.04.20151208-0ubuntu1) xenial; urgency=medium

  [ Alberto Mardegan ]
  * On account creation, filter out providers without valid plugins from the
    providers list (LP: #1287640)

  [ CI Train Bot ]
  * No-change rebuild.

 -- David Barth <email address hidden> Tue, 08 Dec 2015 13:59:09 +0000

Changed in gnome-control-center-signon (Ubuntu Xenial):
status: Confirmed → Fix Released
Alberto Mardegan (mardy)
Changed in gnome-control-center-signon:
status: In Progress → Fix Released
Changed in webapps-sprint:
status: In Progress → Fix Released
dobey (dobey)
Changed in ubuntuone-credentials (Ubuntu Xenial):
status: Confirmed → Won't Fix
Changed in ubuntuone-credentials (Ubuntu):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers