Facebook account setup opens in external browser, unusable

Bug #1132030 reported by Ryan Reamsbottom on 2013-02-23
428
This bug affects 94 people
Affects Status Importance Assigned to Milestone
gnome-control-center-signon (Ubuntu)
Undecided
Unassigned

Bug Description

When I click on "Facebook" in online accounts, it starts to load the page inside the System Settings window. Then, no matter if my default browser is set to Chromium or Firefox, it opens in an external browser window. I log in, it says "success" but the System Settings window does not recognize this and I am unable to complete the account setup. This works for other online accounts, but not Facebook.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: gnome-online-accounts 3.6.2-1
Uname: Linux 3.8.0-030800-generic x86_64
ApportVersion: 2.6.1-0ubuntu10
Architecture: amd64
Date: Fri Feb 22 23:43:51 2013
MarkForUpload: True
ProcEnviron:
 LANGUAGE=en_CA:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_CA.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-online-accounts
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Ryan Reamsbottom (ryanrms) wrote :
Marigold (elig11) wrote :

This also affects me...desperately trying to find a solution.
Fresh install ubuntu-gnome remix 12.10

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-online-accounts (Ubuntu):
status: New → Confirmed
Alberto Mardegan (mardy) wrote :

Looks like something has changed in the Facebook authentication flow. They are now redirecting to an http page, which we refuse to open for security reasons.
I guess we'll have to give up on security and open it anyways. :-(

affects: gnome-online-accounts (Ubuntu) → gnome-control-center-signon (Ubuntu)
BlueCase (bluecase) wrote :

My proposal is to prefer https but allow http.
To make it more transparent for users show a addressbar and mark https connections green like the chrome browser.
Or any other way.
Main target should be that the whole process is comprehensible for users.

same problem here, and it's getting me annoying.. please fix it :/

Alberto Mardegan (mardy) wrote :

Meanwhile, I logged a bug against Facebook. Let's hope that they fix it soon:
http://developers.facebook.com/bugs/427626840651838

Same bug here, but now it opens a HTML page hosted on my computer.

uname : 3.5.0-25-generic #38-Ubuntu SMP Mon Feb 18 23:27:42 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

I have the same problem on my Ubuntu 12.10. It was working fine till the last Ubuntu update one or two weeks ago (I suppose).
I tried to remove Facebook account and recreate it, but it's still opening the browser and showing the 'Success' message.

Patrick B. (blomsmail) wrote :

Same bug on my System. On my Ubuntu 12.10 the bug occurs after the installation of the unity-webapps for facebook. Removing the webapps doesn't solve the problem.

mustangtn (alien-12) wrote :

Same bug, installed ubuntu 12.10 then chrome. The problem occured just with facebook account (no problem with twitter, google and windows live accounts)

Same bug here on Ubuntu 12.10.

Can an end user not add or append http auth scheme at his end till the time Facebook developers discover and accept their own changes?

Ryan Reamsbottom (ryanrms) wrote :

Looks like this bug has been fixed on Facebook's end. Online Accounts is back to working properly.

Kevin Green (kevgreen7) wrote :

I had the same bug on Ubuntu 12.10 64bit but it appears to have been fixed on Facebook's end.

https://developers.facebook.com/bugs/427626840651838

Yes, it is fixed now.

Alberto Mardegan (mardy) on 2013-02-27
Changed in gnome-control-center-signon (Ubuntu):
status: Confirmed → Fix Released
Marigold (elig11) wrote :

Yes, working for me too.
Thanks who ever sorted this out, it was getting annoying.

Patrick B. (blomsmail) wrote :

For me too, no problems since the fix has been released

Martin Siegl (martin79315) wrote :

Works again in my Ubuntu 12.10 64bit.

BlueCase (bluecase) wrote :

Ok this single problem is solved. But I think not the general one.
What's happen when the next Service or Authentication System have a change?
At the moment the user get only a blank web page with the title "Success" and have no idea what’s going wrong or what's to do.

As BlueCase says, this will likely occur again and again from time to time as services have similar problems, and this is fixable in gnome-cocntrol-center-signon. Probably the best thing to do would be for someone who was able to reproduce this before it was fixed on Facebook's side to file a new bug report explaining how this situation reflects a bug in gnome-control-center-signon too. It should also be filed upstream (and the upstream bug added to the new bug's Launchpad page), since this is somewhat unlikely to be fixed in an Ubuntu or Debian specific patch or even to be considered as qualifying for an SRU.

Lévai Marcell (octolith) wrote :

The same problem is happening to me right now on ubuntu 13.04 x64, only with facebook. Google account does the same (it redirects twice to the browser) but it works at least. With facebook, this is not the case :(

peridot (peridot-faceted) wrote :

As Lévai Marcell pointed out, this bug is back. Is there a workaround, since it seems we're stuck waiting for Facebook to fix their site?

Gábor Librecz (kuglee) wrote :

I also have this problem, but I haven't came across any workaround yet :(

Same problem for me :)

Damon Hartman (area51pilot) wrote :

When I click on "Facebook" in online accounts, it starts to load the page inside the System Settings window. Then it opens in an external browser window. I log in, it says "success" but the System Settings window does not recognize this and I am unable to complete the account setup. This works for other online accounts, but not Facebook.

After this occurs any time I try to open Online Accounts, the window open and then closes within a second or so. I have to log out of the session than log back in in order to be able to access online accounts.

I tried removing previous authorizations on Facebook's side, tried removing/re-adding "Online Accounts" from the Software Center but no luck.

Currently using 13.04 x 64 with ALL updates applied.

John Watson (jwatson) wrote :

Someone filed a new bug with Facebook about this:
https://developers.facebook.com/bugs/449221825171392

jfrancis (jfrancis252) wrote :

Having this problem as well. Url of new tab in Chrome is this:

https://www.facebook.com/connect/blank.html#_=_

And the page reads solely:

"Success
SECURITY WARNING: Please treat the URL above as you would your password and do not share it with anyone."

You gave us your secret url, we are hacking you now! Prepare your time.
Sent wirelessly from my BlackBerry device on the Bell network.
Envoyé sans fil par mon terminal mobile BlackBerry sur le réseau de Bell.

-----Original Message-----
From: jfrancis <email address hidden>
Sender: <email address hidden>
Date: Sat, 18 May 2013 07:07:22
To: <email address hidden>
Reply-To: Bug 1132030 <email address hidden>
Subject: [Bug 1132030] Re: Facebook account setup opens in external browser,
 unusable

Having this problem as well. Url of new tab in Chrome is this:

https://www.facebook.com/connect/blank.html#_=_

And the page reads solely:

"Success
SECURITY WARNING: Please treat the URL above as you would your password and do not share it with anyone."

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1132030

Title:
  Facebook account setup opens in external browser, unusable

Status in “gnome-control-center-signon” package in Ubuntu:
  Fix Released

Bug description:
  When I click on "Facebook" in online accounts, it starts to load the
  page inside the System Settings window. Then, no matter if my default
  browser is set to Chromium or Firefox, it opens in an external browser
  window. I log in, it says "success" but the System Settings window
  does not recognize this and I am unable to complete the account setup.
  This works for other online accounts, but not Facebook.

  ProblemType: Bug
  DistroRelease: Ubuntu 12.10
  Package: gnome-online-accounts 3.6.2-1
  Uname: Linux 3.8.0-030800-generic x86_64
  ApportVersion: 2.6.1-0ubuntu10
  Architecture: amd64
  Date: Fri Feb 22 23:43:51 2013
  MarkForUpload: True
  ProcEnviron:
   LANGUAGE=en_CA:en
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=<set>
   LANG=en_CA.UTF-8
   SHELL=/bin/bash
  SourcePackage: gnome-online-accounts
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/gnome-control-center-signon/+bug/1132030/+subscriptions

lively (doratheexplorer) wrote :

I have this problem on 13.04 and it occurred after recent Ubuntu update.
Have tried removing Gwibber fron FB apps but this has not fixed the issue

This also happens to me on a fresh install of 13.04.

jfrancis (jfrancis252) wrote :

Previously posted url is blank, otherwise I wouldn't have posted it for bug info.

Dmitry Shachnev (mitya57) wrote :

The new bug is bug 1180297.

It is not fixed yet, fresh install of 13.04.

chris (christian.ego) wrote :

Same here with a fresh install 13.04

Dhruv (meetsangvikar) wrote :

Don't know whether the bug is facebook's side because till last week with ubuntu/mint/fedora (all 32bit) it was working fine. On 13.04 64 bit ubuntu-gnome this is causing an error. Please get a permanent fix as early as possible. :)

Moving to bug #1185122 as this is closed. It's better to avoid re-opening...

Peter Chibunna (peterchibunna) wrote :

I saw a fix somewhere I can't really recall. This involved modifying the facebook.provider file:
/usr/share/accounts/providers/facebook.provider

Add a line:
<setting name="AllowedSchemes" type="as">['https','http']</setting>
under the line:
<group name="user_agent">

Then you can restart gnome-shell or simply log out and back in.
IT worked for me.

To Do (entodoays) wrote :

This solution doesn't work for me.

alFReD NSH (faridn-soad) wrote :

Why is this closed? I see many people having this bug(including me).

Miroslav Hadzhiev (xtigyro) wrote :

Yep, me, too. :)

Jason Robinson (jaywink) wrote :

alFRed, Miroslav, please check #1180297 for reason this is closed. The fix has been published via -proposed and confirmed by several people.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers