Ubuntu

The online account g-c-c interface doesn't support i18n

Reported by Didier Roche on 2012-09-18
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Empathy
New
Undecided
Unassigned
Google Documents Lens
High
Alberto Mardegan
Gwibber
Undecided
Unassigned
Online Accounts: GNOME Control Center
High
David King
Photos Lens
High
David Callé
Shotwell
New
Undecided
Unassigned
Ubuntu Translations
High
Unassigned
empathy (Ubuntu)
High
Didier Roche
Quantal
High
Didier Roche
gnome-control-center-signon (Ubuntu)
High
David King
Quantal
High
David King
gwibber (Ubuntu)
High
Ken VanDine
Quantal
High
Ken VanDine
shotwell (Ubuntu)
High
Alberto Mardegan
Quantal
High
Alberto Mardegan
unity-lens-photos (Ubuntu)
High
David Callé
Quantal
High
David Callé
unity-scope-gdocs (Ubuntu)
High
Alberto Mardegan
Quantal
High
Alberto Mardegan

Bug Description

The online accounts UI loads the plugins integration from some .application files. Those are not translated, not translatable.

What needs to be done, is:
- rename the .application in .application.in
- ensuring that upstream have an application.in files with translatable tags (using _, as in <_description>I want to be translated</_description>). Example [1]
- add a <translations> tag containing the upstream domain
- then, at build time:

1. Running intltool-extract files.applications.in so that it gets merged into a files.applications.in.h file. If you are using intltool already in your build system (and you probably are), this should be happening already and you can skip to step 2.

2. Including the .in file somewhere in the build system (like po/POTFILES.in for Python apps and Makefiles.am for C/vala apps) so that it's merged into the .pot file. In Python, it's just a matter of adding it as an extra line to the po/POTFILES.in file (example [2]):

[type: gettext/xml]data/gwibber.application.in

3. And running intltool-merge --no-translations -x -u foo.applications.in foo.application to create the xml upstream file which is shipped
- online-account (the g-c-c plugin) should be patched to load them, looking at the <translations> tag and gettext (package, string)

[1] http://bazaar.launchpad.net/~dpm/+junk/testintl/view/head:/data/gwibber.application.in
[2] http://bazaar.launchpad.net/~dpm/+junk/testintl/view/head:/po/POTFILES.in

Didier Roche (didrocks) on 2012-09-18
summary: - The g-c-c interface doesn't support i18n
+ The online account g-c-c interface doesn't support i18n
Changed in shotwell (Ubuntu Quantal):
importance: Undecided → High
milestone: none → ubuntu-12.10-beta-2
status: New → Confirmed
Changed in unity-lens-photos (Ubuntu Quantal):
importance: Undecided → High
status: New → Confirmed
Changed in unity-scope-gdocs (Ubuntu Quantal):
importance: Undecided → High
status: New → Confirmed
Changed in gwibber (Ubuntu Quantal):
importance: Undecided → High
status: New → Confirmed
Changed in gnome-control-center-signon (Ubuntu Quantal):
importance: Undecided → High
status: New → Confirmed
Changed in empathy (Ubuntu Quantal):
importance: Undecided → High
status: New → Confirmed
David Planella (dpm) on 2012-09-18
description: updated
description: updated
Changed in ubuntu-translations:
importance: Undecided → High
status: New → Triaged
David King (amigadave) on 2012-09-18
Changed in online-accounts-gnome-control-center:
assignee: nobody → David King (amigadave)
milestone: none → 0.0.17
importance: Undecided → High
status: New → In Progress
Changed in gwibber (Ubuntu Quantal):
assignee: nobody → Ken VanDine (ken-vandine)
milestone: none → ubuntu-12.10-beta-2
Changed in gnome-control-center-signon (Ubuntu Quantal):
assignee: nobody → David King (amigadave)
milestone: none → ubuntu-12.10-beta-2
Changed in unity-lens-photos (Ubuntu Quantal):
assignee: nobody → David Callé (davidc3)
milestone: none → ubuntu-12.10-beta-2
Changed in unity-scope-gdocs (Ubuntu Quantal):
assignee: nobody → Alberto Mardegan (mardy)
milestone: none → ubuntu-12.10-beta-2
Changed in shotwell (Ubuntu Quantal):
assignee: nobody → Alberto Mardegan (mardy)
Changed in empathy (Ubuntu Quantal):
assignee: nobody → Ken VanDine (ken-vandine)
milestone: none → ubuntu-12.10-beta-2
Didier Roche (didrocks) on 2012-09-18
Changed in empathy (Ubuntu Quantal):
assignee: Ken VanDine (ken-vandine) → Didier Roche (didrocks)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package empathy - 3.5.92-0ubuntu2

---------------
empathy (3.5.92-0ubuntu2) quantal; urgency=low

  * debian/patches/git_fix_uoa_plugin_translation.patch:
    backport and adapt a fix so that the uoa g-c-c plugin is translated
    (LP: #1052375)
 -- Didier Roche <email address hidden> Tue, 18 Sep 2012 16:05:35 +0200

Changed in empathy (Ubuntu Quantal):
status: Confirmed → Fix Released
David Callé (davidc3) on 2012-09-18
Changed in unity-lens-photos:
assignee: nobody → David Callé (davidc3)
milestone: none → 0.5
importance: Undecided → High
status: New → In Progress
David Callé (davidc3) on 2012-09-18
Changed in unity-lens-photos:
milestone: 0.5 → none
status: In Progress → Fix Committed
Alberto Mardegan (mardy) on 2012-09-19
Changed in unity-lens-gdocs:
assignee: nobody → Alberto Mardegan (mardy)
status: New → In Progress
Alberto Mardegan (mardy) on 2012-09-19
Changed in unity-lens-gdocs:
status: In Progress → Fix Committed
David King (amigadave) on 2012-09-19
Changed in online-accounts-gnome-control-center:
status: In Progress → Fix Committed
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center-signon - 0.0.17-0ubuntu1

---------------
gnome-control-center-signon (0.0.17-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - Handle translated .application files (LP: #1052375)
 -- Ken VanDine <email address hidden> Wed, 19 Sep 2012 12:21:28 -0400

Changed in gnome-control-center-signon (Ubuntu Quantal):
status: Confirmed → Fix Released
David Callé (davidc3) on 2012-09-19
Changed in unity-lens-photos:
milestone: none → 0.6
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-lens-photos - 0.6-0ubuntu1

---------------
unity-lens-photos (0.6-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - The online account g-c-c interface doesn't support i18n (LP: #1052375)
    - Desktop file does not validate with desktop-file-validate (LP: #1051949)
    - Unity-lens-photo takes all cpu (LP: #1047739)
    - no pictures previews from dash (LP: #1049268)
    - unity-lens-photos crashed with TypeError in constructor(): Argument 0
      does not allow None as a value (LP: #1047754)
    - Older results from Shotwell are not correctly sorted when they contain
      photos without an exposure time (LP: #1049561)
    - Description of application should be ‘Photos search plugin’ (LP: #1050361)
    - Unity-lens-photo can only search one tag at a time (LP: #1047740)
 -- Ken VanDine <email address hidden> Wed, 19 Sep 2012 16:17:30 -0400

Changed in unity-lens-photos (Ubuntu Quantal):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-scope-gdocs - 0.3-0ubuntu1

---------------
unity-scope-gdocs (0.3-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - allow translating the .application file (LP: #1052375)
    - Dash duplicated in "Show accounts that integrate with" (LP: #1025583)
  * -debian/patches/desktop_file.patch
    - no longer needed
  * debian/source/include-binaries
    - add __pycache__/build_i18n_ext.cpython-32.pyc until we can figure out
      why dpkg is complaining about it
 -- Ken VanDine <email address hidden> Wed, 19 Sep 2012 16:57:30 -0400

Changed in unity-scope-gdocs (Ubuntu Quantal):
status: Confirmed → Fix Released
Changed in gwibber (Ubuntu Quantal):
status: Confirmed → Fix Committed
David Callé (davidc3) on 2012-09-20
Changed in unity-lens-photos:
status: Fix Committed → Fix Released
Didier Roche (didrocks) on 2012-09-20
Changed in gwibber (Ubuntu Quantal):
status: Fix Committed → Fix Released
David King (amigadave) on 2012-09-24
Changed in unity-lens-gdocs:
importance: Undecided → High
David King (amigadave) on 2012-09-24
Changed in unity-lens-gdocs:
milestone: none → 0.3
status: Fix Committed → Fix Released
Alberto Mardegan (mardy) on 2012-09-26
Changed in shotwell (Ubuntu Quantal):
status: Confirmed → Fix Released
David Planella (dpm) wrote :

This is not completely fixed in Shotwell. I've filed bug 1056698 as a follow-up.

David King (amigadave) on 2012-10-04
description: updated
Bilal Shahid (s9iper1) on 2012-10-16
Changed in gwibber:
status: New → Fix Released
David Planella (dpm) wrote :

Not sure if I should change the status or file new bugs, but this does not seem fixed on my system for Gwibber and Shotwell: their messages in the Online Accounts integration panel are still in English.

David Planella (dpm) wrote :

Tracked down what prevented translations from loading in Gwibber and filed follow-up bug 1068126

Hendrik Knackstedt (hennekn) wrote :

Seems to be fixed for all. Follow-ups are also Fix Released.

Changed in ubuntu-translations:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.