Proxy setting is not applied to Online Accounts (ex: Google)

Bug #1048590 reported by Hatem MASMOUDI on 2012-09-10
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Online Accounts: Sign-on UI
High
Alberto Mardegan
gnome-control-center-signon (Ubuntu)
Undecided
Unassigned
signon (Ubuntu)
Undecided
Unassigned
signon-ui (Ubuntu)
Undecided
Unassigned

Bug Description

1- Using Internet connection throught a proxy server.
2- Configure a google online account through Sytem Setting -> Online account
3- When trying to grant access tio ubuntu to google account the Autentification page is not loaded when I use Internet connection through Proxy
4- I using direct connection the Online Account is set correctly

==> How to configure Online Account for Google to use proxy server ? knowing that proxy server setting is set correctly through system setting -> Network setting -> Proxy...

Related branches

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1048590/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → gnome-control-center (Ubuntu)
Adolfo Jayme (fitojb) on 2012-09-12
affects: gnome-control-center (Ubuntu) → gnome-control-center-signon (Ubuntu)
David King (amigadave) on 2012-09-12
summary: - Proxy setting is no applied to Online Accountx (ex: Google)
+ Proxy setting is not applied to Online Accounts (ex: Google)
Alberto Mardegan (mardy) wrote :

Fixing this bug requires fixes in several components:
- signon-ui
- signond
Both of them need to use libproxy.
For signond, the upstream bug is http://code.google.com/p/accounts-sso/issues/detail?id=112

Alberto Mardegan (mardy) on 2012-09-17
Changed in online-accounts-signon-ui:
assignee: nobody → Alberto Mardegan (mardy)
status: New → Fix Committed
Alberto Mardegan (mardy) wrote :

Subscribing the Ubuntu Release Team, to know whether the fix for this needs a FFe.

IMHO, this is not a new feature; this fix is mainly a workaround for the missing support for proxy in Qt (see https://bugreports.qt-project.org/browse/QTBUG-26295) which affects just Linux (Qt supports proxies in Mac OS X and Windows already), and will be fixed in a future Qt version.
Our fix is actually mostly copied from the fix which has been already accepted in Qt itself.

Stéphane Graber (stgraber) wrote :

This sounds like a bugfix to me. As this seem to be cherry-picking code from upstream, I can't see any obvious problem with that.

Unsubscribing ubuntu-release. Feel free to subscribe us again if this bugfix evolves into something bigger.
Please make sure to upload any important fix before beta2 freeze.

Thanks

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package signon - 8.43-0ubuntu1

---------------
signon (8.43-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - Fixed proxy support (LP: #1048590)
  * debian/control
    - build depend on libproxy-dev
 -- Ken VanDine <email address hidden> Wed, 19 Sep 2012 15:03:25 -0400

Changed in signon (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package signon-ui - 0.10-0ubuntu1

---------------
signon-ui (0.10-0ubuntu1) quantal; urgency=low

  * New upstream release.
    - Fixed proxy support (LP: #1048590)
    - Don't emit an OSD notification when accounts fail to
      authenticate (LP: #1049140)
  * debian/control
    - build depend on libproxy-dev
 -- Ken VanDine <email address hidden> Wed, 19 Sep 2012 15:06:38 -0400

Changed in signon-ui (Ubuntu):
status: New → Fix Released
David King (amigadave) on 2012-09-24
Changed in online-accounts-signon-ui:
milestone: none → 0.10
importance: Undecided → High
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center-signon (Ubuntu):
status: New → Confirmed
David King (amigadave) on 2012-09-28
Changed in gnome-control-center-signon (Ubuntu):
status: Confirmed → Invalid
Z@bA (zaba-marcin) wrote :

How can I reopen this bug. For me, and I know that for other users, connection through proxy still doesn't work.
This doesn't work for me when I set automatic proxy configuration with proxy.pac file instead of manual proxy settings

Paolo (redsun82) wrote :

Using version 8.49 of signond here, and have the problem with automatic proxy. Changing to manual is not an option, the (corporate) proxy script is 153 lines long, as various corporate services need to be accessed directly. Do we need to open a new bug?

Alberto Mardegan (mardy) wrote :

Hi Paolo! Could you please try to set the proxy to manual (so that it can connect to a certain Online Account) and try creating an account of that type?
Knowing whether that works or not would help us understand where the problem could be.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.