Headerbar used as toolbars in unity are missing proper css classes

Bug #1689239 reported by Marco Trevisan (Treviño) on 2017-05-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME Software
Fix Released
Medium
Mahjongg
Expired
Medium
baobab (Ubuntu)
Medium
Marco Trevisan (Treviño)
eog (Ubuntu)
Medium
Unassigned
epiphany (Ubuntu)
Low
Unassigned
evince (Ubuntu)
High
Marco Trevisan (Treviño)
file-roller (Ubuntu)
Medium
Marco Trevisan (Treviño)
gnome-contacts (Ubuntu)
Medium
Marco Trevisan (Treviño)
gnome-mahjongg (Ubuntu)
Low
Unassigned
gnome-software (Ubuntu)
High
Marco Trevisan (Treviño)
nautilus (Ubuntu)
High
Marco Trevisan (Treviño)
ubuntu-themes (Ubuntu)
Medium
Marco Trevisan (Treviño)

Bug Description

In Nautilus, Gnome-Software, Gnome-Contacts, gnome-mahjongg the headerbar in unity is used as a toolbar, but without applying the proper .primary-toolbar class, which leads to make impossible to use Unity themes properly in other environments (as GS) as they try to apply a toolbar-like theme to any headerbar that is not a titlebar (which might be in cases such as gedit, where custom widgets are heavily used).

Related branches

Changed in nautilus (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in gnome-contacts (Ubuntu):
importance: High → Medium

The attachment "nautilus-headerbar-primary-toolbar-style-class.patch" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
affects: gnome-contacts → gnome-software
Changed in gnome-software (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in gnome-software:
importance: Unknown → Medium
status: Unknown → In Progress
description: updated
Changed in gnome-mahjongg (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in gnome-mahjongg:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in baobab (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in gnome-software:
status: In Progress → Fix Released
Khurshid Alam (khurshid-alam) wrote :

We, at Numix use light color for toolbar and dark color for titlebar and headerbar. This breaks our theme design and causes issues in contacts, nautilus.

Mh, I'm not sure I'm following...

These patches basically ensure that when an headerbar is used under unity as a toolbar it will be themed as a toolbar.
I don't see how this should break your theme; actually it should make it work properly, isn't it?

Jeremy Bicha (jbicha) wrote :

Other affected apps include eog, evince, file-roller and epiphany-browser.

Because Unity is not going to be our default desktop any more, the Ubuntu Desktop team doesn't have to fix these ourselves but it could make a nice bitesize task if someone else wants to get started in Ubuntu Desktop development or if someone else really cares about Unity 7.

tags: added: bitesize
Jeremy Bicha (jbicha) on 2017-05-10
Changed in nautilus (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nautilus - 1:3.24.1-0ubuntu3

---------------
nautilus (1:3.24.1-0ubuntu3) artful; urgency=medium

  * 0002-Only-use-a-header-bar-in-GNOME-shell.patch:
    - Use the primary-titlebar style class for headerbar in unity
      (LP: #1689239)

 -- Marco Trevisan <email address hidden> Fri, 05 May 2017 13:34:36 -0700

Changed in nautilus (Ubuntu):
status: Fix Committed → Fix Released
Changed in eog (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in evince (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in file-roller (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in epiphany (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in evince (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Triaged → In Progress
Changed in file-roller (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Triaged → In Progress
Changed in ubuntu-themes (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → Medium
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 16.10+17.10.20170518-0ubuntu1

---------------
ubuntu-themes (16.10+17.10.20170518-0ubuntu1) artful; urgency=medium

  * Ambiance, Radiance: handle .titlebar separator as headerbar one
  * Ambiance, Radiance: apply toolbar style to headerbars that are not
    child or are not .titlebar's (LP: #1689239)
  * Ambiance, Radiance: don't apply the toolbar style to headerbars or
    titlebars

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Thu, 18 May 2017 16:22:36 +0000

Changed in ubuntu-themes (Ubuntu):
status: In Progress → Fix Released
Jeremy Bicha (jbicha) wrote :

Marco, can we close this bug as obsolete now?

Changed in baobab (Ubuntu):
status: In Progress → Won't Fix
Changed in evince (Ubuntu):
status: In Progress → Won't Fix
Changed in file-roller (Ubuntu):
status: In Progress → Won't Fix
Changed in gnome-software (Ubuntu):
status: In Progress → Won't Fix
Changed in gnome-contacts (Ubuntu):
status: In Progress → Won't Fix
Jeremy Bicha (jbicha) on 2018-04-01
Changed in gnome-mahjongg (Ubuntu):
status: Triaged → Won't Fix
Changed in epiphany (Ubuntu):
status: Triaged → Won't Fix
Changed in eog (Ubuntu):
status: Triaged → Won't Fix
Changed in gnome-mahjongg:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.