gnome-contacts-search-provider crashed with signal 5 in contacts_ensure_eds_accounts()

Bug #1063019 reported by mezclatebrother! on 2012-10-06
52
This bug affects 6 people
Affects Status Importance Assigned to Milestone
GNOME Contacts
Fix Released
Medium
gnome-contacts (Ubuntu)
Medium
Unassigned
Trusty
Medium
Unassigned
Xenial
Medium
Unassigned

Bug Description

[Impact]
Annoying, unnecessary crash report pop up

[Test Case]
I don't really have a test case for this as I'm not sure how to trigger an EDS timeout.
Make sure the new version of gnome-contacts doesn't appear in the Errors bucket for this crash:
https://errors.ubuntu.com/bucket/?id=/usr/lib/gnome-contacts/gnome-contacts-search-provider%3A5%3Acontacts_ensure_eds_accounts%3Acontacts_search_provider_construct%3Acontacts_search_provider_new%3Acontacts_search_provider_app_real_dbus_register%3Ag_application_impl_attempt_primary

[Regression Potential]
The fix is a one-line upstream change to emit a warning instead of an error upon a timeout communicating with evolution-data-server.

The fix is part of gnome-contacts 3.20.0 so it's in yakkety and other GNOME 3.20 distros.

ProblemType: CrashDistroRelease: Ubuntu 12.10
Package: gnome-contacts 3.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-15.23-generic 3.5.4
Uname: Linux 3.5.0-15-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.6.1-0ubuntu1
Architecture: i386
Date: Sat Oct 6 21:43:49 2012
ExecutablePath: /usr/lib/gnome-contacts/gnome-contacts-search-provider
ProcCmdline: /usr/lib/gnome-contacts/gnome-contacts-search-provider
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANGUAGE=es_ES:en
 LANG=es_ES.UTF-8
Signal: 5SourcePackage: gnome-contacts
StacktraceTop:
 contacts_ensure_eds_accounts ()
 contacts_search_provider_construct ()
 contacts_search_provider_new ()
 ?? ()
 ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
Title: gnome-contacts-search-provider crashed with signal 5 in contacts_ensure_eds_accounts()
UpgradeStatus: Upgraded to quantal on 2011-10-28 (344 days ago)
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare

mezclatebrother! (prueboblog) wrote :

StacktraceTop:
 contacts_ensure_eds_accounts () at contacts-esd-setup.c:37
 contacts_search_provider_construct (object_type=148654296, app=app@entry=0x8dc0010) at contacts-shell-search-provider.c:273
 contacts_search_provider_new (app=app@entry=0x8dc0010) at contacts-shell-search-provider.c:292
 contacts_search_provider_app_real_dbus_register (base=0x8dc0010, connection=0x8dc2868, object_path=0x8dc47c0 "/org/gnome/Contacts/SearchProvider", error=0xbf98f0dc) at contacts-shell-search-provider.c:1290
 g_application_impl_attempt_primary (error=0xbf98f0dc, cancellable=0x0, impl=0x8dbee28) at /build/buildd/glib2.0-2.34.0/./gio/gapplicationimpl-dbus.c:275

Changed in gnome-contacts (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
tags: added: raring
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-contacts (Ubuntu):
status: New → Confirmed
tags: added: saucy
Jeremy Bicha (jbicha) on 2016-08-06
information type: Private → Public
Changed in gnome-contacts (Ubuntu):
status: Confirmed → Triaged
Changed in gnome-contacts (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Medium
Changed in gnome-contacts (Ubuntu):
status: Triaged → Fix Committed
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) wrote :

fixed in yakkety (-proposed) with 3.20 which includes the fix:

https://launchpad.net/ubuntu/+source/gnome-contacts/3.20.0-1ubuntu1

Jeremy Bicha (jbicha) on 2016-08-06
description: updated
Changed in gnome-contacts:
importance: Unknown → Medium
status: Unknown → Fix Released
Jeremy Bicha (jbicha) on 2016-08-07
Changed in gnome-contacts (Ubuntu Xenial):
status: Triaged → In Progress

Hello mezclatebrother!, or anyone else affected,

Accepted gnome-contacts into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-contacts/3.18.1-1ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

description: updated
Changed in gnome-contacts (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello mezclatebrother!, or anyone else affected,

Accepted gnome-contacts into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-contacts/3.8.3-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-contacts (Ubuntu Trusty):
status: New → Fix Committed
Changed in gnome-contacts (Ubuntu Trusty):
importance: Undecided → Medium
Jeremy Bicha (jbicha) wrote :

It has been a week and neither new version of gnome-contacts 3.8.3-1ubuntu1.1 or 3.18.1-1ubuntu3 shows up on the link in the test case. I'm going to go ahead and mark this verified then.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-contacts - 3.18.1-1ubuntu3

---------------
gnome-contacts (3.18.1-1ubuntu3) xenial; urgency=medium

  * Log a warning instead of a crash error when communication with
    evolution-data-server times out. Fix backported from 3.20 (LP: #1063019)

 -- Jeremy Bicha <email address hidden> Sat, 06 Aug 2016 18:15:57 -0400

Changed in gnome-contacts (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-contacts has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-contacts - 3.8.3-1ubuntu1.1

---------------
gnome-contacts (3.8.3-1ubuntu1.1) trusty; urgency=medium

   * Log a warning instead of a crash error when communication with
    evolution-data-server times out. Fix backported from 3.20 (LP: #1063019)

 -- Jeremy Bicha <email address hidden> Thu, 11 Aug 2016 17:51:05 -0400

Changed in gnome-contacts (Ubuntu Trusty):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.