gnome-contacts-search-provider crashed with signal 5 in g_variant_new_va()

Bug #1033262 reported by Gerhard Bogner on 2012-08-05
432
This bug affects 94 people
Affects Status Importance Assigned to Milestone
GNOME Contacts
Unknown
High
gnome-contacts (Ubuntu)
Medium
Unassigned
Raring
Medium
Unassigned
Saucy
Medium
Unassigned

Bug Description

[Impact]
 * gnome-contacts-search-provider regularly crashes.
 * This is caused by the bytestring_type.patch which is no longer required since vala 0.17.3 (see BGO: #679423)

[Testcase]
From gnome-shell overview
- Start with a short search that brings up a list of contacts results
- Wait a second and then add a letter to the search so there are no results
- gnome-contacts-search-provider will crash.

[Regression Potential]
None, the patch was originally added to fix a FTBS, it is no longer required.

== Original Report ==

ProblemType: CrashDistroRelease: Ubuntu 12.10
Package: gnome-contacts 3.5.4.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-8.8-generic 3.5.0
Uname: Linux 3.5.0-8-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.4-0ubuntu6
Architecture: amd64
Date: Sun Aug 5 20:37:47 2012
ExecutablePath: /usr/lib/gnome-contacts/gnome-contacts-search-providerInstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcCmdline: /usr/lib/gnome-contacts/gnome-contacts-search-providerSignal: 5SourcePackage: gnome-contacts
StacktraceTop:
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_variant_new_va () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_variant_new () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: gnome-contacts-search-provider crashed with signal 5 in g_variant_new_va()
UpgradeStatus: Upgraded to quantal on 2012-07-13 (23 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare users
XsessionErrors:
 gnome-session[2148]: WARNING: Failed to start app: Unable to start application: Failed to execute child process "gnome-power-manager" (No such file or directory)
 (process:2512): Gtk-WARNING **: Locale not supported by C library.

Related branches

Gerhard Bogner (bogi788) wrote :

StacktraceTop:
 g_variant_valist_new_nnp (str=0x7ffff864e758, ptr=0x0) at /build/buildd/glib2.0-2.33.6/./glib/gvariant.c:4051
 g_variant_valist_new_leaf (app=0x7ffff864e788, str=0x7ffff864e758) at /build/buildd/glib2.0-2.33.6/./glib/gvariant.c:4207
 g_variant_valist_new (str=str@entry=0x7ffff864e758, app=app@entry=0x7ffff864e788) at /build/buildd/glib2.0-2.33.6/./glib/gvariant.c:4389
 g_variant_valist_new (str=str@entry=0x7ffff864e758, app=app@entry=0x7ffff864e788) at /build/buildd/glib2.0-2.33.6/./glib/gvariant.c:4441
 g_variant_new_va (format_string=0x422e9a "ay)", endptr=0x0, app=0x7ffff864e788) at /build/buildd/glib2.0-2.33.6/./glib/gvariant.c:4598

Changed in gnome-contacts (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-contacts (Ubuntu):
status: New → Confirmed
tags: added: raring
tags: added: bugpattern-needed
Jeremy Bicha (jbicha) on 2013-03-30
information type: Private → Public
Changed in gnome-contacts:
importance: Unknown → High
status: Unknown → New
Osik (stefan-tollkuehn) wrote :

This also happens under 13.04 x64.

Tim Lunn (darkxst) wrote :

This is caused by the type change introduced by, bytestring_type.patch

From the changelog it seems that patch was added as a workaround for an introspection bug, hopefully that might have been fixed in the latest g-i.

Tim Lunn (darkxst) on 2013-06-07
description: updated
Tim Lunn (darkxst) on 2013-06-08
description: updated
Jeremy Bicha (jbicha) on 2013-06-08
Changed in gnome-contacts (Ubuntu Raring):
importance: Undecided → Medium
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-contacts - 3.8.2-0ubuntu2

---------------
gnome-contacts (3.8.2-0ubuntu2) saucy; urgency=low

  * debian/patches/bytestring_type.patch: Dropped, no longer needed
    (LP: #1033262)
 -- Tim Lunn <email address hidden> Fri, 07 Jun 2013 09:54:14 +1000

Changed in gnome-contacts (Ubuntu Saucy):
status: Confirmed → Fix Released
Changed in gnome-contacts:
status: New → Unknown
Jeremy Bicha (jbicha) wrote :

Uploaded to the Raring queue. The crash popups for this bug have been pretty annoying so I'm glad to see this is being fixed!

Changed in gnome-contacts (Ubuntu Raring):
status: Triaged → In Progress

Hello Gerhard, or anyone else affected,

Accepted gnome-contacts into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-contacts/3.6.2-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-contacts (Ubuntu Raring):
status: In Progress → Fix Committed
tags: added: verification-needed
Tim Lunn (darkxst) wrote :

Tested with updated package from -proposed, can no longer reproduce the crash using test case.

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-contacts - 3.6.2-0ubuntu2.1

---------------
gnome-contacts (3.6.2-0ubuntu2.1) raring; urgency=low

  * debian/patches/bytestring_type.patch: Dropped, no longer needed and
    causes the contacts search provider for GNOME Shell to crash (LP: #1033262)
 -- Tim Lunn <email address hidden> Fri, 07 Jun 2013 10:03:13 +1000

Changed in gnome-contacts (Ubuntu Raring):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.