Selection in tree view does not work as expected

Bug #373415 reported by Phil_fb on 2009-05-07
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Metacity
Invalid
Undecided
Unassigned
gnome-common (Ubuntu)
Undecided
Unassigned

Bug Description

Summary changed from: Multiple selection in list view with shift+mouseclick fails sometimes

Try this to reproduce the problem:

Remark: Set Desktops effects to "none" - I haven't been able to reproduce this with compiz enabled, so this may also be caused by metacity.

- Set Nautilus to list view
- navigate to a folder with some subdirectories in it
- select any subdirectory except for the first one (leftclick on the name, not the arrow)
- move the mouse to the line up to which you want to select
- do NOT move the mouse from now on
- press and hold shift
- left click

Instead of getting a multiple selection the first folder in the list expands (as if you had clicked on its' arrow)
If you watch carefully, you can see, that the instant you press shift, the arrow for the first directory becomes black. If you now move the mouse, the arrow returns to its previews state and you can click to get the desired multiple selection.

This behaviour becomes anoying, when you do lots of selections in quick succession for copying and just can't figure out why you sometimes get the selection and in other cases the first folder expands. I believe this has been there since hardy at least, but have only now found a way to reproduce it consistently.

Sebastien Bacher (seb128) wrote :

not a nautilus bug if compiz doesn't show the issue

affects: nautilus (Ubuntu) → ubuntu
Changed in metacity:
status: New → Invalid
Phil_fb (philbfb) on 2009-05-15
description: updated
tags: added: gnome nautilus select
summary: - Multiple selection in list view with shift+mouseclick fails sometimes
+ Selection in tree view does not work as expected
Phil_fb (philbfb) wrote :

The same bug appears in gconf-editor:

In the tree pane move the mouse to a folder with subfolders. Hit shift - the arrow on the root folder changes to black.
 (It stays black, even if you do not keep the shift key pressed.)

Now, move the mouse: the arrow reverts.
Or click without moving the mouse first: the whole tree collapses.

(I know, it makes no sense to do multiple selections in the tree pane, but is a way for me to check that the problem does not originate in nautilus)

I assume that this is caused by some underlying piece of code in gnome, as the problem appears in more than one application.

affects: ubuntu → gnome-common (Ubuntu)
Johannes (kakemphaton) wrote :

This is a very annoying bug if you happen to want to select files in Nautilus!

Phil_fb: your description is ok, except the last step:
- rightclick

Shouldn't it be
- left-click?

As an attachement, a screen capture of the problem (Theora).
I try to select a serie of files with shift + left-click, it just doesn't work.
Instead, the first folder in the list expands.

It happens VERY often.

Phil_fb (philbfb) on 2009-06-12
description: updated
Phil_fb (philbfb) wrote :

@Johannes

You are right! It is a left click.
Thanks for pointing this out and for adding the nice screen capture.

nemoinis (nemoinis) wrote :

Confirmed. It happens to me every time as long as it is in a newly created Nautilus window.
After a while, shift-clicking always in the same window, it stops happening, but it starts happening again if you change folder or start a new window.
This is using Jaunty.

Changed in gnome-common (Ubuntu):
status: New → Confirmed
nemoinis (nemoinis) wrote :

This does not happen anymore in Lucid 10.04.1 LTS with Nautilus 2.30.1-0ubuntu1.1

Changed in gnome-common (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers